Issue 119557 - [From Symphony] Column header can not be displayed correclty in AOO3.4 after open the xls file.
[From Symphony] Column header can not be displayed correclty in AOO3.4 after ...
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: ui
OOo 3.4 Beta
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 119486 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 05:55 UTC by binguo
Modified: 2012-12-26 08:45 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Sample file (18.50 KB, application/octet-stream)
2012-05-30 05:55 UTC, binguo
no flags Details
screenshot (41.02 KB, image/pjpeg)
2012-05-30 05:56 UTC, binguo
no flags Details
Patch for this bug (633 bytes, patch)
2012-06-13 11:16 UTC, Jianyuan Li
awf.aoo: review+
Details | Diff
UT sample files for this bug (9.77 KB, application/x-zip-compressed)
2012-06-13 11:17 UTC, Jianyuan Li
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description binguo 2012-05-30 05:55:46 UTC
Created attachment 77771 [details]
Sample file

Steps:
1.Launch AOO.
2.Open the sample file.
3.Click anywhere using mouse cursor in the sheet, such as A3.
4.Check column header.

Defet:
Column header can not be displayed correclty. (please refer to the screenshot.)

Sample File:
Yes

Screen Shot:
Yes
Comment 1 binguo 2012-05-30 05:56:17 UTC
Created attachment 77773 [details]
screenshot
Comment 2 Jianyuan Li 2012-06-13 03:17:11 UTC
I am investigating this issue
Comment 3 Jianyuan Li 2012-06-13 11:07:27 UTC
How to reproduce this issue:
1. Launch Excel 2003 and a default work book(window) will be created.
2. Select a cell and click "Windows->Freeze Panes". Then current sheet will be divided into several parts.
3. Click "Window->New Window". A new window will be created.
4. Save it as "Book1.xls".
5. Import "Book1.xls" in AOO.
Actual result:
Column/Row header can not be displayed correctly.
Comment 4 Jianyuan Li 2012-06-13 11:11:45 UTC
Root cause:
AOO only supports one window and the later created window will be imported. But a redundant "split" window property is imported. There is no "freeze" or "split" window property for the later created window. See "How to reproduce this issue" above.
Resolution:
Add a condition to ignore the redundant "split" window property when import.
Comment 5 Jianyuan Li 2012-06-13 11:16:00 UTC
Created attachment 78291 [details]
Patch for this bug

The patch just contains two lines modification
Comment 6 Jianyuan Li 2012-06-13 11:17:11 UTC
Created attachment 78292 [details]
UT sample files for this bug
Comment 7 Andre 2012-06-13 12:14:15 UTC
@Jianyuan Li: I am not a Calc expert, but Calc supports more than one window per document and more than one view per document.  Is that not sufficient to support the "split" property?

A new window can be created via the main menu Window->New Window.
The view can be split vertically or horizontally by dragging the black bars at the right of the horizontal scroll bar and at the top of the vertical scroll bar, respectively.
Comment 8 Jianyuan Li 2012-06-14 02:22:23 UTC
@Andre: Yes, Calc supports more than one window per document and more than one view per document. But those windows will be save into an individual document separately. One Calc document will save one window. While for Excel several windows will saved into one document.

So when import, only one window(the later created window) is imported due to the feature difference. But there is no "freeze" or "split" window property for the later created window. So here ignore the redundant property.

To confirm this, we can also create two windows in Excel and set "Freeze" property in the later created window. Import it in AOO. Still the later created window will be imported and there will be "Freeze" property in the imported window.

Any other comments please tell me. Thanks.
Comment 9 Terry Yang 2012-06-14 02:35:30 UTC
*** Issue 119486 has been marked as a duplicate of this issue. ***
Comment 10 Andre 2012-06-26 15:30:01 UTC
Comment on attachment 78291 [details]
Patch for this bug

Reviewed, tested, checked in.  
SVN revision is 1354063.
Comment 11 Andre 2012-06-26 15:30:19 UTC
Fixed.
Comment 12 Terry Yang 2012-08-20 02:49:08 UTC
Verify fixed on revision 1374181.
Comment 13 Terry Yang 2012-08-20 02:49:28 UTC
Close this bug