Issue 119545 - [From Symphony]The title text is not Italic in Studio design template like that in MS Office.
[From Symphony]The title text is not Italic in Studio design template like th...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
: 119542 119556 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 03:12 UTC by Du Jing
Modified: 2012-10-18 07:30 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (16.50 KB, application/vnd.ms-powerpoint)
2012-05-30 03:12 UTC, Du Jing
no flags Details
patch for ppt import title text italic attr lost (2.06 KB, patch)
2012-06-26 08:26 UTC, SunYing
awf.aoo: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-05-30 03:12:31 UTC
Created attachment 77753 [details]
sample file

build info:AOO3.4_1327774

Steps:
1.open the sample file in AOO3.4
2.check the title box font style

defect:
it is not italic like that in MS Office.
Comment 1 Li Feng Wang 2012-06-07 07:31:09 UTC
can reproduce with this build on Windows XP
Comment 2 SunYing 2012-06-26 08:04:25 UTC
I'm checking this defect and find the root cause:
AOO hasn't process the PPT_LAYOUT_TITLEMASTERSLIDE type layout for master page.
Comment 3 SunYing 2012-06-26 08:26:25 UTC
Created attachment 78485 [details]
patch for ppt import title text italic attr lost
Comment 4 SunYing 2012-06-26 08:27:14 UTC
solution:
add process for the PPT_LAYOUT_TITLEMASTERSLIDE type layout of master page
Comment 5 Armin Le Grand 2012-06-26 15:09:38 UTC
ALG: I am curious why that code was commented out in the original version. I tried to find information about it. It was commented out in cws ooxml03, but I could not get more information. It would be interesting why it was removed, so that we do not trigger something to show up again by this fix.
Comment 6 SunYing 2012-06-27 05:00:47 UTC
I tried to get more information for the commented out code, but I have not found  why code was commented out in the original version too.
Comment 7 Jianyuan Li 2012-07-09 02:10:33 UTC
Review and tested. The fix is OK.
Comment 8 SVN Robot 2012-07-09 13:59:08 UTC
"af" committed SVN revision 1359174: "#i119545# Fixed import of master page layout from PPT.          Reported"
Comment 9 Andre 2012-07-09 13:59:23 UTC
Comment on attachment 78485 [details]
patch for ppt import title text italic attr lost

Reviewed and tested: OK
Comment 10 Andre 2012-07-09 14:58:22 UTC
I have checked in the patch.  I see no reason to search any longer for the reason of some ancient changes.  If the fix breaks anything then we have to fix it.
Comment 11 Li Feng Wang 2012-08-20 07:56:44 UTC
Verified pass on Windows and Redhat with AOO trunk r1374181.
Comment 12 Li Feng Wang 2012-08-20 07:56:44 UTC
Verified pass on Windows and Redhat with AOO trunk r1374181.
Comment 13 Li Feng Wang 2012-08-20 07:56:44 UTC
Verified pass on Windows and Redhat with AOO trunk r1374181.
Comment 14 zjchen 2012-09-12 05:47:20 UTC
*** Issue 119542 has been marked as a duplicate of this issue. ***
Comment 15 Shenfeng Liu 2012-10-18 05:51:32 UTC
*** Issue 119556 has been marked as a duplicate of this issue. ***
Comment 16 Shenfeng Liu 2012-10-18 07:30:26 UTC
Update Target Milestone to AOO 3.5.0.