Issue 119535 - [From Symphony]Trendline of two Data Series can't be displayed but after edit it the trendline will be showed correctly
[From Symphony]Trendline of two Data Series can't be displayed but after edit...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: Jianyuan Li
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-30 02:27 UTC by Du Jing
Modified: 2012-12-26 08:30 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (72.50 KB, application/vnd.ms-powerpoint)
2012-05-30 02:27 UTC, Du Jing
no flags Details
Patch for this issue (1.63 KB, patch)
2012-08-07 11:36 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff
patch for win7 build break (1.34 KB, patch)
2012-08-17 08:43 UTC, Jianyuan Li
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-05-30 02:27:41 UTC
Created attachment 77743 [details]
sample file

build info:AOO3.4_1327774

steps:
1.open the sample file in AOO3.4
2.in chart object the two trend lines of two data series are lost.
Only after double clicking it to change to edit mode,then the trend line will be shown correctly.
Comment 1 Du Jing 2012-07-17 06:15:56 UTC
confirmed,change its status
Comment 2 Jianyuan Li 2012-08-06 03:12:16 UTC
Looking at this issue...
Comment 3 Jianyuan Li 2012-08-07 02:16:56 UTC
Root cause: Line brush command was not parsed in emf picture filter
Resolution: Resolve it
Limitation: Line style in sample file is not supported by aoo. So its line style will be imported as SOLID instead.
Comment 4 Jianyuan Li 2012-08-07 11:36:30 UTC
Created attachment 78871 [details]
Patch for this issue
Comment 5 SunYing 2012-08-14 09:19:10 UTC
The patch looks good and reviewed.
Comment 6 SVN Robot 2012-08-16 02:27:01 UTC
"lijiany" committed SVN revision 1373702 into trunk:
#119535# Fix WMF image with type pattern brushReported by: Du JingPatch by: J...
Comment 7 Jianyuan Li 2012-08-16 02:41:43 UTC
UT is made. The patch looks good.
Comment 8 Andre 2012-08-17 07:28:12 UTC
@Jianyuan Li: Reopening because the change breaks the build (Windows7, non-pro) in main/svtools/source/filter/wmf/enhwmf.cxx.  There are two problems:

1. On line 1318 a new variable aColor is introduced.  This is inside a switch/case statement.  Adding curly braces around the whole case will probably fix this.

2. There are now two case statements for EMR_CREATEDIBPATTERNBRUSHPT.  One in the new code, the other inside the following #ifdef WIN_MTF_ASSERT block.  Removing the second case statement will probably fix this.
Comment 9 Jianyuan Li 2012-08-17 08:00:58 UTC
@Andre:
Sorry for the break.
I have a try in Win7 with cygwin with this patch. No break happened. So can you tell me what you do when build(configure parameter...)?
Comment 10 Jianyuan Li 2012-08-17 08:43:21 UTC
Created attachment 78991 [details]
patch for win7 build break
Comment 11 Jianyuan Li 2012-08-17 08:44:30 UTC
The possible issues has been patched.
Comment 12 Andre 2012-08-17 09:06:04 UTC
@Jianyuan Li: Don't worry about the build break.  If you don't cause a build break now and then, the you don't work hard enough :-)

Your patch works and looks good. svtools is compilable again.  Please go ahead and commit it.

I can reproduce both problems on Windows 7 and cygwin with non-pro build.
Comment 13 Jianyuan Li 2012-08-17 09:12:00 UTC
Comitted in Revision: 1374181
Comment 14 Jianyuan Li 2012-08-17 09:14:47 UTC
Win7 build break issue has been fixed
Comment 15 Li Feng Wang 2012-08-21 05:23:17 UTC
Verified pass with AOO trunk r1374181.