Issue 119525 - AOo doesn't work with Java 1.7 on Windows
AOo doesn't work with Java 1.7 on Windows
Status: CLOSED FIXED
Product: General
Classification: Code
Component: ui
3.4.0
PC Windows 7
: P3 major (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
:
: 119993 120046 120275 120455 120729 121250 121515 121551 121558 121621 121770 (view as issue list)
Depends on: 120979
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 13:16 UTC by vulcain
Modified: 2013-07-21 10:11 UTC (History)
18 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---
jsc: 3.4.1_release_blocker-


Attachments
Error Message in french: Java is not Found (10.56 KB, image/png)
2012-05-29 13:16 UTC, vulcain
no flags Details
Java configuration in Windows 'parameter (19.75 KB, image/png)
2012-06-13 21:56 UTC, vulcain
no flags Details
Java configuration in AOO (254.65 KB, image/png)
2012-06-13 21:56 UTC, vulcain
no flags Details
AOO on WIndows 7 64 bits with a working JRE Java 1.7.0_05 (latest version) (59.38 KB, image/png)
2012-06-16 20:19 UTC, Ariel Constenla-Haile
no flags Details
AOO 3.4.0 in Windows 7 64 bits with Java 7 Update 5 (228.18 KB, image/png)
2012-06-17 23:55 UTC, Ariel Constenla-Haile
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description vulcain 2012-05-29 13:16:32 UTC
Created attachment 77737 [details]
Error Message in french: Java is not Found

After install, the new version of Java, found here: www.java.com (Java 7 Update 4). I make a fresh install of AOo 3.4 (AOO340m1(build:9590) - Rev 1327774) on Window 8 Prewiew Consummer x86_64
I see that Java i reconnize in Tools -> Options -> OpenOffice.org-> Java: i could see Java 1.7_4

But, when i launch Base and create new base, i have some error message who means, that Java is not found.

Expected: Java 1.7 work correctly in AOo 3.4
Comment 1 Du Jing 2012-06-13 05:27:40 UTC
i can confirm and reproduce on Win7 32bit
Comment 2 Olaf Felka 2012-06-13 08:38:25 UTC
If JRE7 is displayed at tools options it should work in every case. I suggsr this as a 3.4.1 blocker.
Comment 3 jsc 2012-06-13 13:19:47 UTC
please try to add "-d32" JVM option under Tools -> Options -> Java
Comment 4 vulcain 2012-06-13 21:56:05 UTC
Created attachment 78301 [details]
Java configuration in Windows 'parameter
Comment 5 vulcain 2012-06-13 21:56:50 UTC
Created attachment 78302 [details]
Java configuration in AOO
Comment 6 vulcain 2012-06-13 22:01:13 UTC
@ jsc@apache.org
Could you explain?? In which programs ?

I don't find it in Java or in AOO.

It's in AOO menu -> Tool -> OpenOffice.org -> Java i have 3 choice: Add, Parameters and Class Path. If i go in Parameters and write in Java Starter Parameters: "-d32" It's don't work. (see Java configuration in AOo)

Or may be it's in Java's configuration ??
I go in windows's configuration, i check Java, i click. I have this windows (see java configuration) but could not find where i write your "-d32"

Please, explain.
Comment 7 Ariel Constenla-Haile 2012-06-13 22:28:12 UTC
(In reply to comment #5)
> Created attachment 78302 [details]
> Java configuration in AOO

Did you install a 32 bits Java or a 64 bits Java?
Looking at the program folder on your screenshot, isn't this the path for 32 bits applications on Windows 64 bits?

C:\Program Files (x86)\
Comment 8 vulcain 2012-06-13 23:52:36 UTC
(In reply to comment #7)
> (In reply to comment #5)
> > Created attachment 78302 [details]
> > Java configuration in AOO
> 
> Did you install a 32 bits Java or a 64 bits Java?
> Looking at the program folder on your screenshot, isn't this the path for 32
> bits applications on Windows 64 bits?
> 
> C:\Program Files (x86)\

I take what https://www.java.com give. 
I uninstall java, delete all java's file in user's profil. After i go to https://www.java.com/en/download/manual.jsp
and install jre-7u5-windows-x64 who create a C:\Program Files\Java => LiBO don't recognize Java. It's logic if you read https://www.java.com/en/download/faq/java_win64bit.xml : LibO is in 32 bits.
I uninstall Java and install jre-7u5-windows-i586 who create C:\Program Files (x86)\java => LibO recognize Java but i have the same error message and Base don't wok.
Comment 9 Ariel Constenla-Haile 2012-06-14 00:07:04 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > (In reply to comment #5)
> > > Created attachment 78302 [details]
> > > Java configuration in AOO
> > 
> > Did you install a 32 bits Java or a 64 bits Java?
> > Looking at the program folder on your screenshot, isn't this the path for 32
> > bits applications on Windows 64 bits?
> > 
> > C:\Program Files (x86)\
> 
> I take what https://www.java.com give. 
> I uninstall java, delete all java's file in user's profil. After i go to
> https://www.java.com/en/download/manual.jsp
> and install jre-7u5-windows-x64 who create a C:\Program Files\Java => LiBO
> don't recognize Java. It's logic if you read
> https://www.java.com/en/download/faq/java_win64bit.xml : LibO is in 32 bits.
> I uninstall Java and install jre-7u5-windows-i586 who create C:\Program
> Files (x86)\java => LibO recognize Java but i have the same error message
> and Base don't wok.

That was what I guessed, from the program path: 

C:\Program Files (x86)\ <--- 32 bits
C:\Program Files\       <--- 64 bits

So, you already *have* a 32 bits Java on C:\Program Files (x86)\java
This means, you don't need the -d32 switch.


With this 32 bits Java selected on Tools - Options - OOo - Java, could you make other Java related stuff run? Did you try with any of the wizards?
For example:

Menu "File" - "Wizards" - "Letter..." or "Fax..." or "Agenda..."

All these wizards require Java.
Do they work with your Java from C:\Program Files (x86)\java ?

If they work, then the issue is with Base.
Please try, and let us know.
Comment 10 vulcain 2012-06-14 08:03:52 UTC
(In reply to comment #9)
> With this 32 bits Java selected on Tools - Options - OOo - Java, could you
> make other Java related stuff run? Did you try with any of the wizards?
> For example:
> 
> Menu "File" - "Wizards" - "Letter..." or "Fax..." or "Agenda..."
> 
> All these wizards require Java.
> Do they work with your Java from C:\Program Files (x86)\java ?
> 
> If they work, then the issue is with Base.
> Please try, and let us know.

I try Menu -> File -> Wizard -> Letter or Fax or Agenda, i have the same error message like in attachment 77737 [details]: Java is not Found
Comment 11 Ariel Constenla-Haile 2012-06-16 20:04:46 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > With this 32 bits Java selected on Tools - Options - OOo - Java, could you
> > make other Java related stuff run? Did you try with any of the wizards?
> > For example:
> > 
> > Menu "File" - "Wizards" - "Letter..." or "Fax..." or "Agenda..."
> > 
> > All these wizards require Java.
> > Do they work with your Java from C:\Program Files (x86)\java ?
> > 
> > If they work, then the issue is with Base.
> > Please try, and let us know.
> 
> I try Menu -> File -> Wizard -> Letter or Fax or Agenda, i have the same
> error message like in attachment 77737 [details]: Java is not Found

Quite strange. I've just tried in Windows 7, 64 bits, with AOO and latest Java 1.7.5 32 bits, and both the wizards and Base work.

Can a developer working on windows 7 please try to verify this?
Thanks.
Comment 12 Ariel Constenla-Haile 2012-06-16 20:19:29 UTC
Created attachment 78348 [details]
AOO on WIndows 7 64 bits with a working JRE Java 1.7.0_05 (latest version)

Both wizards and Base work with Java 32 bits 1.7.0_05 (latest version)
Comment 13 vulcain 2012-06-16 23:38:19 UTC
(In reply to comment #0)
> Created attachment 77737 [details]
> Error Message in french: Java is not Found
> 
> After install, the new version of Java, found here: www.java.com (Java 7
> Update 4). I make a fresh install of AOo 3.4 (AOO340m1(build:9590) - Rev
> 1327774) on Window 8 Prewiew Consummer x86_64
> I see that Java i reconnize in Tools -> Options -> OpenOffice.org-> Java: i
> could see Java 1.7_4
> 
> But, when i launch Base and create new base, i have some error message who
> means, that Java is not found.
> 
> Expected: Java 1.7 work correctly in AOo 3.4

In your screenshot you have 4 version of java.It's too much. You should delete one of 1.6.0_30 (why have you two line with 1.6.0_30 ??) and 1.7.0_02.

May be wizard and base work in your PC because you have 1.6.0_30 and 1.7.0 ??
Uninstall all java programs and install only java 1.7 and try to launch wizard and base
Comment 14 Ariel Constenla-Haile 2012-06-16 23:42:29 UTC
(In reply to comment #13)
> (In reply to comment #0)
> > Created attachment 77737 [details]
> > Error Message in french: Java is not Found
> > 
> > After install, the new version of Java, found here: www.java.com (Java 7
> > Update 4). I make a fresh install of AOo 3.4 (AOO340m1(build:9590) - Rev
> > 1327774) on Window 8 Prewiew Consummer x86_64
> > I see that Java i reconnize in Tools -> Options -> OpenOffice.org-> Java: i
> > could see Java 1.7_4
> > 
> > But, when i launch Base and create new base, i have some error message who
> > means, that Java is not found.
> > 
> > Expected: Java 1.7 work correctly in AOo 3.4
> 
> In your screenshot you have 4 version of java.It's too much. You should
> delete one of 1.6.0_30 (why have you two line with 1.6.0_30 ??) and 1.7.0_02.

in order to test things reported in bugs :) I even have a JRockit!

> May be wizard and base work in your PC because you have 1.6.0_30 and 1.7.0 ??
> Uninstall all java programs and install only java 1.7 and try to launch
> wizard and base

I checked the only Java process running was the Java 7.
Any way, tomorrow I'll try uninstalling all versions, just to make you happy :)
Comment 15 Ariel Constenla-Haile 2012-06-17 23:55:04 UTC
Created attachment 78362 [details]
AOO 3.4.0 in Windows 7 64 bits with Java 7 Update 5

Tested the following:

- removing every Java version, leaving only Java 7 u5 32 and 64 bits
- remove also Java 7 u5 64 bits

In both cases, the wizards and Base work fine.
Comment 16 louqle 2012-06-19 06:22:42 UTC
it works for me on Windows 7 32 bits with JRE 1.7.0_05
Comment 17 vulcain 2012-06-19 10:57:07 UTC
Stange, 

Another guy in french forum have the same problem like me in windows 7:
http://user.services.openoffice.org/fr/forum/viewtopic.php?p=187934#p187934
Comment 18 Ariel Constenla-Haile 2012-06-19 12:51:06 UTC
(In reply to comment #17)
> Stange, 
> 
> Another guy in french forum have the same problem like me in windows 7:
> http://user.services.openoffice.org/fr/forum/viewtopic.php?p=187934#p187934

Please note:

"Je t'invite à voter car si il y a plus de personnes qui se disent touchées par le bogue, les développeurs se sentiront concernés."

Developers cannot fix something they cannot reproduce, it is something logical.
Comment 19 vulcain 2012-06-19 12:59:01 UTC
I write this before you come and bjdujing@gmail.com confirmed this bug (the other guys in french's forum, too now).
Comment 20 Ariel Constenla-Haile 2012-06-19 13:41:35 UTC
Bug 119993 might be a duplicated
Comment 21 Ariel Constenla-Haile 2012-06-20 18:58:08 UTC
*** Issue 120046 has been marked as a duplicate of this issue. ***
Comment 22 nestoribio 2012-06-22 19:25:47 UTC
After several hours back and fourth I finally found that was the installed extensions the culprits.
To solve java related issues remove extensions one by one until you find the culprit one or ones.

Maybe it is easier to say than to implement it, but extensions should not crash the main program, no matter how bad they behave: they should crash by themselves and let users know what is going on.

NB
Comment 23 Olaf Felka 2012-06-23 09:47:30 UTC
(In reply to comment #22)
> After several hours back and fourth I finally found that was the installed
> extensions the culprits.
> To solve java related issues remove extensions one by one until you find the
> culprit one or ones.
Can you give aus a hint which extension causes trouble?
Comment 24 jsc 2012-06-27 07:09:17 UTC
I think this issue becomes invalid and we can't reproduce the Java 7 issue.

The root cause of the problem here is an extension that is not under our control.

I mark this issue invalid and close it.
Comment 25 jsc 2012-06-27 07:09:40 UTC
closed
Comment 26 vulcain 2012-06-27 08:40:56 UTC
Could you give the extension who give the problem ??

In typical french's install there are two extensions:
- Dictionnary French 4.2 by Dicollecte
- Presentation Mimizer 1.1.0 by Apache Software fondation ( not under your control ??)

If i remove this two extensions, the problem keep :-(
with delet C:\Users\user\AppData\Roaming\OpenOffice.org or not.

I try to install english's version (after delet C:\Users\user\AppData\Roaming\OpenOffice.org):
http://sourceforge.net/projects/openofficeorg.mirror/files/stable/3.4.0/Apache_OpenOffice_incubating_3.4.0_Win_x86_install_en-US.exe/download

With typical install, if i launch wizard, i have the same problems ...
If i delet all this extensions:
- Americans Englsih Spell 1.0 by Mini-Geek
- Australian English Spell and Hyphenation dictionaries and thesaurus 2008.12 1.5 by  ??
- Canadian English Spell and Hyphenation dictionaries and thesaurus 2.0.0 by DaveD
- English Spell and Hyphenation dictionaries and thesaurus 2010.03.16 by  ???
- New Zealand Canadian English Spell and Hyphenation dictionaries and thesaurus 2008.10.3 by ??
- Presentation Mimizer 1.1.0 by Apache Software fondation

I have always the error message.

If it's not under your control, who choose the extension will be inclued in setup's programm ??

I don't think extension is the origin of the problem.
Comment 27 jsc 2012-06-27 09:02:02 UTC
can anybody provide info which extension caused a problem here. Otherwise we can't do anything because the problem can't be reproduced.

You can try to rename your user directory and create a new one from scratch when you restart the office. Just to test if there is a problem with your user directory. You can switch back to your original user directory afterwards
Comment 28 jsc 2012-06-27 09:02:51 UTC
until we have more information it is no showstopper for 3.4.1
Comment 29 vulcain 2012-06-27 09:42:22 UTC
(In reply to comment #27)
> can anybody provide info which extension caused a problem here. Otherwise we
> can't do anything because the problem can't be reproduced.
I give you a list of the extensions i have, and as you can see if i delet them or not the problem is always here.

> 
> You can try to rename your user directory and create a new one from scratch
> when you restart the office. Just to test if there is a problem with your
> user directory. You can switch back to your original user directory
> afterwards
I delet C:\Users\user\AppData\Roaming\OpenOffice.org -> always the problem
I create a new user -> always the problem
What do you want ??
Comment 30 vulcain 2012-06-27 10:24:50 UTC
I delet C:\Users\user\AppData\LocalLow\Sun, uninstall java 1.7, delet C:\ProgramData\Sun. Delet C:\Users\user\AppData\Roaming\OpenOffice.org make a new install of java 1.7 with jre-7u5-windows-i586 and administrator's right.

I always have the same message
Comment 31 vulcain 2012-06-30 17:11:08 UTC
Don't works with OOo-dev 3.4.1 Build:9591 Rev 1351960
Comment 32 Jeff 2012-07-01 17:09:35 UTC
I am new to OpenOffice, but I am having the same problem described here with two new fresh installations of OO 3.4.0.  They are different computers, both Win7 64 bit.  If I have Java 1.6 installed, they both work fine.  If I upgrade Java to 1.7 (latest version, 32 or 64 bit), I get the same Java error described in this bug string.  I can easily downgrade back to Java 1.6 and OO begins working again with no Java error message.  Upgrade again and it breaks again.

The error includes the problems described with Base as well as the Wizards.
Comment 33 vulcain 2012-07-07 07:19:56 UTC
May be the same as this one: https://bugs.freedesktop.org/show_bug.cgi?id=50371
I try to follow the comment 15, but hardiest for me.

I think only x86_64 are affected.
Comment 34 nestoribio 2012-07-07 21:02:21 UTC
I really do not understand anything!
I am running AOo on a Windows XP SP3 (32bits) virtual machine; VirtualBox (up to date) and hosted on a Windows 7 Ultimate 64 bits installed on an amd E350 laptop (amd64?).
As I commented on a previous post, after uninstalling all extensions, AOo 3.4 start working again.
I had previously uninstalled all java versions, cleaned file system and registry (as deep as I can), downloaded and installed again jre 1.7 unsuccessfully...
I was very busy at that time, now somewhat with more time. last night I reinstalled all extensions again, one by one, trying to find some culprit and... surprise! Everything works!

But what really quizzes me is the fact that no other program noticed the many changes and cleaning I did, at least the ones I used more frequently... The list could be quite large.

Quizzed
NB
Comment 35 Olaf Felka 2012-08-04 09:47:48 UTC
*** Issue 120455 has been marked as a duplicate of this issue. ***
Comment 36 silstarl1 2012-08-20 02:19:54 UTC
I've also had similar problems with Java 1.7 versions and OOo 3.4 on Windows 7 64 bit. Tried using both the 32 bit and 64 bit Java 1.7 versions, but neither worked proberly. OOo didn't even recognize the 64 bit version. With the 32 bit version I got error messages, such as "OpenOffice.org requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective." and Wizards wouldn't work. Tried uninstalling and re-installing both the Java and OOo programs, but these efforts didn't fix anything. Uninstalling Java 1.7 and going back to the latest Java 1.6 version did solve the problem.
Comment 37 Ariel Constenla-Haile 2012-09-15 14:10:38 UTC
*** Issue 119993 has been marked as a duplicate of this issue. ***
Comment 38 Ariel Constenla-Haile 2012-09-15 14:17:31 UTC
The problem was discovered by a user. Please see http://markmail.org/thread/axfeyzyux66sz37h

The solution is to install the Microsoft Visual C++ 2010 Redistributable Package
http://download.microsoft.com/download/5/B/C/5BC5DBB3-652D-4DCE-B14A-475AB85EEF6E/vcredist_x86.exe
Comment 39 nestoribio 2012-09-18 02:22:56 UTC
Nice to hear that the issue was finally solved.

I wonder why I had to go to Markmail to read the details.
Besides the error shown by AOO was misleading and it was in part why it took so long to solve it.

I fully agree with jsmi...@fastmail.fm and his points.
Java and VS updates should be done, if possible, automatic.
And yes, software should work just downloaded and should continue working as updates come and go.

A second wonder; could java be avoided in future versions of AOO?
Or it is so deeply entangled on the suite's code it is just impossible...
That is because just following Oracle's moves makes me wonder... nothing about java in specific but Oracle's doing...
Comment 40 Ariel Constenla-Haile 2012-09-18 08:58:26 UTC
(In reply to comment #39)
> Nice to hear that the issue was finally solved.
> 
> I wonder why I had to go to Markmail to read the details.

This is just a bug report :)

> Besides the error shown by AOO was misleading and it was in part why it took
> so long to solve it.

Technical explanation (for the record):
The misleading part is AOO lists under Tools - Options - Java,  JREs that do not work.

* it detects the JRE paths in the Windows registry
* it calls java.exe to get the properties
* if this call does not fail, and the Java virtual machine can be located, then this JRE is added in the Options dialog

The problem is that while calling java.exe works, and the JVM library is there, at the moment of using the JVM AOO tries to load the JVM library and it fails to do so because of the missing VS C++ 2010 redist (Java 7 is built with VS C++ 2010, but Oracle does not include the redis. in its installation).

An enhancement to make the User Experience better would be to only list in the Options dialog does JRE where the JVM library can actually be loaded.

 
> A second wonder; could java be avoided in future versions of AOO?
> Or it is so deeply entangled on the suite's code it is just impossible...
> That is because just following Oracle's moves makes me wonder... nothing
> about java in specific but Oracle's doing...

It is possible, but someone has to do it; that is, write the code ;)
IMHO writing the Wizards in Java was a bad a design choice.
Also, the Online Help uses Apache Lucene in the background. There is a C++ implementation called CLucene, which has dual license (LGPL and ALv2).
Comment 41 Ariel Constenla-Haile 2012-09-18 09:04:10 UTC
Added dependency to bug 120979
Comment 42 Ariel Constenla-Haile 2012-09-23 04:03:25 UTC
Please verify with http://people.apache.org/~arielch/packages/r1388877/win/Apache_OpenOffice_incubating-Dev_AOO350m1_Win_x86_install_en-US.exe
It installs as OOo-Dev, it will not override your current installation.
Comment 43 Ariel Constenla-Haile 2012-11-05 20:37:16 UTC
*** Issue 121250 has been marked as a duplicate of this issue. ***
Comment 44 Li Feng Wang 2012-11-08 06:16:46 UTC
Verified pass on windows 32bit and 64bit with trunk r1404513.

On windows7 32bit and 64bit all have JDK1.7 32bit to ensure AOO can work with JDK1.7.
Comment 45 Ariel Constenla-Haile 2012-11-15 12:31:28 UTC
*** Issue 120729 has been marked as a duplicate of this issue. ***
Comment 46 Ariel Constenla-Haile 2012-12-15 16:49:54 UTC
*** Issue 120275 has been marked as a duplicate of this issue. ***
Comment 47 Ariel Constenla-Haile 2012-12-20 01:14:59 UTC
*** Issue 121515 has been marked as a duplicate of this issue. ***
Comment 48 Ariel Constenla-Haile 2012-12-27 20:02:16 UTC
*** Issue 121551 has been marked as a duplicate of this issue. ***
Comment 49 Alex Seggie 2012-12-29 17:41:11 UTC
You said: "An enhancement to make the User Experience better would be to only list in the Options dialog does JRE where the JVM library can actually be loaded."

Would it not be even better to let the user know that that the problem is the missing run-time library? ie "The following versions of Java were located but they may not load correctly unless ..."

Alex
Comment 50 Ariel Constenla-Haile 2012-12-30 00:27:55 UTC
*** Issue 121558 has been marked as a duplicate of this issue. ***
Comment 51 Ariel Constenla-Haile 2013-01-14 15:14:59 UTC
*** Issue 121621 has been marked as a duplicate of this issue. ***
Comment 52 Ariel Constenla-Haile 2013-02-14 03:34:25 UTC
*** Issue 121770 has been marked as a duplicate of this issue. ***