Issue 119524 - [From Symphony]Can not open the sample ppt file which contain vb controls in the slide master.
[From Symphony]Can not open the sample ppt file which contain vb controls in ...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: WangZhe
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 09:51 UTC by Du Jing
Modified: 2012-10-18 07:21 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (76.00 KB, application/vnd.ms-powerpoint)
2012-05-29 09:51 UTC, Du Jing
no flags Details
Fix patch for this issue (452 bytes, patch)
2012-08-24 02:46 UTC, Steve Yin
steve.yin.aoo: review?
steve.yin.aoo: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-05-29 09:51:55 UTC
Created attachment 77734 [details]
sample file

build:AOO3.4_1327774

STEPS:
1.Open the sample in AOO
2.open the sample in MS Office 2003,switch to master view,will find some controls in second master page


defect:
AOO will crash
Comment 1 Du Jing 2012-07-17 06:16:10 UTC
confirmed,change its status
Comment 2 Steve Yin 2012-08-24 02:46:22 UTC
Created attachment 79109 [details]
Fix patch for this issue

Please help to review the patch.

Root Cause:
There are several OLE objects in the master pages of the sample file. When importing OLE objects, it will call UNO interface SdXImpressDocument::getMasterPages(). In this function, it calls initializeDocument(). Once there is no page, it will create a page for the document. But in this case, the pages are not created when importing master pages.

Resolution:
Do NOT call initializeDocument() when loading. Use hasControllersLocked() for the conditional statement.
Comment 3 WangZhe 2012-09-07 02:42:00 UTC
I'll take this one
Comment 4 WangZhe 2012-09-07 03:13:11 UTC
Delivered at revision: 1381847

   * subversion/main/sd/source/ui/unoidl/unomodel.cxx
     []Before initializeDocument,should check whether it is in loading process
Comment 5 louqle 2012-09-18 02:39:59 UTC
verified on XP SP3, mac 10.8, Ubuntu 12.04 against build r1384699

verified on RHEL 6.1 64 bit against build 1386464

fixed. Close thid bug
Comment 6 Shenfeng Liu 2012-10-18 07:21:41 UTC
Update Target Milestone to AOO 3.5.0.