Issue 119523 - [From Symphony]The line indent change after save once by AOO
[From Symphony]The line indent change after save once by AOO
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: editing
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 09:15 UTC by liuping
Modified: 2012-12-26 08:38 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (120.50 KB, application/vnd.ms-powerpoint)
2012-05-29 09:15 UTC, liuping
no flags Details
Capture.PNG (476.31 KB, image/png)
2012-05-29 09:17 UTC, liuping
no flags Details
patch for import and export leftmargin and indent (3.21 KB, patch)
2012-08-07 06:28 UTC, SunYing
sunyingshadesun: review?
Details | Diff
UT file (141.00 KB, application/vnd.ms-powerpoint)
2012-08-07 06:28 UTC, SunYing
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-05-29 09:15:37 UTC
Created attachment 77732 [details]
sample file

Build: AOO3.4 rev 1327774


Description:

1. Launch AOO then open the attached sample file.
2. Select "Viwer->RulerS" to show horizontal/vertical ruler.
3. Set the 1st paragraph line indent at "5" on horizontal ruler.
4. Save as a new .ppt 
5. Reopen the new .ppt and check the line indent of 2nd paragraph.

Actual Result:The line indent of 2nd paragraph is at "5" on horizontal ruler yet.

Expect Result:The line indent of 2nd paragraph is at "4" on horizontal ruler.
Comment 1 liuping 2012-05-29 09:17:34 UTC
Created attachment 77733 [details]
Capture.PNG
Comment 2 Du Jing 2012-07-17 06:16:18 UTC
confirmed,change its status
Comment 3 SunYing 2012-08-07 03:10:11 UTC
 root cause:
 the paragrah of indent and leftmargin attribute didn't exported and imported.
Comment 4 SunYing 2012-08-07 06:28:04 UTC
Created attachment 78866 [details]
patch for import and export leftmargin and indent

 solution:
 save the indent and leftmargin attribute when export.
 read the indent and leftmargin attribute when import.
Comment 5 SunYing 2012-08-07 06:28:52 UTC
Created attachment 78867 [details]
UT file
Comment 6 Jianyuan Li 2012-08-14 08:44:12 UTC
Reviewed and looks good.
Comment 7 SVN Robot 2012-08-16 05:21:10 UTC
"sunying" committed SVN revision 1373731 into trunk:
#119523# fix the indent and left margin attribute lost when save .ppt file an...
Comment 8 sunying 2012-08-20 01:51:39 UTC
has been fixed
Comment 9 louqle 2012-08-24 04:30:29 UTC
verified on Ubuntu 12.04, XP SP3, Vista, Win7, Win7 64-bit, Suse 11 SP1, Redhat 6.1, Mac 10.7 against build 1376366,

SLED 11 SP1 64 bit against build 1376353

Pass. Close this bug