Issue 119520 - [From Symphony]the right brace shape cannot display after save the sample .odt file to .doc file then reopen in aoo
[From Symphony]the right brace shape cannot display after save the sample .od...
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 08:59 UTC by louqle
Modified: 2012-10-18 06:28 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
odt file with right brace shape (14.43 KB, application/vnd.oasis.opendocument.text)
2012-05-29 08:59 UTC, louqle
no flags Details
Patch for this issue (7.56 KB, patch)
2012-08-22 08:06 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description louqle 2012-05-29 08:59:22 UTC
Created attachment 77729 [details]
odt file with right brace shape

1. open the test.odt file in Aoo 3.4
2. save as test.doc
3. reopen in Aoo 3.4

the right brace cannot display

if open test.doc in MS Word 2003, the two right braces can display
Comment 1 Jianyuan Li 2012-08-19 05:59:25 UTC
I am looking at this issue...
Comment 2 Jianyuan Li 2012-08-22 08:03:49 UTC
Root cause: AOO permits an adjustment value reference for path coordinates(pVertices) such as "M 0 10000 X 2000 ?f0 L 2000 ?f2 Y 4000 5000 X 2000 ?f1 L 2000 $0 Y 0 0 F N" in which "$0" is an adjustment value. While doc export code do not handle a parameter with adjustment type and the adjustment indext(0~9) will be exported. So the coordinates will be incorrect.
Resolution: Handle adjustment type parameter when export. Find its actual value and export it.
Comment 3 Jianyuan Li 2012-08-22 08:04:28 UTC
MS does not permit an adjustment value reference for path coordinates(pVertices)
Comment 4 Jianyuan Li 2012-08-22 08:06:06 UTC
Created attachment 79061 [details]
Patch for this issue
Comment 5 sunying 2012-09-10 02:33:36 UTC
patch looks good, reviewed.
Comment 6 SVN Robot 2012-09-10 08:14:16 UTC
"lijiany" committed SVN revision 1382685 into trunk:
#119520# the right brace shape cannot display after save the sample .odt file...
Comment 7 Jianyuan Li 2012-09-10 09:15:58 UTC
Issue has been fixed.
Comment 8 Du Jing 2012-10-08 05:46:59 UTC
verified on the build AO3.5_r1387482
Comment 9 Shenfeng Liu 2012-10-18 06:28:01 UTC
Update Target Milestone to AOO 3.5.0.