Issue 119519 - [From Symphony] One shape's border cannot be displayed completely
[From Symphony] One shape's border cannot be displayed completely
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 08:57 UTC by liuping
Modified: 2012-12-26 08:30 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (25.00 KB, application/vnd.ms-powerpoint)
2012-05-29 08:57 UTC, liuping
no flags Details
Capture.PNG (134.19 KB, image/png)
2012-05-29 08:58 UTC, liuping
no flags Details
Patch for this issue (953 bytes, patch)
2012-07-02 06:34 UTC, Jianyuan Li
awf.aoo: review+
Details | Diff
UT file for this issue (19.00 KB, application/vnd.ms-powerpoint)
2012-07-02 06:35 UTC, Jianyuan Li
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-05-29 08:57:49 UTC
Created attachment 77727 [details]
sample file

Build: rev 1327774

Steps:
1. Open the sample file in AOO and in MS
2. Check the shape border in page 1

Defect:
Shape's border cannot be displayed completely

pls refer the capture.png
Comment 1 liuping 2012-05-29 08:58:33 UTC
Created attachment 77728 [details]
Capture.PNG
Comment 2 Jianyuan Li 2012-06-26 08:03:27 UTC
I am investigating this issue
Comment 3 Jianyuan Li 2012-06-28 09:04:47 UTC
It is related to the issue 76201.
Comment 4 Jianyuan Li 2012-06-29 07:57:52 UTC
Root cause: For the sample shape, there is an unnecessary command "ELLIPSETO" is found. Due to this command, a closed polygon turns into a open polypolygon(with two polygon, one is open and one is closed from code property view). Due to the open polygon, border is not rendered completely(a OBJ_PLIN SdrPathObj is created for render).

Solution: The sample shape is so wired with a "ELLIPSETO" command. And the related segment is with 0 point. No segment is created for this command. If no segment is created, it will not be neccessary to divide the polygon into a polypolygon for command "ELLIPSETO". So when the points number for command is 0, do not end the last polygon.
Comment 5 Jianyuan Li 2012-06-29 08:00:31 UTC
(In reply to comment #4)
> Root cause: For the sample shape, there is an unnecessary command
> "ELLIPSETO" is found. Due to this command, a closed polygon turns into a
> open polypolygon(with two polygon, one is open and one is closed from code
> property view). Due to the open polygon, border is not rendered completely(a
> OBJ_PLIN SdrPathObj is created for render).
> 
> Solution: The sample shape is so wired with a "ELLIPSETO" command. And the
The command is "ANGLEELLIPSE" other than "ELLIPSETO"
> related segment is with 0 point. No segment is created for this command. If
> no segment is created, it will not be neccessary to divide the polygon into
> a polypolygon for command "ELLIPSETO". So when the points number for command
> is 0, do not end the last polygon.
Comment 6 liuping 2012-06-29 08:07:50 UTC
confirm this bug on rev 1327774
Comment 7 Jianyuan Li 2012-07-02 06:34:35 UTC
Created attachment 78538 [details]
Patch for this issue
Comment 8 Jianyuan Li 2012-07-02 06:35:15 UTC
Created attachment 78539 [details]
UT file for this issue
Comment 9 Jianyuan Li 2012-07-02 06:36:36 UTC
(In reply to comment #7)
> Created attachment 78538 [details]
> Patch for this issue

The patch looks a little complicated. But actually only a condition "if ( nPntCount )" is added.
Comment 10 SVN Robot 2012-07-09 12:25:29 UTC
"af" committed SVN revision 1359107: "#i119519# Fixed import of closed borders from PPT when an ellipse is involved.          Reported by: liupingtan          Patch by: Jianyuan Li          Review by: Andre Fischer"
Comment 11 Andre 2012-07-09 12:25:45 UTC
Comment on attachment 78538 [details]
Patch for this issue

Reviewed and tested, OK.
Comment 12 Andre 2012-07-09 12:26:18 UTC
Checked in that patch in SVN revision 1359107.
Comment 13 liuping 2012-08-20 06:24:39 UTC
Verified pass on Windows7-64bit, Redhat 32bit,ubutu 10.04 Mac10.7 with AOO trunk r1374181