Issue 119515 - [From Symphony] The numbering in table cell changes to bullets when saved in AOO
[From Symphony] The numbering in table cell changes to bullets when saved in AOO
Status: VERIFIED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 08:30 UTC by liuping
Modified: 2012-12-26 08:05 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (29.50 KB, application/vnd.ms-powerpoint)
2012-05-29 08:30 UTC, liuping
no flags Details
capture.png (162.00 KB, image/png)
2012-05-29 08:31 UTC, liuping
no flags Details
patch for export number bullet in table error (2.69 KB, patch)
2012-08-06 05:47 UTC, SunYing
sunyingshadesun: review?
Details | Diff
UT sample file (62.00 KB, application/vnd.ms-powerpoint)
2012-08-06 05:48 UTC, SunYing
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-05-29 08:30:23 UTC
Created attachment 77718 [details]
sample file

Build: rev 1327774

Steps:
1. Open the sample file
2. Check the items in the table cell , they're same as that in MS PPT.
3. Save the document to ppt format file.
4. Open the saved file , then check the items in the table cell. The 1,2,3 Numbering changes to circle bullets.

If save the document to odp file, the numbering displays correctly.
Defect:

pls refer the capture.png
Comment 1 liuping 2012-05-29 08:31:16 UTC
Created attachment 77719 [details]
capture.png
Comment 2 Du Jing 2012-07-17 06:16:56 UTC
confirmed,change its status
Comment 3 Du Jing 2012-07-17 06:17:49 UTC
confirmed,change its status
Comment 4 SunYing 2012-08-06 03:24:18 UTC
Root Cause:
Extend bullet was exported wrong.
Comment 5 SunYing 2012-08-06 05:47:58 UTC
Created attachment 78853 [details]
patch for export number bullet in table error

write client data for extend bullet.
Comment 6 SunYing 2012-08-06 05:48:57 UTC
Created attachment 78854 [details]
UT sample file
Comment 7 Jianyuan Li 2012-08-14 08:39:44 UTC
Reviewed and looks good.
Comment 8 SVN Robot 2012-08-16 03:23:14 UTC
"sunying" committed SVN 0 into trunk:
#119515# fix the numbering bullet in table cell changed when saved to .ppt fi...
Comment 9 sunying 2012-08-20 01:50:36 UTC
has been fixed
Comment 10 liuping 2012-08-23 02:54:20 UTC
Verified on Windows7-64bit &Ubuntu10.04 &Mac10.7 &Redhat &Ubuntu-64bit with AOO trunk 0 ,Pass