Issue 119496 - [From Symphony]PPT Import:Word Art becomes larger
[From Symphony]PPT Import:Word Art becomes larger
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: open-import
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 06:24 UTC by liuping
Modified: 2012-12-26 08:32 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (247.00 KB, application/vnd.ms-powerpoint)
2012-05-29 06:29 UTC, liuping
no flags Details
capture.png (162.21 KB, image/png)
2012-05-29 06:31 UTC, liuping
no flags Details
patch for import fontworl become larger (683 bytes, patch)
2012-08-14 02:16 UTC, SunYing
sunyingshadesun: review?
Details | Diff
UT sample file (52.00 KB, application/vnd.ms-powerpoint)
2012-08-14 02:17 UTC, SunYing
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-05-29 06:24:14 UTC
build info:rev 1327774
1.open the sample file in MS and AOO
2.check the left-bottom wordart 

defect:
the wordart become larger in AOO than inMS

ref the capture.png
Comment 1 liuping 2012-05-29 06:29:07 UTC
Created attachment 77691 [details]
sample file
Comment 2 liuping 2012-05-29 06:31:32 UTC
Created attachment 77692 [details]
capture.png
Comment 3 Du Jing 2012-07-17 06:18:29 UTC
confirmed,change its status
Comment 4 SunYing 2012-08-14 02:15:46 UTC
Root Cause:
The word art 's rectangle has been recaculated, which need not  recaculated.
Comment 5 SunYing 2012-08-14 02:16:49 UTC
Created attachment 78921 [details]
patch for import fontworl become larger
Comment 6 SunYing 2012-08-14 02:17:56 UTC
Created attachment 78922 [details]
UT sample file
Comment 7 SunYing 2012-08-14 02:31:41 UTC
solution:
Generally,the resize autoshape to fit text attr of word art in MS PPT is always false,and in sample file, the attr has been set true,so the wordart's rectangle has been recaculated, which need not recaculated,so error occur.
So the resize autoshape to fit text attr of word art should be always set to false when import.
the resize autoshape to fit text attr of word art in MS PPT correspond to the TextAutoGrowWidth and TextAutoGrowHeight in AOO.
Comment 8 Jianyuan Li 2012-08-14 08:44:41 UTC
Reviewed and looks good.
Comment 9 Jianyuan Li 2012-08-14 08:46:44 UTC
Reviewed and looks good.
Comment 10 Armin Le Grand 2012-08-14 10:56:55 UTC
ALG: Hi SunYing,
I took a look and it looks good in principle. Just one question: In msdffimp.cxx line 4370 it is decided what shape type it is. It depends on testing the property DFF_Prop_gtextFStrikethrough. Will this only trigger for the shapes which will get changed here (WordArt) or also for others...?

Thanks in advance!
Comment 11 SunYing 2012-08-15 02:34:40 UTC
Hi Armin, I looked the book <<OfficeDrawing97-2007BinaryFormatSpecification.pdf>>, and in page 27, describe the GeoText, "Effect text of the shape - this is what the WordArt tools use",So that property is to trigger for the WordArt shape.Pls check,Many thanks!

(In reply to comment #10)
> ALG: Hi SunYing,
I took a look and it looks good in principle. Just one
> question: In msdffimp.cxx line 4370 it is decided what shape type it is. It
> depends on testing the property DFF_Prop_gtextFStrikethrough. Will this only
> trigger for the shapes which will get changed here (WordArt) or also for
> others...?

Thanks in advance!
Comment 12 SVN Robot 2012-08-15 14:19:23 UTC
"alg" committed SVN revision 1373430 into trunk:
#119496# Correct flags AutoGrowWidth/Height for WordArtPatch by: SunYingRevie...
Comment 13 Armin Le Grand 2012-08-15 14:19:44 UTC
ALG: Okay, I see. Comitted as revision 1373430. Thanks!
Comment 14 sunying 2012-08-20 02:02:23 UTC
has been fixed
Comment 15 liuping 2012-08-20 06:33:50 UTC
Verified pass on Windows7-64bit, Redhat 32bit,ubutu 10.04 Mac10.7 with AOO trunk r1374181