Issue 119495 - [From Symphony]Arrow style of line changes after save the sample file to a new .ppt file.
[From Symphony]Arrow style of line changes after save the sample file to a ne...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 06:23 UTC by Du Jing
Modified: 2012-12-26 08:28 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (11.50 KB, application/vnd.ms-powerpoint)
2012-05-29 06:23 UTC, Du Jing
no flags Details
Patch for this issue (903 bytes, patch)
2012-07-13 07:15 UTC, Jianyuan Li
awf.aoo: review+
Details | Diff
UT file for this issue (23.50 KB, application/vnd.ms-powerpoint)
2012-07-13 07:16 UTC, Jianyuan Li
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-05-29 06:23:35 UTC
Created attachment 77690 [details]
sample file

Builds info: AOO3.4_1327774

Description:
1. Open the sample file.
2. Do not do any action and save as a new .ppt file.
3. Open the new .ppt file and the arrow style of the line changes.
Comment 1 Jianyuan Li 2012-07-11 03:36:39 UTC
I am investigating this issue.
Comment 2 Jianyuan Li 2012-07-11 03:36:57 UTC
Root cause:
ppt imported arrow styles is separately set into document model from AOO predefined arrow styles. When export, the two kinds styles also will be exported separately. But incorrect cross handling occurs for both.
Solution:
Separately handle them.
Comment 3 Jianyuan Li 2012-07-13 07:15:16 UTC
Created attachment 78636 [details]
Patch for this issue
Comment 4 Jianyuan Li 2012-07-13 07:16:26 UTC
Created attachment 78637 [details]
UT file for this issue
Comment 5 SVN Robot 2012-07-13 09:27:10 UTC
"af" committed SVN revision 1361125 into trunk:
#i119495# Fixed export of arrow styles to PPT.
Comment 6 Andre 2012-07-13 09:27:26 UTC
Comment on attachment 78636 [details]
Patch for this issue

Reviewed and tested: OK.
Comment 7 Andre 2012-07-13 09:27:39 UTC
Fixed.
Comment 8 Li Feng Wang 2012-08-21 05:25:37 UTC
Verified pass with AOO trunk r1374181