Issue 119492 - [From Symphony]The .xlsx sample file is opened with modified state
[From Symphony]The .xlsx sample file is opened with modified state
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: open-import
3.4.0
PC All
: P3 minor (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 06:10 UTC by Shan Zhu
Modified: 2012-11-07 08:33 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
.xlsx (191.63 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-05-29 06:10 UTC, Shan Zhu
no flags Details
Add patch (1.69 KB, patch)
2012-06-13 06:33 UTC, Clarence GUO
awf.aoo: review+
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Shan Zhu 2012-05-29 06:10:12 UTC
Created attachment 77686 [details]
.xlsx

Build info: AOO3.4_r1327774

Open the .xlsx sample file attached.
Check the state of the Save button on toolbar. It will be enabled.
Close the file without any change, a dialog will popup to ask whether you want to save the change.
Comment 1 Clarence GUO 2012-06-08 03:15:42 UTC
Due to chart was set modified flag to true during loading. PPTX has the same problem. I'm working on this.
Comment 2 Clarence GUO 2012-06-13 06:33:32 UTC
Created attachment 78283 [details]
Add patch
Comment 3 Clarence GUO 2012-06-13 06:34:55 UTC
Comment on attachment 78283 [details]
Add patch

Request Review
Comment 4 Clarence GUO 2012-06-13 06:47:04 UTC
Root Cause:
chart was set modify flag to true during loading.

Solution:
Reset all OLE's modify flag to false at the end of ImportFrom. It's the major filer method of MSOffice2010. As SD has the same problem(SW doesn't support import chart of MSOffice2010 yet), ImportFrom is the joint entry of the three applications, and MS2003 and ODF have no such problem, so it should the correct place to reset the flag.
Comment 5 Andre 2012-06-13 12:39:53 UTC
Reviewing.
Comment 6 Andre 2012-06-13 13:11:24 UTC
Comment on attachment 78283 [details]
Add patch

Reviewed.  Patch looks good.
Thanks for the good work.
Applied on SVN revision 1349824.
Comment 7 Andre 2012-06-15 11:19:08 UTC
Forgot to update the issue status.  Doing that now.
Comment 8 Terry Yang 2012-06-19 01:35:44 UTC
Verify not fixed on trunk rev. 1350167, Reopen this bug.
Platform is Win7 64 bit.
Comment 9 Andre 2012-06-19 12:12:05 UTC
@Terry: Very good that you caught that.  I applied the patch at the wrong place.  Probably because I did that manually (the patch had only partial path information).

Fixed that by moving the patch to the right place (a couple of lines down in the same file.)
SVN revision is 1351665.

I am sorry for the inconvenience.
Comment 10 Terry Yang 2012-06-25 03:16:58 UTC
Verify fixed on AOO 3.4.1 Dev Snapshot Builds Rev.1351712
Suggest close this bug.
Comment 11 Terry Yang 2012-08-20 02:58:30 UTC
Close this bug
Comment 12 Shenfeng Liu 2012-11-07 08:33:26 UTC
set Target Milestone to AOO 3.5.0 for PM purpose.