Issue 119491 - [From Symphony]Under Handout view mode, Header&Footer displays inconsistent with the one presented in MS PowerPoint
[From Symphony]Under Handout view mode, Header&Footer displays inconsistent w...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 06:06 UTC by Du Jing
Modified: 2012-10-18 07:08 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (24.50 KB, application/vnd.ms-powerpoint)
2012-05-29 06:06 UTC, Du Jing
no flags Details
Patch for this issue (1.39 KB, patch)
2012-08-28 09:33 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-05-29 06:06:30 UTC
Created attachment 77685 [details]
sample file

Build version  : AOO3.4_1327774

Detailed description:
1. Launch AOO3.4.
2. Open sample file
3. Switch to Handout view.
4. Check the display of Header&Footer under handout  view.
5. Header&Footer displays inconsistent with the one presented in MS PowerPoint.Pls view the attachments picture.
Comment 1 Du Jing 2012-07-17 06:18:34 UTC
confirmed,change its status
Comment 2 Jianyuan Li 2012-08-27 06:20:10 UTC
I am investigating this issue.
Comment 3 Jianyuan Li 2012-08-28 09:28:05 UTC
Root cause: Handout master page is not imported.
Resolution: Import handout master page together with slide master and notes master.
Comment 4 Jianyuan Li 2012-08-28 09:31:52 UTC
Limitation:
1. In handout master, the color of default text for header/footer/datatime cannot be changed. This is a feature gap.
2. For vertical text, it cannot be imported correctly in MAC. This issue will be tracked by Bug 119474
Comment 5 Jianyuan Li 2012-08-28 09:33:06 UTC
Created attachment 79198 [details]
Patch for this issue
Comment 6 sunying 2012-09-10 02:24:56 UTC
Handout master page has been imported, a great work!
patch looks good, reviewed and tested.
Comment 7 SVN Robot 2012-09-10 08:19:42 UTC
"lijiany" committed SVN revision 1382687 into trunk:
#119491# fix Handout view mode issueReported by: Du JingPatch by: Jianyuan Li...
Comment 8 Jianyuan Li 2012-09-10 09:17:25 UTC
Bug has been fixed
Comment 9 louqle 2012-09-18 02:57:29 UTC
verified on XP SP3, mac 10.8, Ubuntu 12.04 against build r1384699

verified on RHEL 6.1 64 bit against build 1386464

fixed. Close thid bug
Comment 10 Shenfeng Liu 2012-10-18 07:08:27 UTC
Update Target Milestone to AOO 3.5.0.