Issue 119487 - [From Symphony]Images lose macro association when open Excel file in AOO.
[From Symphony]Images lose macro association when open Excel file in AOO.
Status: CLOSED FIXED
Product: App Dev
Classification: Unclassified
Component: vba
OOo 3.3 or older
All All
: P3 normal
: 4.0.0
Assigned To: issues@vba
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 05:31 UTC by Shan Zhu
Modified: 2013-07-11 15:17 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Picture has a Macro assigned (49.00 KB, application/vnd.ms-excel)
2012-05-29 05:31 UTC, Shan Zhu
no flags Details
Patch for 119487 (402 bytes, patch)
2012-09-06 06:38 UTC, Chen Peng
chenpeng2006: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Shan Zhu 2012-05-29 05:31:25 UTC
Created attachment 77680 [details]
Picture has a Macro assigned

Build info:AOO3.4_r1327774

Problem Description:
An Excel file has a image in, assign a macro to the image, when click the image, the macro will run. Open the file in Aoo3.4, when click the image, macro does not run.
A sample file attched for reproducing the problem.

Issue: 
The macro is still here, but the association between image and macro will be lost.
Comment 1 Chen Peng 2012-09-06 06:38:49 UTC
Created attachment 79308 [details]
Patch for 119487
Comment 2 Chen Peng 2012-09-06 06:39:07 UTC
Root Cause:
Macro on picture is supported by VBA, should set the related flag to true,

2. Resolution:
Set the SimpleMacro flag to true to enable the macro on picture.
Comment 3 SVN Robot 2012-09-07 09:56:47 UTC
"leiw" committed SVN revision 1381968 into trunk:
#i119487 [From Symphony]Images lose macro association when open Excel file in...
Comment 4 Wang Lei 2012-09-07 09:57:50 UTC
Submit in revision 1381968
Comment 5 Du Jing 2012-10-17 02:08:29 UTC
verify fail in the build AOO3.5_r1397404
Comment 6 Du Jing 2012-10-17 02:10:27 UTC
verify step:
1.Launch AOO and set macro security low
2.open the sample file and click the graphic,no any response
but in MS office,when click it,it will disappear.
Comment 7 Du Jing 2012-10-17 02:49:52 UTC
sorry for not enable "excute code" in VBA properties.
Comment 8 Du Jing 2012-10-17 02:50:30 UTC
verify result:pass
Comment 9 Shenfeng Liu 2012-10-18 05:34:25 UTC
Update Target Milestone to AOO 3.5.0.