Issue 119477 - [From Symphony]PPT Export: Diagram bullet can not be displayed correctly after saved as *.ppt in AOO
[From Symphony]PPT Export: Diagram bullet can not be displayed correctly afte...
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 03:16 UTC by liuping
Modified: 2012-10-18 05:46 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (14.00 KB, application/vnd.ms-powerpoint)
2012-05-29 03:16 UTC, liuping
no flags Details
after saving sample file (75.50 KB, application/octet-stream)
2012-05-29 03:17 UTC, liuping
no flags Details
capture.png (143.03 KB, image/png)
2012-05-29 03:18 UTC, liuping
no flags Details
another sample file with 3D shape (17.50 KB, application/vnd.ms-powerpoint)
2012-06-07 08:46 UTC, Li Feng Wang
no flags Details
patch for import bullet start with (1.94 KB, patch)
2012-09-14 01:57 UTC, sunying
no flags Details | Diff
UT file (73.00 KB, application/vnd.ms-powerpoint)
2012-09-14 01:57 UTC, sunying
no flags Details
defect screenshot (112.03 KB, image/png)
2012-09-14 02:13 UTC, sunying
no flags Details
patch for import bullet start with (2.31 KB, patch)
2012-09-19 01:51 UTC, sunying
sunying: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description liuping 2012-05-29 03:16:46 UTC
Created attachment 77668 [details]
sample file

build info: Rev:1327774
Steps:
1.Open the sample file in AOO and in MS
2.Save it as *.ppt (11.ppt)
3.Open the *.ppt(11.ppt) in AOO and compared the original .ppt file (1.ppt)

Defect:
Diagram bullet can not be displayed correctly.
Comment 1 liuping 2012-05-29 03:17:42 UTC
Created attachment 77669 [details]
after saving sample file
Comment 2 liuping 2012-05-29 03:18:32 UTC
Created attachment 77670 [details]
capture.png
Comment 3 Li Feng Wang 2012-06-07 08:46:44 UTC
Created attachment 78121 [details]
another sample file with 3D shape

Steps:
1. Launch AOO, open this attachment
2 [details]. Save the file as *.ppt
3. Reopen the saved ppt file in MS 2003 Powerpoint.

Defects:
1. 3D shape in page1 is not visible.
2. 3D shape in page2 become very large.

Notes: If reopen the saved ppt file with AOO, this prb does not exist
Comment 4 Du Jing 2012-07-17 06:10:36 UTC
confirmed,change its status
Comment 5 Li Feng Wang 2012-09-12 02:53:48 UTC
This problem can't reproduce on AOo trunk again.


(In reply to comment #3)
> Created attachment 78121 [details]
another sample file with 3D shape

Steps:
> 1. Launch AOO, open this attachment
2 [details]. Save the file as *.ppt
3.
> Reopen the saved ppt file in MS 2003 Powerpoint.

Defects:
1. 3D shape in
> page1 is not visible.
2. 3D shape in page2 become very large.

Notes: If
> reopen the saved ppt file with AOO, this prb does not exist
Comment 6 sunying 2012-09-13 08:30:00 UTC
root cause:
the "startwith" of numbering bullet has not been set when import, 
so read startwith var from model in line 2539 \main\sd\source\filter\eppt\epptso.cxx always is 1.
Comment 7 sunying 2012-09-14 01:57:02 UTC
Created attachment 79494 [details]
patch for import bullet start with
Comment 8 sunying 2012-09-14 01:57:34 UTC
Created attachment 79495 [details]
UT file
Comment 9 sunying 2012-09-14 02:12:37 UTC
solution:
set SvxNumberFormat's startwith value at function ImplGetExtNumberFormat() in file /impr/svx/source/svdraw/svdfppt.cxx.
It is unnecessary to set rOutliner's StartValue in line 2517 in file /impr/svx/source/svdraw/svdfppt.cxx.

The patch in file /main/editeng/source/outliner/outliner.cxx is in order to fix the following defect:
steps:
1.Open AOO, and create a presention,
2.add three line text, 
3.set the text's bullet is numbering.
4.choose the 2rd line, and reset Start at is 4, find the 2rd line's numbering become 5,refer the attachment "defect screenshot.png".
Comment 10 sunying 2012-09-14 02:13:05 UTC
Created attachment 79497 [details]
defect screenshot
Comment 11 Steve Yin 2012-09-18 13:52:32 UTC
Please add more comments for the changes your have made.
Comment 12 sunying 2012-09-19 01:51:26 UTC
Created attachment 79553 [details]
patch for import bullet start with
Comment 13 sunying 2012-09-19 01:53:37 UTC
(In reply to comment #11)
> Please add more comments for the changes your have made.

Hi,Steve, I has add comments for the patch, pls review again,thx!
Comment 14 Steve Yin 2012-09-19 02:46:23 UTC
Review done.
Comment 15 SVN Robot 2012-09-19 08:09:45 UTC
"sunying" committed SVN revision 1387482 into trunk:
#119477# fix bullet's start with error when save .ppt fileReported by: Liu Pi...
Comment 16 sunying 2012-09-21 06:43:05 UTC
fixed
Comment 17 Li Feng Wang 2012-10-16 03:14:40 UTC
Verified pass on windows and linux with r1397404
Comment 18 Shenfeng Liu 2012-10-18 05:46:19 UTC
Update Target Milestone to AOO 3.5.0.