Issue 119470 - [From Symphony]page number in header lost when we save the .doc file as another in web layout
[From Symphony]page number in header lost when we save the .doc file as anoth...
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: ui
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 02:42 UTC by louqle
Modified: 2012-12-26 08:39 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
sample file (23.50 KB, application/msword)
2012-05-29 02:42 UTC, louqle
no flags Details
page number fileds in header (7.29 KB, image/png)
2012-05-29 02:44 UTC, louqle
no flags Details
patch for the issue (5.01 KB, patch)
2012-08-03 05:08 UTC, Lei Debin
debin.lei: review?
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description louqle 2012-05-29 02:42:11 UTC
Created attachment 77657 [details]
sample file

build: A003.4

1. open the sample file
2. click View->Web Layout
3. save as a new .doc file
4. close and reopen the new .doc file
5. click View->print layout

the page nubmber fields in header moved out of page and the fields are empty.
Comment 1 louqle 2012-05-29 02:44:06 UTC
Created attachment 77658 [details]
page number fileds in header
Comment 2 Lei Debin 2012-08-03 05:05:26 UTC
I am checking the issue find the root cause.
The page number is lost, when export in browser mode.
In browser mode, there's no header or footer, so the filter will fail in finding
the field in a textbox.
Comment 3 Lei Debin 2012-08-03 05:07:15 UTC
When exporting a text box object (and the types alike), the filter will find the object's info through the instance of the object in the "view module". In browse mode, the header/footer is not shown, so their content text box has no instance in the view module. The text box can not be find, and it can not be exported. 

The solution will made a "backup clue" for the filter to find the correct object info in case that the original method fails
Comment 4 Lei Debin 2012-08-03 05:08:32 UTC
Created attachment 78836 [details]
patch for the issue
Comment 5 zjchen 2012-08-06 05:49:58 UTC
I am volunteering to review this patch. Adding text box object export process in  Browse Mode to solve this issue is reasonable. The patch is OK to me.
Comment 6 SVN Robot 2012-08-06 06:07:47 UTC
"leidb" committed SVN revision 1369728 into trunk:
#119470# fix page number in header lost when we save the .doc file as another...
Comment 7 Lei Debin 2012-08-06 06:10:04 UTC
Thanks zuo jun for the code review.
Comment 8 Du Jing 2012-08-20 09:11:00 UTC
verified on the AOO3.5