Issue 119467 - [From Symphony]Form controls cannot be saved into .ppt file in AOO3.4
[From Symphony]Form controls cannot be saved into .ppt file in AOO3.4
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: save-export
3.4.0
PC All
: P3 normal (vote)
: 4.0.0
Assigned To: AOO issues mailing list
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-29 02:15 UTC by Du Jing
Modified: 2012-10-18 07:10 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Patch for this issue (9.52 KB, patch)
2012-09-06 08:25 UTC, Jianyuan Li
lijianyuan1983: review?
Details | Diff
UT files (45.41 KB, application/x-zip-compressed)
2012-09-06 08:26 UTC, Jianyuan Li
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Du Jing 2012-05-29 02:15:16 UTC
Build version:  AOO3.4_1327774
Detailed descripton :

1. Launch AOO, new a presentation
2. Insert some Form controls
3. Save the file as MS format (.ppt)
4. close the file , and the reopen it
-----------------------------------------------------------------------------------------
Defect: these form controls cannot be saved correctly, there are only some rectangle frames.
Comment 1 Du Jing 2012-07-17 06:18:55 UTC
confirmed,change its status
Comment 2 Jianyuan Li 2012-08-31 08:43:21 UTC
I am investigating this issue...
Comment 3 Jianyuan Li 2012-09-04 11:03:33 UTC
Root cause: Form control graphic is not exported.
Resolution: Export it.
Impact area:
1. Form controls will be exported correctly. The exported file can be o open by MS ppt or AOO correctly.
2. Fix crash issue for spin button on opening exported file in MS ppt.
3. Export/import basic properties: Font style, horizontal alignment and background.
Comment 4 Jianyuan Li 2012-09-06 08:25:35 UTC
Created attachment 79314 [details]
Patch for this issue
Comment 5 Jianyuan Li 2012-09-06 08:26:13 UTC
Created attachment 79315 [details]
UT files
Comment 6 sunying 2012-09-10 09:30:10 UTC
patch looks good, reviewed.
Comment 7 SVN Robot 2012-09-11 09:00:46 UTC
"lijiany" committed SVN revision 1383298 into trunk:
#119467# Form controls cannot be saved into .ppt file in AOO3.4Reported by: D...
Comment 8 Jianyuan Li 2012-09-11 09:03:09 UTC
Fixed
Comment 9 louqle 2012-09-18 02:57:25 UTC
verified on XP SP3, mac 10.8, Ubuntu 12.04 against build r1384699

verified on RHEL 6.1 64 bit against build 1386464

fixed. Close thid bug
Comment 10 Shenfeng Liu 2012-10-18 07:10:19 UTC
Update Target Milestone to AOO 3.5.0.