Issue 119418 - About Dialog Improvements
About Dialog Improvements
Status: RESOLVED FIXED
Product: General
Classification: Code
Component: ui
3.4.0
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 16:21 UTC by Timon
Modified: 2013-07-11 09:33 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
In LibreOffice version and build-ID may be copied (33.00 KB, image/jpeg)
2012-05-25 16:21 UTC, Timon
no flags Details
About Dialog from current trunk (50.65 KB, image/png)
2012-06-26 05:42 UTC, Ariel Constenla-Haile
no flags Details
About Dialog from current trunk (99.79 KB, image/png)
2012-09-20 22:45 UTC, Ariel Constenla-Haile
no flags Details
Readme, License and Notice dialog (84.26 KB, image/png)
2012-09-20 22:45 UTC, Ariel Constenla-Haile
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Timon 2012-05-25 16:21:28 UTC
Created attachment 77601 [details]
In LibreOffice version and build-ID may be copied

Apache OpenOffice 3.4.0 (Final) AOOO340m1 (Build 9590) - Rev. 1327774 Russian UI/Locale

Need the ability to copy version, build, and revision of the program information from the About Box like it's made in LibreOffice.

While descripting problems in Office applications it is desirable to specify the exact version, build, and revision of the program since this information helps to diagnose the problem much faster (also good idea to increase default font size used to display described above info in Apache OpenOffice - now it's very small). Very uncomfortable to gain this information each time manually.

Also About Box does not show bitness (32-bit or 64-bit).

Also remove the "full stop (dot)" at the end of URL with credits (http://www.openoffice.org/welcome/credits.html.), because after copy-paste functions you need to delete this "full stop (dot)" manually, or make URL clickable.
Comment 1 Ariel Constenla-Haile 2012-05-25 21:30:04 UTC
Confirmed as request for enhancement.
Comment 2 Ariel Constenla-Haile 2012-06-18 19:28:19 UTC
Committed some changes under Revision 1351463
Comment 3 Ariel Constenla-Haile 2012-06-26 05:42:24 UTC
Created attachment 78475 [details]
About Dialog from current trunk
Comment 4 Ariel Constenla-Haile 2012-06-26 05:47:03 UTC
> Need the ability to copy version, build, and revision of the program
> information from the About Box 

This information can now be selected and copied

> Also About Box does not show bitness (32-bit or 64-bit).

Right now, Linux is the only system where we support both 32 and 64 bits, so I left this as an optional feature to be set at configure time by the developer building AOO using --with-build-version, for example:

--with-build-version="$(date +"%Y-%m-%d %H:%M:%S (%a, %d %b %Y)") - `uname -sm`"

This will produce something like

2012-06-22 08:23:54 (Fri, 22 Jun 2012) - Linux x86_64


> Also remove the "full stop (dot)" at the end of URL with credits
> (http://www.openoffice.org/welcome/credits.html.), because after copy-paste
> functions you need to delete this "full stop (dot)" manually, or make URL
> clickable.

I removed this and added a link
Comment 5 SVN Robot 2012-09-20 22:31:54 UTC
"arielch" committed SVN revision 1388247 into trunk:
#i119418# - About Dialog improvements
Comment 6 Ariel Constenla-Haile 2012-09-20 22:45:03 UTC
Created attachment 79591 [details]
About Dialog from current trunk
Comment 7 Ariel Constenla-Haile 2012-09-20 22:45:34 UTC
Created attachment 79592 [details]
Readme, License and Notice dialog
Comment 8 hdu@apache.org 2013-07-11 09:27:43 UTC
Updated status to FIXED and target to release that will contain the enhancement.
Comment 9 Ariel Constenla-Haile 2013-07-11 09:33:34 UTC
The current version, after the logo changes, looks IMO horrible (besides the horribleness of the flat logo).