Issue 119385 - Decrease current system requirements on Linux
Decrease current system requirements on Linux
Status: RESOLVED FIXED
Product: Build Tools
Classification: Code
Component: code
3.4.0
PC Linux
: P3 normal with 2 votes (vote)
: 4.0.0
Assigned To: Ariel Constenla-Haile
:
: 121604 (view as issue list)
Depends on: 119392
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-19 22:05 UTC by James Pearson
Modified: 2013-07-21 11:58 UTC (History)
7 users (show)

See Also:
Issue Type: TASK
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description James Pearson 2012-05-19 22:05:01 UTC
I've just tried to use the 32 bit (and 64 bit) Linux builds of 3.4 on 
CentOS 5 but get errors saying that its various shared libs require 
glibc 2.7 or 2.11 - i.e:

/opt/openoffice.org3/program/../basis-link/ure-link/bin/javaldx: 
/lib/libc.so.6: version `GLIBC_2.7' not found (required by 
/opt/openoffice.org/ure/bin/../lib/libuno_sal.so.3)
/opt/openoffice.org3/program/../basis-link/ure-link/bin/javaldx: 
/lib/libc.so.6: version `GLIBC_2.7' not found (required by 
/opt/openoffice.org/ure/bin/../lib/libxml2.so.2)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version 
`GLIBC_2.7' not found (required by 
/opt/openoffice.org3/program/../basis-link/ure-link/lib/libuno_sal.so.3)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version 
`GLIBC_2.11' not found (required by 
/opt/openoffice.org3/program/../basis-link/program/libsvt.so)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version 
`GLIBC_2.7' not found (required by 
/opt/openoffice.org3/program/../basis-link/program/libsvt.so)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version 
`GLIBC_2.11' not found (required by 
/opt/openoffice.org3/program/../basis-link/program/libvcl.so)
/opt/openoffice.org3/program/soffice.bin: /lib/libc.so.6: version 
`GLIBC_2.7' not found (required by 
/opt/openoffice.org3/program/../basis-link/program/../ure-link/lib/libxml2.so.2)

The README that comes with 3.4 states:

> System Requirements
> ----------------------------------------------------------------------
> 
> * Linux Kernel version 2.6.18 or higher
> * glibc2 version 2.5 or higher
> * gtk version 2.10.4 or higher

Has the System Requirements for 3.4 changed so it now needs 'glibc2 
version 2.11 or higher' - or has 3.4 been built on a non glibc 2.5 
platform by mistake?

Ideally, 3.4 should be able to run on RHEL5/CentOS5
Comment 1 Ariel Constenla-Haile 2012-05-20 20:46:24 UTC
Confirmed.
CentOS 5 comes with GNU C Library 2.5
CentOS 5 will receive full updates until Q1 2014, and maintenance updates until 2017-03-31.
AOO should be able to be installed in Linux distributions that are still being supported.
Comment 2 Ariel Constenla-Haile 2012-05-20 20:54:30 UTC
Changing subject
Comment 3 Ariel Constenla-Haile 2012-05-20 20:55:08 UTC
Accepted.
Started.
Comment 4 Ariel Constenla-Haile 2012-05-21 09:31:20 UTC
(In reply to comment #0)
> The README that comes with 3.4 states:
> 
> > System Requirements
> > ----------------------------------------------------------------------
> > 
> > * Linux Kernel version 2.6.18 or higher
> > * glibc2 version 2.5 or higher
> > * gtk version 2.10.4 or higher

For updating the System requirements in the documentation (README and website) there is a separated Bug 119393
Comment 5 Ariel Constenla-Haile 2012-05-21 22:34:54 UTC
You can try 64 bit RPM/DEB packages from http://people.apache.org/~arielch/packages/3.4.1-beta/
(32 bit packages are comming soon).
Usual warning: this is beta software, do not use it in production.

So far I tested that it works on:

- Fedora 16
- Ubuntu 10.04.4 LTS
- Ubuntu 11.10
- Debian 5
- Debian 6
- CentOS 5
Comment 6 James Pearson 2012-05-22 10:09:54 UTC
(In reply to comment #5)
> You can try 64 bit RPM/DEB packages from
> http://people.apache.org/~arielch/packages/3.4.1-beta/
> (32 bit packages are comming soon).
> Usual warning: this is beta software, do not use it in production.

Thanks - starts OK on CentOS 5 for me
Comment 7 Ariel Constenla-Haile 2012-05-22 14:10:30 UTC
(In reply to comment #5)
> You can try 64 bit RPM/DEB packages from
> http://people.apache.org/~arielch/packages/3.4.1-beta/
> (32 bit packages are comming soon).

All packages are now ready:
http://people.apache.org/~arielch/packages/3.4.1-beta/index.html

Builds are based on Revision 1337125 from http://svn.apache.org/viewvc/incubator/ooo/branches/AOO34/
and include some patches from bug fixes not committed yes:
Bug 119206 
Bug 119327
Bug 119102

In short, it's basically AOO 3.4.0, with a few tested bug fixes.
While the build environment used to build the Linux packages released as AOO 3.4.0 has been tested since January this year http://s.apache.org/tp , this new packages really need testing in different Linux distributions, this is why they are not recommended for production.
Comment 8 James Pearson 2012-05-29 14:29:13 UTC
(In reply to comment #7)
> 
> In short, it's basically AOO 3.4.0, with a few tested bug fixes.
> While the build environment used to build the Linux packages released as AOO
> 3.4.0 has been tested since January this year http://s.apache.org/tp , this
> new packages really need testing in different Linux distributions, this is
> why they are not recommended for production.

Does this mean 3.4.1 will or will not work on glibc 2.5 systems ?
Comment 9 Ariel Constenla-Haile 2012-05-29 14:49:05 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > 
> > In short, it's basically AOO 3.4.0, with a few tested bug fixes.
> > While the build environment used to build the Linux packages released as AOO
> > 3.4.0 has been tested since January this year http://s.apache.org/tp , this
> > new packages really need testing in different Linux distributions, this is
> > why they are not recommended for production.
> 
> Does this mean 3.4.1 will or will not work on glibc 2.5 systems ?

I didn't still propose for discussion if we should build AOO 3.4.1 in the same environment as AOO 3.4.0, or switch to a new one, because I'm still testing some things (like bringing back KDE3 support, and other issues related to building with older libraries).

Consider that AOO 3.4.1 is likely to be released by the end of July, so this is not much time for testing the new Linux build environmen.

In case the official release keeps the current systems requirements, I will provide RPM and DEB packages as I did now.
Comment 10 Ariel Constenla-Haile 2012-08-23 22:02:20 UTC
FYI, now that AOO 3.4.1 has been released, you can found the new packages on http://people.apache.org/~arielch/packages/r1372282-glibc-2.5/
Comment 11 Ravi Chodavarapu 2012-11-27 13:47:01 UTC
(In reply to comment #10)
> FYI, now that AOO 3.4.1 has been released, you can found the new packages on
> http://people.apache.org/~arielch/packages/r1372282-glibc-2.5/

Ariel, can you give a bit of detail as to what the packages in that link are based on? Is it based on the release version of 3.4.1, but with the fix to address the version of glibc? Will your changes go into the next release version of OpenOffice?
Comment 12 Ariel Constenla-Haile 2012-11-27 14:11:15 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > FYI, now that AOO 3.4.1 has been released, you can found the new packages on
> > http://people.apache.org/~arielch/packages/r1372282-glibc-2.5/
> 
> Ariel, can you give a bit of detail as to what the packages in that link are
> based on? Is it based on the release version of 3.4.1, but with the fix to
> address the version of glibc? 

These packages are based on the same revision as 3.4.1 plus the fixes to make it build on CentOS 5

> Will your changes go into the next release version of OpenOffice?

All fixes are already applied in trunk.
The Developer Snapshots on https://cwiki.apache.org/confluence/x/f8KoAQ are built with support for glibc-2.5 

That said, I'm not sure if the next release is going to be build on the build bots.
Comment 13 maxslug 2012-12-04 01:18:52 UTC
Added a HOWTO for other non-root RHEL5 users.  Thanks so much for the packages compiled for older GLIBs!
http://warped.org/blog/2012/12/03/open-office-3-4-as-non-root-rhel-5/
Comment 14 Ariel Constenla-Haile 2013-01-09 18:05:45 UTC
*** Issue 121604 has been marked as a duplicate of this issue. ***
Comment 15 Ariel Constenla-Haile 2013-07-21 11:58:31 UTC
Fixed in 4.0.0
The new release is built on CentOS 5