Issue 119248 - fix fetch_tarballs.sh on Solaris
fix fetch_tarballs.sh on Solaris
Status: RESOLVED FIXED
Product: Build Tools
Classification: Code
Component: solenv
OOo 3.4 Beta
Sun Solaris
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-19 10:26 UTC by Jean-Louis Fuchs
Modified: 2013-07-11 09:37 UTC (History)
3 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
patch shows where the problem is (519 bytes, patch)
2012-04-19 13:22 UTC, Jean-Louis Fuchs
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Jean-Louis Fuchs 2012-04-19 10:26:56 UTC
Sed on solaris doesn't understand [[:space:]], I changed those to \s. See patch.

There is gsed in /usr/bin/gsed if the package is installed. It is imo safe to assume that gsed is there. Hence fetch_tarballs.sh could use gsed on solars.

(for Andre Fischer)
Comment 1 Jean-Louis Fuchs 2012-04-19 13:22:02 UTC
Created attachment 77461 [details]
patch shows where the problem is
Comment 2 Andre 2012-04-20 07:32:08 UTC
Thanks. I will check in the patch as soon as the release is done (please ping me, if I forget it)
Comment 3 Andre 2012-05-04 09:23:56 UTC
Checked in on revision 1333822.