Issue 119006 - Restore windows problem on Mac OS X
Restore windows problem on Mac OS X
Status: VERIFIED FIXED
Product: General
Classification: Code
Component: code
OOo 3.4 Beta
Mac Mac OSX
: P3 critical (vote)
: 4.1.0
Assigned To: hdu@apache.org
:
: 110914 118547 119236 120026 120361 120577 120618 120742 120793 120814 120862 121123 121124 121228 121253 121693 121830 121952 121963 122036 122222 122341 122344 122861 122960 123131 123237 123274 123430 123482 123560 123608 123675 123681 123967 124093 124101 124110 124276 124344 124352 124358 124366 124370 124379 124382 124485 124598 124602 124612 124616 124663 124690 124700 124753 124767 124785 124885 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 00:14 UTC by tydog2008
Modified: 2014-06-02 17:01 UTC (History)
80 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 4.1.0-dev
Developer Difficulty: ---


Attachments
This is the message window that won't go away (51.26 KB, image/tiff)
2014-01-12 16:28 UTC, RobH
no flags Details
AOO saved state causing re-open dialog to appear. (4.93 KB, application/x-zip-compressed)
2014-01-19 16:23 UTC, rony
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description tydog2008 2012-03-02 00:14:37 UTC
Forced quit once and the restore windows will not go away. Tried installing and reinstalling and still won't go away. Neither the restore or don't restore won't work. Don't see a way to get rid of problem.
Comment 1 T. J. Frazier 2012-03-02 03:21:29 UTC
A recent thread on the ooo-users ML has discussed this very problem. The link

http://user.services.openoffice.org/en/forum/viewtopic.php?f=17&t=45936&p=212231&hilit=restore+window#p212236

should provide you with enough information to get you running again. However, there is one important thing you can do to help get this _fixed_.

The forum advises to delete a particular file or folder. It seems likely that the developers would like to look at the bad file, or whatever is in that folder. Please try to add that material as an attachment to this bug report; then you can delete it.
Comment 2 Tim Keagy 2012-03-30 19:45:24 UTC
I am experiencing the same problem, as far as I can tell all products are working but the box will not go away. Using Mac OS X 10.7.3. OpenOffice.org 3.3 415.9 MB
Comment 3 zhao xia 2012-04-28 08:03:11 UTC
I confimred this problem against my Mac 10.7
Comment 4 peetroets 2012-05-25 08:49:19 UTC
When Openoffice is started, the Restore window opens and cannot be removed in any way. This is before any database files are opened.
Comment 5 lgusaas 2012-08-25 14:45:51 UTC
For workaround:
Option-click the Go menu
Choose Library from the menu to open the folder in the Finder.
Click on the folder Saved Application State
Delete the file org.openoffice.script.savedState
Comment 6 123 2012-09-10 14:33:34 UTC
(In reply to comment #5)
> For workaround:
> Option-click the Go menu
> Choose Library from the menu to open the folder in the Finder.
> Click on the folder Saved Application State
> Delete the file org.openoffice.script.savedState

I tried your fix, and it didn't fix anything.  This is a really old bug, and a critical one, and I am wondering when or if it is will ever be fixed?
Comment 7 Andrea Pescetti 2012-09-11 20:48:13 UTC
*** Issue 119236 has been marked as a duplicate of this issue. ***
Comment 8 Andrea Pescetti 2012-09-11 20:49:47 UTC
*** Issue 120361 has been marked as a duplicate of this issue. ***
Comment 9 Andrea Pescetti 2012-09-11 20:50:19 UTC
*** Issue 120577 has been marked as a duplicate of this issue. ***
Comment 10 Andrea Pescetti 2012-09-11 20:50:59 UTC
*** Issue 120618 has been marked as a duplicate of this issue. ***
Comment 11 Andrea Pescetti 2012-09-11 20:51:36 UTC
*** Issue 120793 has been marked as a duplicate of this issue. ***
Comment 12 Andrea Pescetti 2012-09-11 20:52:15 UTC
*** Issue 120814 has been marked as a duplicate of this issue. ***
Comment 13 Ariel Constenla-Haile 2012-09-27 04:29:50 UTC
*** Issue 121124 has been marked as a duplicate of this issue. ***
Comment 14 kristiangolick 2012-09-29 03:56:17 UTC
My dialogue box for reopening unexpectant closed windows will not close and will not work. I cannot use the open, print, and save as features.
Comment 15 Bob Edmonson 2012-09-30 20:59:30 UTC
Add me to the list of folk who have encountered the 'restore windows' problem. OpenOffice was working fine until today, when I tried to open an MS Word document with the .docx suffix. OOcrashed and when I reopened, there was the restore windows box. I don't know if this helps or not. I tried the workaround already noted without success.
Comment 16 Chris 2012-10-14 04:49:00 UTC
I am using OSX 10.8.2 there is no such folder "Saved Application State" or file "org.openoffice.script.savedState" I have even tried using Terminal to find it. Any ideas OOO is basically useless at this point.
Comment 17 Chris 2012-10-14 05:20:31 UTC
Found it it was the hidden ~/Library not the one in your user folder sorry.
Comment 18 Andrea Pescetti 2012-10-18 20:01:25 UTC
*** Issue 121228 has been marked as a duplicate of this issue. ***
Comment 19 Marcus 2012-10-23 18:45:39 UTC
*** Issue 121253 has been marked as a duplicate of this issue. ***
Comment 20 donald r. scott 2012-11-25 02:15:14 UTC
Add Me To This as well
Comment 21 Cor 2012-12-27 21:09:44 UTC
I have a similar problem, the menu won't go away and it has disabled my edit bar... I don't have a folder "Saved Application State" or file "org.openoffice.script.savedState" either. It also won't let me shut down unless I force quit the program. It's not exactly useless, but it's very annoying and problematic, since I can't copy and paste, nor undo...
Comment 22 Chris 2012-12-27 21:19:48 UTC
What OS are you currently using?
Comment 23 Cor 2012-12-30 18:39:46 UTC
Not sure, think it says it updated "Mac OS X" to 10.7.5 some time ago... (I don't know how to find were it tells you which OS it is, so I'm not fully sure on my answer).
Comment 24 Cor 2012-12-30 18:41:54 UTC
Also, I realized, the only way to make anything work is to use the actual window buttons, so I can type and use tool bar, but that's it.
(Also, sorry for late reply)
Comment 25 Cor 2012-12-30 18:53:11 UTC
Okay, nvm. The Saved Application State Folder is not found by going from "Computer > Macintosh > Library" but by holding alt/option key down while in "Go" in the Finder menu bar, where a "Library" will magically appear and allow you to select it...
(Missed veiwtopic link and went to the blog link instead [which didn't tell me this]... My bad. Still, why does there have to be two libraries?...)
Comment 26 lgusaas 2012-12-30 18:56:58 UTC
(In reply to comment #23)
> Not sure, think it says it updated "Mac OS X" to 10.7.5 some time ago... (I
> don't know how to find were it tells you which OS it is, so I'm not fully
> sure on my answer).

For help with your problems go to http://forum.openoffice.org/en/forum/

I have some questions to ask in order to clarify your problems, but, this is a place to report bugs, not to get support.
Comment 27 SVN Robot 2013-01-18 12:28:02 UTC
"hdu" committed SVN revision 1435109 into trunk:
#i119006# disable OSX>=10.7 window restoration until we support it directly
Comment 28 hdu@apache.org 2013-01-18 12:36:29 UTC
My fix above disables the OSX>=10.7 window restoration and the resulting problem that this mechanism is not handled yet. This should prevent the problem caused by OSX creating the restoration status file named:
~/Library/Saved Application State/org.openoffice.script.savedState
Comment 29 gregprimus33 2013-01-22 13:19:18 UTC
i can open any files due to this restore problem
Comment 30 hdu@apache.org 2013-01-22 16:16:02 UTC
(In reply to comment #29)
> i can open any files due to this restore problem

Please see comment 5 on how to remove the saved application state
Comment 31 Ariel Constenla-Haile 2013-02-26 22:35:35 UTC
*** Issue 121830 has been marked as a duplicate of this issue. ***
Comment 32 Ariel Constenla-Haile 2013-02-26 22:37:08 UTC
*** Issue 120742 has been marked as a duplicate of this issue. ***
Comment 33 Ariel Constenla-Haile 2013-02-26 22:38:04 UTC
*** Issue 121693 has been marked as a duplicate of this issue. ***
Comment 34 Yurggent Alfredo Chable Torrez 2013-03-25 19:25:29 UTC
*** Issue 121952 has been marked as a duplicate of this issue. ***
Comment 35 SVN Robot 2013-03-26 09:58:57 UTC
"hdu" committed SVN revision 1461043 into trunk:
#i119006# NSObject's performSelector:withObject expects a NSNumber argument
Comment 36 Ariel Constenla-Haile 2013-04-01 20:19:27 UTC
*** Issue 118547 has been marked as a duplicate of this issue. ***
Comment 37 Ariel Constenla-Haile 2013-04-11 13:58:09 UTC
*** Issue 122036 has been marked as a duplicate of this issue. ***
Comment 38 Scott 2013-04-19 15:54:54 UTC
so anyone know the solution for mac 10.8 because i can't see any of these folders etc mentioned here
Comment 39 Ariel Constenla-Haile 2013-04-19 16:34:25 UTC
(In reply to comment #38)
> so anyone know the solution for mac 10.8 because i can't see any of these
> folders etc mentioned here

did you take into account that the folder is *hidden*?
Comment 40 lgusaas 2013-04-19 16:45:05 UTC
(In reply to comment #38)
> so anyone know the solution for mac 10.8 because i can't see any of these
> folders etc mentioned here

For instructions go to:
http://forum.openoffice.org/en/forum/viewtopic.php?f=17&t=55755&p=258965#p244931
Comment 41 Scott 2013-04-19 21:10:09 UTC
(In reply to comment #40)
> (In reply to comment #38)
> > so anyone know the solution for mac 10.8 because i can't see any of these
> > folders etc mentioned here
> 
> For instructions go to:
> http://forum.openoffice.org/en/forum/viewtopic.
> php?f=17&t=55755&p=258965#p244931

a big thanks! we're not all tech heads here, so finding hidden folders is something i had to learn for this - and will most like forget soon after. so when giving advice all, remember, assume nothing, explain everything! cheers...it works great now! S
Comment 42 Ariel Constenla-Haile 2013-05-04 14:15:28 UTC
*** Issue 122222 has been marked as a duplicate of this issue. ***
Comment 43 Ariel Constenla-Haile 2013-05-18 20:59:43 UTC
*** Issue 122341 has been marked as a duplicate of this issue. ***
Comment 44 Ariel Constenla-Haile 2013-05-19 15:11:37 UTC
*** Issue 122344 has been marked as a duplicate of this issue. ***
Comment 45 John Maune 2013-07-16 05:38:34 UTC
Do the coders (authors?) still want files that led to this bug?  I ask because bug 119006 happened to me and I can send in the file that caused it if it would help with fixing the bug.  Let me know how to send in the file if you want the file.  That said, many times new word files  (docx)  have crashed open office many times.
thanks
Comment 46 hdu@apache.org 2013-07-16 08:47:58 UTC
AOO 4.0 has fixes to prevent the creation of the savedState files. So if AOO 4.0 is installed and the old savedState files are removed then this problem cannot reoccur.
Comment 47 Ariel Constenla-Haile 2013-07-23 23:21:48 UTC
*** Issue 121123 has been marked as a duplicate of this issue. ***
Comment 48 Rainer Bielefeld 2013-09-17 15:12:23 UTC
*** Issue 123274 has been marked as a duplicate of this issue. ***
Comment 49 Rainer Bielefeld 2013-09-17 15:14:21 UTC
*** Issue 123131 has been marked as a duplicate of this issue. ***
Comment 50 Rainer Bielefeld 2013-09-17 15:15:14 UTC
*** Issue 122960 has been marked as a duplicate of this issue. ***
Comment 51 Rainer Bielefeld 2013-09-17 15:15:59 UTC
*** Issue 122861 has been marked as a duplicate of this issue. ***
Comment 52 Rainer Bielefeld 2013-09-17 15:16:55 UTC
*** Issue 121963 has been marked as a duplicate of this issue. ***
Comment 53 Rainer Bielefeld 2013-09-17 15:18:12 UTC
*** Issue 120026 has been marked as a duplicate of this issue. ***
Comment 54 Rainer Bielefeld 2013-10-06 05:44:38 UTC
*** Issue 123430 has been marked as a duplicate of this issue. ***
Comment 55 Ariel Constenla-Haile 2013-10-16 02:34:35 UTC
*** Issue 123482 has been marked as a duplicate of this issue. ***
Comment 56 Rainer Bielefeld 2013-10-27 21:31:15 UTC
*** Issue 123560 has been marked as a duplicate of this issue. ***
Comment 57 Rainer Bielefeld 2013-11-11 11:44:39 UTC
*** Issue 123675 has been marked as a duplicate of this issue. ***
Comment 58 Rainer Bielefeld 2013-11-11 11:46:53 UTC
*** Issue 123608 has been marked as a duplicate of this issue. ***
Comment 59 mrmack1 2013-11-13 16:49:00 UTC
This problem with the Restore Windows dialog box not being able to close is in both Apache Open Office and Libre Open Office. I now have no Office program that I can use as the Restore Window does not go away when you delete the program and then reinstall, it stays! I reported this to Libre, got many bugzilla's reports but no solutions, HELP!!!
Comment 60 lgusaas 2013-11-13 17:10:55 UTC
(In reply to mrmack1 from comment #59)
> This problem with the Restore Windows dialog box not being able to close is
> in both Apache Open Office and Libre Open Office. I now have no Office
> program that I can use as the Restore Window does not go away when you
> delete the program and then reinstall, it stays! I reported this to Libre,
> got many bugzilla's reports but no solutions, HELP!!!
See comment #5:  https://issues.apache.org/ooo/show_bug.cgi?id=119006#c5

Or check this thread on the user forum:  https://forum.openoffice.org/en/forum/viewtopic.php?f=17&t=55755&p=258965
Comment 61 lgusaas 2013-12-10 23:29:37 UTC
It seem this bug is not fixed as reported. There are still people reporting the problem on the forum and on the mailing list. Several of them say they are using AOO 4.0.1.

I got a new Mac a month ago with OS X version 10.9 (Mavericks). Using AOO 4.0.1 I had the Restore Windows once. I had previously been using OS X 10.6.8 so hadn't personally experienced the problem before.
Comment 62 lgusaas 2013-12-29 18:49:35 UTC
REOPEN

This needs to be reopened. I commented on this here and the develop mailing list and this bug is still marked as fixed.There continues to reports of this bug occurring on the forum and the mailing lists. Also the recent bug reports that have been listed as duplicate.
Comment 63 Keith N. McKenna 2013-12-30 00:54:23 UTC
I agre with Larry that this should be re-opened. There are increasing reports of this occuring still with version 4.0.1 on both the mailing lists and on the forum.
Comment 64 Fredrik Alink 2014-01-03 20:34:24 UTC
Also here, this problem pops up and can't be fixed. Maverick and OO 4.01
Comment 65 Keith N. McKenna 2014-01-03 22:14:33 UTC
Given the number of reports of this bug re-accuring on 4.0.1 should we mark this as a regression?
Comment 66 Fredrik Alink 2014-01-04 11:14:27 UTC
Also, the Cmd-combinations don't work anymore: Cmd-C, Cmd-V, Cmd-F, Cmd-S, none ....
Comment 67 RobH 2014-01-12 16:28:51 UTC
Created attachment 82257 [details]
This is the message window that won't go away
Comment 68 RobH 2014-01-12 16:32:47 UTC
I've attached a screen grab of the message window that won't go away. I manually fixed it on my mac by deleting all files, except windows.plist from user/library/org.openoffice.script.savedState folder as instructed.
Comment 69 rony 2014-01-19 16:23:37 UTC
Created attachment 82318 [details]
AOO saved state causing re-open dialog to appear.

As per Andrea Pescettis request in the e-mail from 2014-01-18 on the dev list. If there is anything I should do, please let me know.
Comment 70 Andrea Pescetti 2014-01-24 20:26:16 UTC
*** Issue 124093 has been marked as a duplicate of this issue. ***
Comment 71 Ariel Constenla-Haile 2014-01-25 15:59:15 UTC
*** Issue 124110 has been marked as a duplicate of this issue. ***
Comment 72 Andrea Pescetti 2014-01-25 21:25:24 UTC
*** Issue 124101 has been marked as a duplicate of this issue. ***
Comment 73 Ariel Constenla-Haile 2014-02-21 04:51:40 UTC
*** Issue 124276 has been marked as a duplicate of this issue. ***
Comment 74 Raphael Bircher 2014-02-22 01:04:20 UTC
*** Issue 123967 has been marked as a duplicate of this issue. ***
Comment 75 hdu@apache.org 2014-02-24 09:50:27 UTC
*** Issue 123681 has been marked as a duplicate of this issue. ***
Comment 76 SVN Robot 2014-02-24 09:56:28 UTC
"hdu" committed SVN revision 1571205 into trunk:
#i119006# delay AOO/Mac initial event until the app has finished lauching
Comment 77 hdu@apache.org 2014-02-24 10:00:50 UTC
The fix committed above enables OSX to clean things up after the dialog has appeared. So after a machine reboot, app crash, forced quit, etc. the dialog will show only once and behave normally then.
Comment 78 Desiree 2014-02-26 09:30:52 UTC
Comment on attachment 82318 [details]
AOO saved state causing re-open dialog to appear.

when I open AOO a window pops up which says 
"The last time you opened OpenOffice, it unexpectedly quit while reopening windows. Do you want to try to reopen its windows again?"
I've tried clicking re-open, it does nothing, & don't re-open, it does nothing.
I Have to force quit on my Mac to get rid of the pop up window.
I've tried uninstalling AOO then re-installing it, but the window still pops up.
Comment 79 Ariel Constenla-Haile 2014-03-01 14:05:10 UTC
*** Issue 124344 has been marked as a duplicate of this issue. ***
Comment 80 Ariel Constenla-Haile 2014-03-03 17:09:10 UTC
*** Issue 124352 has been marked as a duplicate of this issue. ***
Comment 81 Ariel Constenla-Haile 2014-03-04 16:14:39 UTC
*** Issue 124358 has been marked as a duplicate of this issue. ***
Comment 82 Ariel Constenla-Haile 2014-03-06 16:31:38 UTC
*** Issue 124366 has been marked as a duplicate of this issue. ***
Comment 83 Ariel Constenla-Haile 2014-03-07 03:46:33 UTC
*** Issue 124370 has been marked as a duplicate of this issue. ***
Comment 84 Ariel Constenla-Haile 2014-03-08 10:14:14 UTC
*** Issue 124379 has been marked as a duplicate of this issue. ***
Comment 85 Ariel Constenla-Haile 2014-03-08 21:07:00 UTC
*** Issue 124382 has been marked as a duplicate of this issue. ***
Comment 86 Ken Kaiser 2014-03-09 20:35:30 UTC
I had a window popping up saying "The last time you opened Open Office it unexpectedly quit........etc etc" I followed the steps in this thread,and PROBLEM SOLVED!
Comment 87 hdu@apache.org 2014-03-10 07:57:26 UTC
*** Issue 123237 has been marked as a duplicate of this issue. ***
Comment 88 Brian Croner 2014-03-12 17:54:55 UTC
Comment on attachment 82257 [details]
This is the message window that won't go away

I have this problem too.
Comment 89 Ken Kaiser 2014-03-12 18:34:20 UTC
Option-click the Go menu in Finder
Choose Library from the menu to open the folder in the Finder.(hold the alt key to get Library option)
Click on the folder Saved Application State
Delete the file org.openoffice.script.savedState
Comment 90 jgc 2014-03-17 05:53:26 UTC
The bug fix works only once.  Then the problem returns with the Restore Window Prompt.  I cannot save, save as, save all, export nor copy any of my files.  What gives
Comment 91 jsc 2014-03-17 09:19:59 UTC
comment 90: your comment is not useful in any way and we would need some more info. If your document crash the office for whatever reason this is a different problem and please submit a new issue with attached crashing test documents. 

The fix is simply to allow closing of this restore window which was not possible before.
Comment 92 jsc 2014-03-18 08:31:28 UTC
verified on 10.7 and 10.9.2
Comment 93 Keith N. McKenna 2014-03-22 23:06:52 UTC
*** Issue 124485 has been marked as a duplicate of this issue. ***
Comment 94 Justine 2014-03-23 15:15:11 UTC
re Comment 28 
It Worked !!!!


My fix above disables the OSX>=10.7 window restoration and the resulting problem that this mechanism is not handled yet. This should prevent the problem caused by OSX creating the restoration status file named:
~/Library/Saved Application State/org.openoffice.script.savedState

I've been battled this for weeks.

Working on Mac Osx 10.9.2 Open office had the (last time you used OO it crash do you want to reopen loop) Yes but clicking didnt work.
I removed the Saved state file described aboved downloaded a new version and hey presto all docs back and no reopne sign PHEW !!! 

Big Big thank you x
Comment 95 jsc 2014-03-28 12:59:42 UTC
*** Issue 110914 has been marked as a duplicate of this issue. ***
Comment 96 Ariel Constenla-Haile 2014-04-05 22:53:56 UTC
*** Issue 124612 has been marked as a duplicate of this issue. ***
Comment 97 Rainer Bielefeld 2014-04-06 10:41:33 UTC
*** Issue 124616 has been marked as a duplicate of this issue. ***
Comment 98 hdu@apache.org 2014-04-07 09:40:40 UTC
*** Issue 124602 has been marked as a duplicate of this issue. ***
Comment 99 j.nitschke 2014-04-07 16:05:57 UTC
*** Issue 120862 has been marked as a duplicate of this issue. ***
Comment 100 hdu@apache.org 2014-04-09 11:54:23 UTC
*** Issue 124598 has been marked as a duplicate of this issue. ***
Comment 101 Ariel Constenla-Haile 2014-04-11 18:39:40 UTC
*** Issue 124663 has been marked as a duplicate of this issue. ***
Comment 102 cslaude 2014-04-11 19:34:59 UTC
fixed with computer restart (for me)
Comment 103 Ariel Constenla-Haile 2014-04-15 14:31:13 UTC
*** Issue 124690 has been marked as a duplicate of this issue. ***
Comment 104 Oliver-Rainer Wittmann 2014-04-17 12:58:51 UTC
*** Issue 124700 has been marked as a duplicate of this issue. ***
Comment 105 Ariel Constenla-Haile 2014-04-27 21:20:15 UTC
*** Issue 124753 has been marked as a duplicate of this issue. ***
Comment 106 Ariel Constenla-Haile 2014-04-29 06:43:23 UTC
*** Issue 124767 has been marked as a duplicate of this issue. ***
Comment 107 Keith N. McKenna 2014-04-30 22:05:55 UTC
*** Issue 124785 has been marked as a duplicate of this issue. ***
Comment 108 Rainer Bielefeld 2014-05-13 15:21:29 UTC
*** Issue 124885 has been marked as a duplicate of this issue. ***
Comment 109 Hazel Denvir 2014-06-02 17:01:38 UTC
I have this problem too. I cant open my docs. Tried trashing Open Office and downlaoded again - same bug.