Issue 118997 - adapt help to new color picker
adapt help to new color picker
Status: RESOLVED FIXED
Product: documentation
Classification: Unclassified
Component: Online help
OOo 3.4 Beta
All All
: P3 normal (vote)
: AOO 4.0
Assigned To: Ariel Constenla-Haile
:
: 120317 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-29 21:02 UTC by Regina Henschel
Modified: 2013-03-07 03:43 UTC (History)
2 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Help changes for file text/shared/optionen/01010500.xhp (1.99 KB, patch)
2012-03-01 19:29 UTC, Uwe Fischer
no flags Details | Diff
Help changes for file text/shared/optionen/01010501.xhp (12.90 KB, patch)
2012-03-01 19:30 UTC, Uwe Fischer
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description Regina Henschel 2012-02-29 21:02:56 UTC
The actual version AOO3.4 has got a new color picker, see issue 118828. But the help is not adapted and still refers the old dialog. The file to be changed is /text/shared/optionen/01010501.xhp.
You get this text in the help via index 'color;defining and saving' and then near the bottom of the text the link 'color dialog'.
Comment 1 Uwe Fischer 2012-03-01 18:01:12 UTC
I'll try to fix this and provide a diff file.
Comment 2 Uwe Fischer 2012-03-01 19:29:47 UTC
Created attachment 77266 [details]
Help changes for file text/shared/optionen/01010500.xhp
Comment 3 Uwe Fischer 2012-03-01 19:30:35 UTC
Created attachment 77267 [details]
Help changes for file text/shared/optionen/01010501.xhp
Comment 4 Uwe Fischer 2012-03-01 19:34:02 UTC
Patched Help files "should" work. Have no way to build modules for testing :(
Can some friendly soul please test and submit?
Comment 5 Regina Henschel 2012-03-01 20:37:31 UTC
Hi Uwe, some comments:

The preview is now the other way round. The left part is the new color, and the right part is the original one. (id="par_id3154164")

I'm not sure whether in id="par_id31400044" and id="par_id3148944" it is really clear that this property is locked, when selecting a color in the left big field. Perhaps add: "All colors in the left, big field will contain the property which is set by the color slider."

Rethink paragraph id="par_id3148944"? The essential problem is, that it is not possible to _store_ color values in other models, but it must be RGB.

What do you reference with <comment>UFI: is this still true?</comment> before bookmark id="bm_id3159152"?
Comment 6 Marcus 2012-03-01 21:17:17 UTC
Uwe, thanks for your help. I've set this issue to "Patch" to indicate to integrate the text into SVN.
Comment 7 Uwe Fischer 2012-03-02 08:24:20 UTC
Regina, thank you for your comments. These two patches and the one in 118979 were my first attempts in creating patches. Instead of the following two header lines:

--- 01010500.xhp	Mon Feb 27 11:50:42 2012
+++ new01010500.xhp	Thu Mar 01 19:13:30 2012

there should be instead these two lines to get the file names right:

--- old01010500.xhp	Mon Feb 27 11:50:42 2012
+++ 01010500.xhp	Thu Mar 01 19:13:30 2012

The patch view of Bugzilla only shows the correct file name on top, then the old file contents at the left and the new contents at the right. So I suppose Bugzilla gets it right, the patch will change the existing file and not create a new one. 
I cannot open the second patch attachment for viewing now. Don't know why. Would it be better to have both file patches in one patch file? But then I would have to find out how to include the complete path of the files (starting from where?)

I inserted the comment because I'm not sure about the CMYK and RGB handling. The line above the comment says this:

"%PRODUCTNAME uses only the RGB color model for printing in color. The CMYK controls are provided only to ease the input of color values using CMYK notation."

This is about printing, not storing, of color values.
It would be fine to write a guide or tutorial describing the new Color Picker and the handling of colors. However, I don't know too much about this at the moment.
Comment 8 Ariel Constenla-Haile 2013-03-07 01:52:47 UTC
*** Issue 120317 has been marked as a duplicate of this issue. ***
Comment 9 Ariel Constenla-Haile 2013-03-07 01:53:50 UTC
Reopening. The patches were never applied.
Comment 10 Ariel Constenla-Haile 2013-03-07 01:54:34 UTC
Compiling and testing.
Comment 11 SVN Robot 2013-03-07 03:43:15 UTC
"arielch" committed SVN revision 1453677 into trunk:
i118997 - Adapt Online Help to new Color Picker