Issue 118813 - Slide Preview ignores Landscape Page Layout
Slide Preview ignores Landscape Page Layout
Status: CLOSED FIXED
Product: Draw
Classification: Application
Component: code
OOo 3.4 Beta
All All
: P3 normal (vote)
: 4.0.0
Assigned To: Andre
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-18 12:28 UTC by hdu@apache.org
Modified: 2013-02-22 21:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: 3.4.1
Developer Difficulty: ---


Attachments
wrong border for page changed to landscape (15.08 KB, image/png)
2012-01-18 12:28 UTC, hdu@apache.org
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hdu@apache.org 2012-01-18 12:28:31 UTC
Created attachment 77144 [details]
wrong border for page changed to landscape

1. Open the Draw Application
2. Change the Page Orientation to Landscape
=> the slide preview on the left side looks strange as only the content area has been updated but the border remained unchanged
Comment 1 SVN Robot 2012-07-11 12:17:53 UTC
"af" committed SVN revision 1360139 into trunk:
#i118813# Update slide sorter after page format is modified.
Comment 2 Andre 2012-07-11 12:21:00 UTC
The bug was caused by PageObjectPainter using an old PageObjectLayouter, that still used page size values before the change of the page format.

Fixed by updating the PageObjectPainter::mpPageObjectLayouter member when PageObjectPainter::NotifyResize() is called.
Comment 3 Andre 2012-07-11 12:22:05 UTC
Status update got lost due to midair collision with robot.
Comment 4 Javier Lopez 2013-02-16 01:32:31 UTC
Bug not found in W7 64 bit with version 3.4.1 AOO

Javier Lopez
Comment 5 hdu@apache.org 2013-02-18 09:11:54 UTC
Thanks for verifying! Closing as "resolved fixed" then.
Comment 6 hdu@apache.org 2013-02-18 09:13:01 UTC
Got into trunk (for AOO 4.0)
Comment 7 DanielAlvaro 2013-02-22 21:55:05 UTC
Hello,  I  was chcking this problem in  AOO 4.00 and  I  didn't find anything,

Regards .