Issue 116162 - Filling of combined curves are missing when black and white printing is selected
Filling of combined curves are missing when black and white printing is selected
Status: CLOSED FIXED
Product: Impress
Classification: Application
Component: printing
OOO320m19
All All
: P3 trivial (vote)
: 4.0.0
Assigned To: AOO issues mailing list
issues@graphics
:
: 120075 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-17 21:04 UTC by diegodlh
Modified: 2013-07-10 15:09 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
odp sample file with four random arrowhead lines (9.79 KB, application/vnd.oasis.opendocument.presentation)
2010-12-17 21:09 UTC, diegodlh
no flags Details
"Print to a file" .ps file obtained from Arrowhead.odp attached above (22.32 KB, application/pdf)
2010-12-17 21:10 UTC, diegodlh
no flags Details
Drawing with combined circles (9.66 KB, application/vnd.oasis.opendocument.graphics)
2012-10-21 23:53 UTC, Regina Henschel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description diegodlh 2010-12-17 21:04:36 UTC
When black and white printing is enabled, arrowheads do not print. To reproduce, 
follow these steps:
1) Create a new empty slideshow.
2) Draw a line with an arrowhead at the end (trying to figure out what it would 
be in English, since I am using another language version).
3) File > Print > Options, Black and White, Accept.
4) Accept.
The printout does not have arrowheads.
I shall say I have had this problem for a while. I was hesitant whether to post 
it or not, but for months I haven't been able to find anyone else reporting 
this. It doesn't happen with any of the other two printing options (ie. default 
or grayscale).
Comment 1 diegodlh 2010-12-17 21:09:12 UTC
Created attachment 75366 [details]
odp sample file with four random arrowhead lines
Comment 2 diegodlh 2010-12-17 21:10:41 UTC
Created attachment 75367 [details]
"Print to a file" .ps file obtained from Arrowhead.odp attached above
Comment 3 wolframgarten 2010-12-20 11:38:36 UTC
Reproducible in OOO330_m18. Reassigned.
Comment 4 Regina Henschel 2012-10-21 23:53:17 UTC
Created attachment 79805 [details]
Drawing with combined circles

It does occur for other polypolygon objects too.
Comment 5 Regina Henschel 2012-10-21 23:55:05 UTC
No action since nearly two years, set back to default owner.
Comment 6 Regina Henschel 2012-10-22 00:02:34 UTC
Chance summary to reflect the more general problem.
Comment 7 Regina Henschel 2012-10-22 00:04:34 UTC
*** Issue 120075 has been marked as a duplicate of this issue. ***
Comment 8 Armin Le Grand 2012-10-22 09:07:17 UTC
ALG: Took a short look; the printer dialog (not only in tools/options, but in the new printer dialog with preview directly testable) sets SdOptionsPrint::SetOutputQuality to 2 (B&W).- That triggers in PreparePages to set aInfo.mnDrawMode = DRAWMODE_BLACKLINE | DRAWMODE_BLACKTEXT | DRAWMODE_WHITEFILL | DRAWMODE_GRAYBITMAP | DRAWMODE_WHITEGRADIENT;

This again seems to avoid some things, looking further...
Comment 9 Armin Le Grand 2012-10-22 11:13:58 UTC
ALG: SOmeone seems to set drawmode to DRAWMODE_WHITEFILL, so the arrow is white filled and thus by default not visible on default page background. Preparing SD with debug to see why this happens...
Comment 10 Armin Le Grand 2012-10-22 11:28:43 UTC
ALG: Checking with SD shows that this is by purpose: The B&W drawmode *is* by default defined as described in comment8. This is probably to make all filled objects look lighter in B&W mode. Unfortunately, non-outlined objects will completely vanish with that mode.

Thus, the answer is: The fillings do *not* vanish, but all fills are forced to white fill in B&W mode.
Comment 11 Armin Le Grand 2012-10-22 13:36:05 UTC
ALG: There is a chance to detect when polygon actions in a metafile are part of a line geometry using the comment action (hacks) XPATHSTROKE_SEQ_BEGIN/XPATHSTROKE_SEQ_END. This would allow during replay of a metafile to detect polygons which are part of a line geometry and to switch DRawMode on the target OutputDevice from DRAWMODE_WHITEFILL to DRAWMODE_BLACKFILL which would be better for line geometries, esp. since DRAWMODE_BLACKLINE is used. All this should only be done when DRAWMODE_WHITEFILL is active. Caution, this will not be done on all places where Metafiles are replayed (there are some) and it will vanish again when that comment action hacks may be removed one day. Trying if this is possible...
Comment 12 Armin Le Grand 2012-10-22 15:12:19 UTC
ALG: Added code to the MteaFile primitive processor to switch DRAWMODE_WHITEFILL to DRAWMODE_BLACKFILL during processing line geometry sub-content. Works well. Some more tests...
Comment 13 SVN Robot 2012-10-22 15:15:47 UTC
"alg" committed SVN revision 1400911 into trunk:
#116162# Forced DRAWMODE_WHITEFILL to DRAWMODE_BLACKFILL during line geometry...
Comment 14 Armin Le Grand 2012-10-22 15:16:07 UTC
ALG: Okay, checked in, done.
Comment 15 Li Feng Wang 2012-11-08 09:13:45 UTC
Can't reproduce on build r1404513.
Verify pass.
Comment 16 hdu@apache.org 2013-07-10 15:09:48 UTC
adjusted target to version that will contain the fix