Issue 115944 - Can't open pptx in Impress
Can't open pptx in Impress
Status: VERIFIED FIXED
Product: Impress
Classification: Application
Component: open-import
OOo 3.3 RC7
All All
: P2 trivial (vote)
: OOo 3.3
Assigned To: wolframgarten
issues@graphics
: needmoreinfo
Depends on:
Blocks: 111112
  Show dependency treegraph
 
Reported: 2010-12-06 13:57 UTC by myoder
Modified: 2011-01-06 09:46 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
pptx file for issue 115944 (3.83 MB, text/plain)
2010-12-06 14:00 UTC, myoder
no flags Details
a new attachment (7.06 MB, text/plain)
2010-12-08 12:00 UTC, myoder
no flags Details
A basic macro that shows that the ooo storage api implementation can indeed open "slideLayout44.xml.rels" correctly (590 bytes, text/plain)
2011-01-03 13:06 UTC, clippka
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description myoder 2010-12-06 13:57:03 UTC
Tried to open a PPTX made in office 2007 and an error occurred in
opening/converting the file.  It asked to recover the file but nothing happened.
 An earlier issue was closed similar to this because of lack of information.
Comment 1 myoder 2010-12-06 14:00:27 UTC
Created attachment 75249 [details]
pptx file for issue 115944
Comment 2 wolframgarten 2010-12-06 14:12:31 UTC
Opening the file in PPT2007 works. Opening the file in OOO330_m17 crashes the
Office. I have saved a copy of the file with a new name in PPT2007 and this new
copy can be opened wihtout problems in OOO330_m17. Please have a try if this
solves your problem.
Comment 3 myoder 2010-12-07 11:53:32 UTC
Sent auto report after trying to open file this morning (Dec 7. 6:30 am US
Eastern Time).  This crash was from 3.3.0 RC 7 OOO330m17 Build:9551    
Comment 4 wolframgarten 2010-12-07 11:55:16 UTC
Did you try to save it under an new name and open the new file?
Comment 5 myoder 2010-12-07 22:27:22 UTC
I did not try and resave it .  I was sent this file and do not have office 2007.
 I had them resend it under 2003 format and I could open it.  Do you know what
is wrong with the name?  Using the same name but under 2003 ppt format it opened
fine.
Comment 6 wolframgarten 2010-12-08 07:51:00 UTC
I think that re-saving the file fixes a problem in the file. In my opinion the
origianl fiel is broken somehow and a new save fixes this.
Comment 7 wolframgarten 2010-12-08 07:52:39 UTC
The orignial fiel crashes OOo. Reassigned. Any idea to this crash, sj?
Comment 8 myoder 2010-12-08 11:58:55 UTC
I had a friend re-save the original file with the same name and re-save the
original file with a new name using office 2007.  In both cases Impress crashed
about half through the progress bar.  I added a new file called renamed-resaved.zip
Comment 9 myoder 2010-12-08 12:00:01 UTC
Created attachment 75275 [details]
a new attachment
Comment 10 myoder 2010-12-19 15:19:35 UTC
Tried original file in 3.3.0 rc8 and it still crashed on conversion.
Comment 11 clippka 2010-12-21 15:37:40 UTC
had a quick look, problem is that
"ppt/slideLayouts\_relsßslideLayout44.xml.rels" is not readable by our storage
implementation. This leads to a crash in
PresentationFragmentHandler::endDocument() while accessing empty reference
pMasterPersistPtr in line 251.

My guess is that there is either a nonstandard zip encoding used for that file
or maybe the file is locked somewhere else.
Comment 12 myoder 2010-12-21 17:21:46 UTC
Contacted the author of the file.  They did nothing out of the ordinary in
creating the file except using Power Point 2007 and saving it as a pptx.  She
saved the same file as a  Power Point 2003 ppt format by doing the save as in
Power Point and I could open that.  The file was not compressed but downloaded
from the company ftp site.
Comment 13 clippka 2011-01-03 13:06:33 UTC
Created attachment 75465 [details]
A basic macro that shows that the ooo storage api implementation can indeed open "slideLayout44.xml.rels" correctly
Comment 14 clippka 2011-01-03 14:05:50 UTC
The problem happens since we open the zip package in 'repair' mode.
To reproduce with my Basic macro change the following

	Dim aProps(1) as new com.sun.star.beans.PropertyValue
	aProps(0).Name = "StorageFormat"
	aProps(0).Value = "ZipFormat"
	aProps(1).Name = "RepairPackage"
	aProps(1).Value = true

Mikhail is currently investigating
Comment 15 clippka 2011-01-05 14:39:30 UTC
fixed in cws impress208, thanks mav
Comment 16 clippka 2011-01-05 14:42:02 UTC
verified in cws, back to qa
Comment 17 clippka 2011-01-05 14:47:19 UTC
fixed target
Comment 18 wolframgarten 2011-01-06 09:46:50 UTC
Verified in CWS.