Issue 115247 - slideshow in impress on netbook does not work
slideshow in impress on netbook does not work
Status: UNCONFIRMED
Product: Impress
Classification: Application
Component: viewing
OOo 1.0.0
Unknown Windows XP
: P3 trivial (vote)
: ---
Assigned To: AOO issues mailing list
: needmoreinfo
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-25 22:06 UTC by edtrost
Modified: 2013-02-02 02:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Simple Slide (11.28 KB, application/vnd.oasis.opendocument.presentation)
2011-09-24 22:49 UTC, Chris Chartier
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description edtrost 2010-10-25 22:06:58 UTC
slideshow in impress on netbook does not work..it works on laptop
Comment 1 wolframgarten 2010-10-26 08:53:16 UTC
Please try to disable Tools/options/View/graphics output/ hardware acceleration.
Comment 2 Chris Chartier 2011-09-24 22:49:44 UTC
Created attachment 76812 [details]
Simple Slide
Comment 3 Chris Chartier 2011-09-24 22:51:51 UTC
Bug 115247 follow-up
--------------------

Testing Configuration:
----------------------
Open Office – Dev 3.40 (DEV300m106 – Build: 9582)
Netbook: ASUS 1018PB-BK801
OS: Windows 7 Starter (SP1)
CPU: Intel Atom N450 (1.66 GHz w/ 512KB L2 Cache)
Memory: 1 GB
HD: 217 GB (188 GB free)
Video: Intel® Graphics Media Accelerator 3150 (Video BIOS 1933.0, 1024x600)


Note- This bug has duplicates (or very similar) issues. 
Reference:
Bug Report 110894 (2010-04-14) https://issues.apache.org/ooo/show_bug.cgi?id=110894
Bug Report 113953 (2010-08-18) https://issues.apache.org/ooo/show_bug.cgi?id=113953
This (115247) bug report dated 2010-10-25.

Replication:
------------
Replication is hardware specific as a netbook is required. It's difficult to know if I definitively replicated the bug described in this original report as it is so brief and lacking in details. From my experience, I was only able to replicate the bug first time after OO is installed (assuming I replicated what the original reporter saw).

Note: I was ONLY able to reproduce *one time*, and only after the first install of Open Office. Re-installing Open Office did not seem to replicate the bug again.

The original report contains follow-up information from someone on the OO team suggesting to turn off hardware acceleration. So I used that as a variable during testing.

Steps to replicate
-------------------------------------------------
1. Installed Open Office
2. Ensured Hardware Acceleration is turned on (should be by default)
	(Tools->Options->View, "Use hardware acceleration" checked)
3. Opened Impress
3. Created new blank presentation
4. Added simple text slide (title text box and text box in main slide area)
	* See attachment SS1.odp
5. Pressed F5 to go to presentation mode
6. Screen went black and did not display slide.
7. Waited for approximately 20-30 seconds, pressed <ESC> to exit presentation mode
8. After ~10-20 more seconds, received Windows warning the program was not responding
9. Clicked "Wait for program to finish" option
10. Impress stayed black for about 2 minutes before exiting back into edit mode
11. Went to menu Tools->Options->View and unchecked "Use Hardware Acceleration"
12. Pressed F5
13. Slide presented normally
14. Pressed <ESC> to exit back to edit mode
15. Went to menu Tools->Options->View and checked "Use Hardware Acceleration"
16. Pressed F5 again
17. Slide presented normally
18. Pressed <ESC> to exit back to edit mode
19. Took longer than expected to exit to edit mode (~15 seconds)
---------------------------------------------------

I then tried to find other ways to make this bug appear again in order to get more 
detail to aid the debugging process.

Follow-Up Test 1 
  (Checking to see if was unique to initial program startup state)
----------------
1. Exit program
2. Restart Program
3. Open file SS1.odp (attached) from OO main Window
4. Press F5
5. Slided presented normally

Follow-Up Test 2
  (Checking to see if it only happens right after install)
----------------
1. Uninstall Open Office
2. Reinstall Open Office
3. Open file SS1.odp (attached) from OO main window
4. Press F5
5. Delay (black screen) for about 10 sec, but then slide did display
6. <ESC> to go back to edit mode
7. Tools->Options->View, Turn off hardware acceleration
8. Press F5
9. Slide presented normally
10. <ESC> to go back to edit mode
11. Tools->Options->View, Turn on hardware acceleration
12. Press F5
13. Slide presented normally
14. <ESC> to go back to edit mode
* Note: Tried this a few other times and did not notice initial delay (step 5)

Follow-Up Test 3 
  (Checking to see if it some Windows setting that would clear on reboot)
----------------
1. Exit Open Office
2. Reboot computer
3. Open file SS1.odp (attached) from OO main window
4. Press F5
5. Slide presented normally
6. <ESC> to go back to edit mode
7. Tools->Options->View, Turn off hardware acceleration
8. Press F5
9. Slide presented normally
10. <ESC> to go back to edit mode
11. Tools->Options->View, Turn on hardware acceleration
12. Press F5
13. Slide presented normally
14. <ESC> to go back to edit mode

Summary
-------
Let me be clear. I was only able to reproduce this bug on first try on the first install of Open-Office for this netbook. I was not able to reproduce this bug again. Upon further investigation, such as from the other similar reports, it seems likely that video card/driver and screen resolution may have a strong correlation to the error. There are some other follow-up tests that may be good tests to gain more information from.

Further Follow-Up tests that may give more information:
1. Try to disable hardware acceleration in Windows versus the setting in Open Office
	- See if it is strictly hardware acceleration that is the issue
2. Try testing with different screen resolutions, particularly around what is stated by OO as the minimum screen resolution.
	- Try to determine if the problem is directly related to the minimum screen resolution
3. Try differet video cards
	- See if the issue is related only to specific video hardware

	
Impact
------
Product Comparison
Note, I tried this test (and other more rigorous versions) of it in Powerpoint and never
had an issue in MS Powerpoint. Open Office is designed to be an equal replacement for Microsoft Office, so for Open Office to be considered an equivalent product , this bug should be addressed.

It has affected a number of users already as evidenced by the multiple reports on the same issue. It seems that this issue will continue to affect more and more users as netbooks are becoming more common place ( http://gigaom.com/2010/03/09/the-rise-of-netbooks/ ).

Product comparison of minimum published screen resolution shows that OO reports a higer minim screen resolution as well (very related issue as resolution is lower on netbooks):

Open Office (Windows) minimum screen resolution requirements (1024 x 768)
http://www.openoffice.org/dev_docs/source/sys_reqs_30.html

Powerpoint minimum screen resolution requirements (1024 x 576)
http://technet.microsoft.com/en-us/library/ee624351.aspx#section11

This seems to be a problem as many netbooks natively display at 1024x600.


Alternative Solution
-----------------------------
If a solution can not be readily found, an easy workaround solution solution may be to query  for the screen resolution (during installation). If a resolution is found that does not meet the minimum requirements, then display a message noting that hardware acceleration should be turned off if this is a netbook. In fact, it may be a good idea to just turn off that option by default, during installation, if the resolution is below minimum requirements with no message.
Comment 4 Rob Weir 2013-02-02 02:57:27 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.