Issue 11149 - Make ODBC/SQL types 64-bit clean
Make ODBC/SQL types 64-bit clean
Status: CLOSED FIXED
Product: porting
Classification: Code
Component: code
OOo 1.0.2
PC Linux
: P4 trivial (vote)
: OOo 2.0
Assigned To: Martin Hollmichel
issues@porting
:
: 25590 (view as issue list)
Depends on:
Blocks: 8577
  Show dependency treegraph
 
Reported: 2003-02-03 10:19 UTC by gbeauche
Modified: 2004-02-20 10:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Fix odbc headers (patch patch approach) (2.07 KB, patch)
2003-02-03 10:19 UTC, gbeauche
no flags Details | Diff
Define SQL types properly also on 64bit platforms with 8-byte long type (1.63 KB, patch)
2003-11-16 14:58 UTC, pavel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description gbeauche 2003-02-03 10:19:02 UTC
Hi,

Interface for the odbc drivers is currently not 64-bit clean as used by OOo. I
would suggest to update the unixODBC tarball to a more recent version, that
includes the necessary 64-bit fixes for alpha and sparcv9 only though.

The attached patch should better suit the normal OOo patch of external sources
process but I wanted a patch containing a patch instead of regenerating the .pat
tarball. BTW, any reason why odbcpatch.sh no longer patches things?
Comment 1 gbeauche 2003-02-03 10:19:59 UTC
Created attachment 4542 [details]
Fix odbc headers (patch patch approach)
Comment 2 Martin Hollmichel 2003-02-03 14:31:25 UTC
external/odbc is quite old now, for 644 and later we use the unixODBC
module.
Comment 3 Martin Hollmichel 2003-04-11 16:22:47 UTC
reseting prio since no standard platform, but target is 1.1
Comment 4 Martin Hollmichel 2003-04-23 13:03:36 UTC
move target milestone to 1.1
Comment 5 Martin Hollmichel 2003-06-03 14:26:09 UTC
retarget to post 1.1 release
Comment 6 Martin Hollmichel 2003-10-09 09:50:49 UTC
reset target milestone
Comment 7 pavel 2003-11-16 14:56:36 UTC
external/odbc is no longer used. I "ported" this patch to unixODBC.
Attached.

Comment 8 pavel 2003-11-16 14:58:02 UTC
Created attachment 11310 [details]
Define SQL types properly also on 64bit platforms with 8-byte long type
Comment 9 pavel 2003-12-28 13:42:13 UTC
Please approve the attached patch (OOo_1.1.0_source-X86_64-only-unixODBC.diff)
for 20031216.
Comment 10 fa 2003-12-30 05:41:38 UTC
Looks OK to me, as it only changes 64-bit platform code...  Approved to commit to fix2 branch.
Comment 11 fa 2003-12-30 05:50:06 UTC
Eh, are you looking to commit to 680?  If so fine, approved for whatever.
Comment 12 pavel 2003-12-30 08:08:08 UTC
Fixed in cws_src680_ooo20031216.
Comment 13 pavel 2004-02-16 22:19:54 UTC
*** Issue 25590 has been marked as a duplicate of this issue. ***
Comment 14 Martin Hollmichel 2004-02-20 10:57:09 UTC
close issue.