Issue 110497 - Open Office Base crashes on save then recovery fails
Open Office Base crashes on save then recovery fails
Status: UNCONFIRMED
Product: Base
Classification: Application
Component: ReportBuilder
OOo 1.0.0
Mac Mac OSX, all
: P3 trivial (vote)
: ---
Assigned To: AOO issues mailing list
: needmoreinfo, oooqa
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-30 16:52 UTC by iwmackee
Modified: 2013-02-07 22:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description iwmackee 2010-03-30 16:52:04 UTC
I am using Open Office 3.2.0 on Mac OS X 10.62; Sun Report Builder 1.2.0 is
installed but it is otherwise the basic open office base. The very useful Sun
Report Builder tends to be associated with recoverable crashes but, to save
losing too much work, I have saved not only the reports but also the whole database.
On two occasions, the report save went OK but after clicking on the save icon at
the top of the database window there was, after a brief hesitation, a crash. On
going through the recovery procedure there was, on the first occasion, a brief
message saying that the backup file could not be found. On the second occasion
there was no such message but on both occasions the result was the same -
recovery failed.
Following these happenings, the database file becomes unusable - it has lost its
file association and even if you pick ODF Database from the list presented, the
file will not load with data, you only get a blank database.
Fortunately it was possible to restore the database from backups with only
limited data re-entry being required. Please not that I am not a professional
computer person.
Comment 1 r4zoli 2010-08-20 12:09:26 UTC
@ iwmackee 
This problem still happens in OOo 3.2.1?
Comment 2 iwmackee 2010-08-23 12:03:50 UTC
Since upgrading to Open Office 3.2.1 there has been no further instance of an
unrecoverable crash, to date. The only problem with 3.2.1 relates to another
issue http://www.openoffice.org/issues/show_bug.cgi?id=108299. This does not
necessarily mean that the problem has gone away because I have not had the need
to alter form format to the same degree, recently. I will try to provoke the bug
and will notify if there is a problem.
Comment 3 Rob Weir 2013-02-02 02:59:58 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.