Issue 108689 - Buttons "Cut", "Copy" not active when the text is selected in the Basic IDE
Buttons "Cut", "Copy" not active when the text is selected in the Basic IDE
Status: RESOLVED FIXED
Product: App Dev
Classification: Unclassified
Component: scripting
OOo 3.3 or older
All All
: P4 trivial
: 4.0.0
Assigned To: Ariel Constenla-Haile
Unknown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-26 18:23 UTC by fyva
Modified: 2013-07-21 10:06 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description fyva 2010-01-26 18:23:35 UTC
The buttons "Cut", "Copy" on the panel are not active. Open Basic IDE, type some
text, select it and look on the buttons on the panel. In the "Edit" menu all
these shortcuts are active.
Comment 1 kay.ramme 2010-01-29 07:58:38 UTC
@fyva: You are right, same here.

Andreas, please have a look.
Comment 2 ab 2010-02-09 14:03:43 UTC
-> P4, OOo Later, STARTED
Comment 3 mdxonefour 2011-01-25 10:27:31 UTC
Looks like the buttons "copy" and "cut" have never been working. At least I went
back till the good old OOo 2.2 release. They were already not working there.

May be this issue is related to the same root cause as issue 115671 and/or issue
108119.
Comment 4 salva 2012-09-18 09:17:25 UTC
Copy and Cut buttons still do not work properly in Apache OpenOffice 3.4.1
Comment 5 Ariel Constenla-Haile 2012-09-18 09:34:50 UTC
(In reply to comment #4)
> Copy and Cut buttons still do not work properly in Apache OpenOffice 3.4.1

I also find some strange behavior with the "Save" toolbar button, when the macro is inside a document.

The most obvious example:

- File - New - Text document
- From the text document, select "Tools" - "Macros" - "Organize macros..." - "OpenOffice.org Basic..."
- Press the "New" button, it will open the Basic IDE

In this state, the "Save" button is enabled in both the document window and the IDE window (adding a new macro to the document sets its status to modified).

- Go to the document, and save it

After saving it, the "Save" button on the document window grays out == it's disabled. But on the IDE window it is still enabled.
Comment 6 SVN Robot 2012-10-07 11:48:00 UTC
"arielch" committed SVN 0 into trunk:
#i108689# - Invalidate Basic IDE slots in order to trigger feature update
Comment 7 Ariel Constenla-Haile 2012-10-07 11:50:42 UTC
Fixed in trunk.
You can try with tomorrow nightly builds.
Please test:
- dialog editor: de/selecting with the mouse, with keyword (tab key cycles through the dialog and it controls, escape key deselects)
- basic editor: de/selecting text with the mouse and with the keyword.