Issue 107809 - cannot find SeaMonkey 2.0 addressbook data source
cannot find SeaMonkey 2.0 addressbook data source
Status: VERIFIED FIXED
Product: Base
Classification: Application
Component: code
OOO310m19
Unknown All
: P3 trivial with 1 vote (vote)
: 3.4.0
Assigned To: marc.neumann
issues@dba
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-21 12:06 UTC by cchayka
Modified: 2011-05-26 20:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Screenshot of 3.3.0 error (100.76 KB, image/png)
2011-02-08 18:00 UTC, noop
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description cchayka 2009-12-21 12:06:35 UTC
I recently upgraded from SeaMonkey 1.1.19 to 2.0. The profile directory naming
convention has changed and Oo can no longer find the addressbook data source.
When attempting to manually register the addressbook source, selecting either
Mozilla/Netscape or Thunderbird as the addressbook type results in a "no
directories exist" error.

Old profile directory: path/to/profile/<user>/<salt>.slt
New profile directory: path/to/profile/<salt>.<user>
Comment 1 Frank Schönheit 2010-02-01 21:03:51 UTC
confirming, grabbing, targeting
Comment 2 nevilledaniels 2010-05-21 12:46:42 UTC
This certainly occurs under Windows Vista and Windows 7.

The common directory is
C:\Users\Andrew\AppData\Roaming\Mozilla\SeaMonkey\Profiles\vyeaklls.default 

However this is a variable vyeaklls.default profile folder (letters changed)
The *.mab files are the address books.
Comment 3 cchayka 2010-05-21 14:09:06 UTC
"The common directory is
C:\Users\Andrew\AppData\Roaming\Mozilla\SeaMonkey\Profiles\vyeaklls.default"

Just to be clear, the profile location can be changed by the user so it could be
anywhere. Mine is in a different path altogether, not on the C: drive.

In the above location, "vyeaklls" is the <salt> and "default" is <user>.

Comment 4 noop 2010-07-31 01:48:09 UTC
Same issue with OOO320m18 (linux) + SeaMonkey 2.0.6. Path to SeaMonkey is:
~/.mozilla/seamonkey

OOo is picking up the appropriate path for Thunderbird (linux) at:
~/.thunderbird

What file contains the default paths?
Comment 5 Frank Schönheit 2010-09-15 07:22:00 UTC
fs->msc: please verify in CWS dba34a
Comment 6 Frank Schönheit 2010-09-15 07:23:58 UTC
oops, wrong script. Grabbing back.
Comment 7 Frank Schönheit 2010-09-15 07:24:38 UTC
fixed in CWS dba34a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300/dba34a
Comment 8 Frank Schönheit 2010-09-24 08:39:38 UTC
targeting to 3.4, since the fix is part of a CWS which aims for this release
Comment 9 Frank Schönheit 2010-09-24 08:40:39 UTC
targeting to 3.4, since the fix is part of a CWS which aims for this release
Comment 10 Frank Schönheit 2010-09-24 08:41:33 UTC
targeting to 3.4, since the fix is part of a CWS which aims for this release
Comment 11 Frank Schönheit 2010-09-29 09:36:14 UTC
fs->msc: please verify in CWS dba34a
Comment 12 marc.neumann 2010-11-03 10:14:10 UTC
verified in CWS dba34a

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300/dba34a
Comment 13 Peter Lairo 2011-01-17 10:48:10 UTC
Has anyone even bothered to think about how many users there are for Thunderbird
versus Seamonkey. I would bet that Thunderbird has significantly (i.e. orders of
magnitude) more users than Seamonkey. This bug is a clear WONTFIX as it causes
more damage than good.

PS. In the future, please don't make decisions based solely on personal
preference while ignoring the needs of the majority of users.
Comment 14 Frank Schönheit 2011-01-17 12:10:10 UTC
fs->peterlairo:
The damage caused by the fix, to my knowledge, is that old Seamonkey profiles
cannot be accessed anymore. The fix, and the issue as a whole, has nothing to do
with Thunderbird at all.

So, I do not know where you have your information from, but to me, it seems to
be plain wrong. But perhaps I just misunderstood your rant ...
Comment 15 cchayka 2011-01-17 14:27:48 UTC
Does the fix for Seamonkey break the addressbook data source for some version of
Thunderbird?
Comment 16 Frank Schönheit 2011-01-17 17:28:17 UTC
old versions of Thunderbird, prior to ... hmm, when did they change the profile
format? TB 2? ... those old versions' profile format will not be recognized anymore.
Comment 17 noop 2011-01-17 18:57:59 UTC
@peterlairo: Well I'm confused... Thunderbird 3 and SeaMonkey 2 use the exact
same code:

http://mxr.mozilla.org/comm-central/source/mailnews/addrbook/public/

What "more damage than good" are you referring to?
Comment 18 noop 2011-01-17 20:48:17 UTC
Added note: m97 works for me:
[Version]
AllLanguages=en-US
buildid=300m97(Build:9566)
ExtensionUpdateURL=http://updateexte.services.openoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.4
ProductBuildid=9566
ProductMajor=300
ProductMinor=97
ProductSource=DEV300
UpdateID=OOo-dev_3_en-US
UpdateURL=http://update38.services.openoffice.org/ProductUpdateService/check.Update?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH};
BundledLanguages=${AllLanguages})

Build identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.16)
Gecko/20101206 Lightning/1.0b1 SeaMonkey/2.0.11

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.13) Gecko/20101207
Lightning/1.0b2 Thunderbird/3.1.7

Thanks!
Comment 19 noop 2011-02-08 17:54:11 UTC
Still working in m98:
$ cat /opt/ooo-dev3/program/versionrc
[Version]
AllLanguages=en-US
buildid=300m98(Build:9568)
ExtensionUpdateURL=http://updateexte.services.openoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.4
ProductBuildid=9568
ProductMajor=300
ProductMinor=98
ProductSource=DEV300
UpdateID=OOo-dev_3_en-US
UpdateURL=http://update38.services.openoffice.org/ProductUpdateService/check.Update?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH};
BundledLanguages=${AllLanguages})

However with 3.3.0 I get an:
====
SQL Status: HY000

An unknown error occured.
====

$ cat /opt/openoffice.org3/program/versionrc
[Version]
AllLanguages=en-US
buildid=330m20(Build:9567)
ExtensionUpdateURL=http://updateexte.services.openoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.3
ProductBuildid=9567
ProductMajor=330
ProductMinor=20
ProductSource=OOO330
UpdateID=OpenOffice.org_3_en-US
UpdateURL=http://update36.services.openoffice.org/ProductUpdateService/check.Update?pkgfmt=deb
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH};
BundledLanguages=${AllLanguages})

Comment 20 noop 2011-02-08 18:00:58 UTC
Created attachment 75796 [details]
Screenshot of 3.3.0 error
Comment 21 cchayka 2011-04-30 14:30:13 UTC
I just installed 3.4 beta and the addressbook works in Seamonkey as before. Sweet :-)
Comment 22 noop 2011-05-26 20:17:42 UTC
Just wanted to add that 3.4 works for me as well.

$ cat /opt/ooo-dev/basis3.4/program/versionrc
[Version]
buildid=340m0(Build:9583)
OOOBaseVersion=3.4
OOOPackageVersion=3.4.0
ProductBuildid=9583
ProductMajor=340
ProductMinor=0
ProductSource=OOO340

Thanks for the fix!