Issue 10737 - Cropping EPS files does not work
Cropping EPS files does not work
Status: CLOSED FIXED
Product: Writer
Classification: Application
Component: code
OOo 1.1 Beta2
PC Windows 2000
: P3 trivial (vote)
: ---
Assigned To: h.ilter
issues@sw
: oooqa
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-17 16:46 UTC by Unknown
Modified: 2013-08-07 14:41 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Sample eps cropping problem (250.86 KB, application/octet-stream)
2003-06-18 20:46 UTC, Unknown
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2003-01-17 16:46:08 UTC
In a writer document, I added an EPS file created by Adobe Illustrator 10. 
Everything looks ok, and can print ok.  If I use the cropping tools to crop the
image, the image shows croped on the page, and stuff is reformatted.  When I
print the file, the image is not cropped, and the whole image is printed.
Comment 1 prgmgr 2003-06-17 21:01:02 UTC
Chuck, thank you for using and supporting OOo.

Does this problem still exist in 1.1 Beta 2?

If so, could you attach the necessary files for us to consistently
reproduce the issue?
Comment 2 Unknown 2003-06-18 20:46:13 UTC
Created attachment 6977 [details]
Sample eps cropping problem
Comment 3 Unknown 2003-06-18 20:47:19 UTC
I tested this, and it still happens.  The image appears cropped in the
document, but when you print to a PS printer, it prints the full image
and not the cropped one.  It seems that cropping bitmapped based
images is working, because if I print to my PCL based printer (It
seems that EPS files will only print on a PS printer, otherwise it
prints the preview instead of the actual image) it prints the preview
cropped correctly.  I have attached a sample that displays this
property.  Thank you for such a great program, and looking into this bug.
Comment 4 h.ilter 2003-07-02 16:04:38 UTC
HI->SSA: Also reproducible in current version.
Comment 5 stephan_schaefer 2003-07-02 16:57:02 UTC
SSA->THB: Please, have a look. Seems to be DrawEPS related.
Comment 6 thb 2003-07-02 17:59:49 UTC
Yeah, looks like somehow we don't get the clipping right. Will have a look.
Comment 7 thb 2004-04-30 21:18:33 UTC
Now, this is kinda funny. The bug is Windows-only, Linux and Solaris work just right in this case. The 
problem is, for the *nix platforms, we use our own PostScript backend, whereas for Windows, we 
must rely on GDI doing things properly. Which, obviously, it doesn't in this case. I'm currently 
checking whether there are any known workarounds for that problem (we _do_ set a proper clipping, 
only that GDI ignores it).
Comment 8 thb 2004-05-04 15:11:53 UTC
.
Comment 9 thb 2004-05-05 12:32:01 UTC
Fixed by manually adding the relevant PostScript code to the
POSTSCRIPT_PASSTHROUGH, which is performed anyway. Note that the current fix
will not work for complex clip regions (polygons etc.), but there's currently no
codepath in the office that would make use of this feature (i.e. the current fix
is sufficient for now).
Comment 10 thb 2004-05-10 11:26:20 UTC
Fixed, please verify.
Comment 11 wolframgarten 2004-05-10 15:48:09 UTC
Sorry, wrong owner. Reassinged to HI.
Comment 12 h.ilter 2004-05-12 10:24:33 UTC
Fixed in cws: impress9ea1
Comment 13 h.ilter 2004-05-12 10:24:55 UTC
Set to verified
Comment 14 h.ilter 2004-06-09 14:38:25 UTC
Verified with integrated 680m41_8786 = ok