Issue 106278 - [From Symphony] Window.ActiveSheet,Window.FreezePanes,Window.Split, Window.View work not correctly.
[From Symphony] Window.ActiveSheet,Window.FreezePanes,Window.Split, Window.Vi...
Status: RESOLVED FIXED
Product: App Dev
Classification: Unclassified
Component: vba
OOo 3.3 or older
All All
: P3 trivial
: 4.0.0
Assigned To: Chen Peng
noel.power
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-26 11:12 UTC by lihuiibm
Modified: 2013-07-11 12:48 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
Patch for this issue (6.71 KB, patch)
2009-10-26 11:17 UTC, lihuiibm
no flags Details | Diff
Test case sample file for this issue (142.00 KB, text/plain)
2009-10-26 11:17 UTC, lihuiibm
no flags Details
Patch for 106278 (6.24 KB, patch)
2012-08-13 02:01 UTC, Chen Peng
chenpeng2006: review? (pfg)
Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description lihuiibm 2009-10-26 11:12:06 UTC
Steps:
  1.Run the sample file in attachment.
Issue:
  Window.ActiveSheet,Window.FreezePanes,Window.Split, Window.View work not
correctly.

Root Cause:
wrong impl or no impl for Excel APIs in the original codes of OO3.1.

Resolution:
Window.FreezePanes(bFreeze) - no impl when bFreeze=False. Add impl.
Window.Split - wrong impl. Fix it.
Window.SplicColumn - same reason as above. Fix it.
Window.SplitRow - same reason as above. Fix it.
Window.View - no impl. Add the impl.
ActiveSheet.ChartObject - exception. fix it.
ActiveSheet.Index - exception. Fix it.
Comment 1 lihuiibm 2009-10-26 11:17:14 UTC
Created attachment 65616 [details]
Patch for this issue
Comment 2 lihuiibm 2009-10-26 11:17:48 UTC
Created attachment 65617 [details]
Test case sample file for this issue
Comment 3 pflin 2009-10-29 09:03:50 UTC
pflin -> lihuiibm,
the test case Window.SplitRow can't pass after apply your patch
Comment 4 noel.power 2009-11-13 10:40:58 UTC
please investigate the issue raised by fong, reassigning, in the end this will
need cws npower12 integrated before upstreaming
Comment 5 lihuiibm 2009-11-13 15:30:08 UTC
Window.SplitRow passed in my build, not sure why is failed in pflin's build,
need more investigate.
Comment 6 Chen Peng 2012-08-13 02:01:52 UTC
Created attachment 78912 [details]
Patch for 106278

Update the patch to AOO3.4, and test it with the case attached.
Comment 7 Chen Peng 2012-08-13 02:03:03 UTC
Updated the patch to AOO3.4, and tested with the sample file.
Comment 8 Pedro Giffuni 2012-08-13 18:06:56 UTC
Sending        sc/source/ui/vba/vbawindow.cxx
Sending        sc/source/ui/vba/vbawindow.hxx

Committed revision 1372531.


Thank you !!
Comment 9 hdu@apache.org 2013-07-11 12:48:42 UTC
Updated status to FIXED and the target to the release containing the fixes.