Issue 106249 - Calc becomes extremely slow after copying range
Calc becomes extremely slow after copying range
Status: VERIFIED FIXED
Product: Calc
Classification: Application
Component: editing
OOO310m19
All Linux
: P2 trivial (vote)
: ---
Assigned To: kyoshida
issues@sc
https://bugs.launchpad.net/ubuntu/+so...
:
Depends on:
Blocks: 30215
  Show dependency treegraph
 
Reported: 2009-10-25 01:55 UTC by wleoncio
Modified: 2013-08-07 15:14 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description wleoncio 2009-10-25 01:55:06 UTC
I've noticed that, even on empty, newly-created documents, whenever I select and
copy a range that span more than 4 columns, Calc gets extremely unresponsive. I
find this a particularly interesting bug, because it doesn't matter how many
rows I copy. I can copy range A1:A1048576 and Calc stays fairly fast. If I
select something like A1:Z1, however, the program just starts to take a few
seconds to respond to my inputs. I hope someone can reproduce this bug, because
it is really annoying for people who work with big datasheets.
Comment 1 kyoshida 2009-10-25 02:27:19 UTC
I can tell you that this is actually a Go-OO specific issue, not an upstream
one.  So, technically I would have liked to handle this at bugzilla.novell.com.
 However, since this is related to the row limit increase (Issue 30215) that is
scheduled for being upstreamed, I hope we can handle this here as well.
Comment 2 kyoshida 2009-10-25 02:28:54 UTC
I'll take a look.
Comment 3 kyoshida 2009-10-25 02:34:02 UTC
.
Comment 4 ooo 2010-05-28 16:28:17 UTC
Note: I can not reproduce this in the now current CWS koheirowlimitperf with 1M
rows activated.
Comment 5 kyoshida 2010-05-28 16:31:23 UTC
Me neither, using the go-oo build.
Comment 6 kyoshida 2010-05-28 16:33:07 UTC
@wleoncio: can you test this again using a 3.2.1 build from your distro?  They
may provide a beta or RC build of 3.2.1.  Thanks.
Comment 7 thorsten.ziehm 2010-09-23 15:01:37 UTC
As I could read this issue seems to be fixed in CWS "koheirowlimitperf".
Therefore I set this issue to state 'fixed'. Please check it again and close the
issue. Thx
Comment 8 Li Lin Yi 2012-06-14 03:11:08 UTC
Changed to VERIFIED. Verified on AOO3.4, r1327774.