Issue 104820 - Defect in Options Window, in Internet-Search dialog
Defect in Options Window, in Internet-Search dialog
Status: RESOLVED FIXED
Product: ui
Classification: Code
Component: ui
OOO310m9
PC Windows, all
: P3 trivial (vote)
: AOO 4.0
Assigned To: Ariel Constenla-Haile
issues@ui
: oooqa
: 116168 121244 (view as issue list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-05 09:56 UTC by estvit
Modified: 2012-12-03 14:14 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: easy


Attachments
Screenshot Defect in Options Internet Search menu (27.77 KB, image/png)
2009-09-05 10:01 UTC, estvit
no flags Details
Screenshot of a NON-PRO build (55.78 KB, image/png)
2012-10-21 17:59 UTC, Ariel Constenla-Haile
no flags Details
Screenshot of a NON-PRO build with the fix (66.90 KB, image/png)
2012-11-29 01:53 UTC, Ariel Constenla-Haile
no flags Details
Screenshot of a NON-PRO German build with the fix (68.97 KB, image/png)
2012-12-03 14:06 UTC, Ariel Constenla-Haile
no flags Details
Screenshot of a NON-PRO Spanish build with the fix (70.11 KB, image/png)
2012-12-03 14:14 UTC, Ariel Constenla-Haile
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description estvit 2009-09-05 09:56:23 UTC
Please open Tools-Options  window from any application in OO.
Click on Internet - Search lines. 

Nearly impossible to open drop-down menu "Case match". If you click on 
line "none" or "arrow" on left side, menu will be unavailable. 

However, it is possible to open this menu ONLY if click on very thin black line 
wide in one pixel just above word "none".
Comment 1 estvit 2009-09-05 10:01:43 UTC
Created attachment 64564 [details]
Screenshot Defect in Options Internet Search menu
Comment 2 Rainer Bielefeld 2009-09-05 13:08:30 UTC
I checked with "Ooo 3.1.0 WIN XP DE-multilingual version German UI activated
[OOO310m11 (Build 9399)]" and can confirm the reported effect
Comment 3 Rainer Bielefeld 2009-09-05 14:05:11 UTC
Still the same with "Ooo Dev 3.2.0 multilingual version English UI WIN XP:
[DEV300m57 (Build 9422)]"
Comment 4 jbf.faure 2009-09-12 16:17:08 UTC
I do not reproduce the problem with Dev300_m57 under Ubuntu 8.04
But, I can confirm the reported effect for OOo 3.1.1 under Ubuntu 8.04. In fact
the problem concerns almost every fields in this dialog. It seems that the
"focus area" (the area which changes the pointer and the border of the control
when the pointer is inside) is slightly shifted upward.

Regards
JBF
Comment 5 eric.savary 2009-09-25 02:11:23 UTC
@MAV don't know who to reassign to . Please forward.
A lot of controls on this tabpage are unusable.
Comment 6 Regina Henschel 2012-10-21 17:03:22 UTC
*** Issue 116168 has been marked as a duplicate of this issue. ***
Comment 7 Ariel Constenla-Haile 2012-10-21 17:59:29 UTC
Created attachment 79803 [details]
Screenshot of a NON-PRO build

The problem is that fixed text controls on the left overlap with the other controls on the right:

Error: Window overlaps with sibling window: And
Error: Window overlaps with sibling window: AltaVista
Error: RadioButton should have a mnemonic char (~): And
Error: Window overlaps with sibling window: http://www.altavista.com/web/results/?qbmode=&aqa=&aqp=&aqo=
Error: Window overlaps with sibling window: &aqn=&kgs=0&kls=1&avkw=aapt

And by the way, the radio check "And is missing a mnemonic
Comment 8 Regina Henschel 2012-11-18 12:53:03 UTC
*** Issue 121244 has been marked as a duplicate of this issue. ***
Comment 9 Regina Henschel 2012-11-18 12:56:34 UTC
When working on this bug, please update the search engines in addition, see bug 77000.
Comment 10 SVN Robot 2012-11-29 01:48:29 UTC
"arielch" committed SVN revision 1415028 into trunk:
#i104820# - Fix overlapping controls
Comment 11 Ariel Constenla-Haile 2012-11-29 01:53:41 UTC
Created attachment 79965 [details]
Screenshot of a NON-PRO build with the fix
Comment 12 Ariel Constenla-Haile 2012-11-29 01:54:01 UTC
Fixed on trunk
Comment 13 Ariel Constenla-Haile 2012-12-03 14:06:04 UTC
Created attachment 79987 [details]
Screenshot of a NON-PRO German build with the fix
Comment 14 Ariel Constenla-Haile 2012-12-03 14:14:36 UTC
Created attachment 79988 [details]
Screenshot of a NON-PRO Spanish build with the fix

Now that the original algorithm works, controls are positioned taking into account the longest label text; translators should take this into account because with a too long label text the layout may look bad, like in the Spanish translation.

Another solution would be to set a fixed maximal label with, in that case, longer translations won't fit in the label. IMO it's better to leave the algorithm as is, and fix the translations.