Issue 10250 - Crash!
Crash!
Status: CLOSED DUPLICATE of issue 1940
Product: General
Classification: Code
Component: code
OOo 1.0.1
PC Linux
: P3 trivial (vote)
: OOo 2.0
Assigned To: Mathias_Bauer
issues@framework
: crash, oooqa
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-21 00:00 UTC by Unknown
Modified: 2003-09-10 11:52 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-12-21 00:00:22 UTC
Open Office will not open any type MS Office document, even after being 
configured to, it crashes. It also crashes when trying to save any type Open 
Office document.When trying to save I get "/opt/OpenOffice.org/Work does not 
exist". If I continue I get "Write Error, the document could not be written". 
Then, clicking the ok button, I get "Invalid starting parameter", and it 
crashes. I installed OpenOffice with SuSE Linux 8.1 from a DVD. I have tried 
the repair utility, and uninstalling/re-installing it, but no improvement.
Comment 1 Frank Schönheit 2003-01-06 09:30:23 UTC
not an DBA issue - I think it's closest to "framework"

Comment 2 Mathias_Bauer 2003-01-08 14:56:26 UTC
Sorry, this seems to be a configuration problem.
Did you use the OOo setup or some SuSE stuff?
How did you install?
We also need more information about your system
Comment 3 Unknown 2003-01-08 18:01:59 UTC
I installed OO from the SuSe Linux DVD. I tried the repair utiltity, 
then uninstalled & reinstalled OO from the DVD. Then I downloaded OO, 
uninstalled again, installed the downloaded distribution, but it 
still doesn't work. I think the distribution on the DVD has a 
problem, and when I uninstall the DVD version, all the files may not 
be getting deleted, so even when I install the downloaded 
distribution, it's still corrupted.
My system is below. I also have Windows ME on another partition of 
Drive C.
Thanks,
Mike Brenton
System Model: micronpc.com Micron Electronics, Inc. 
System Serial Number: 2648109-0001
Operating System 
SuSE Linux 8.1    
Processor a   Main Circuit Board b 
1000 megahertz AMD Athlon
32 kilobyte primary memory cache
256 kilobyte secondary memory cache

Board: Gigabyte Technology Co., Ltd. 761-686B 
Bus Clock: 100 megahertz
BIOS: Award Software International, Inc. 6.00 PG 10/30/2001
 
Drives  
24.70 Gigabytes Usable Hard Drive Capacity
19.51 Gigabytes Hard Drive Free Space

LITE-ON LTR-0841 [CD-ROM drive]
LITEON DVD-ROM LTD122 [CD-ROM drive]
Generic floppy disk drive (3.5")

Generic IDE hard disk drive (16.29 GB) -- drive 0
Generic IDE hard disk drive (8.41 GB) -- drive 1
IOMEGA ZIP 100 [Hard drive] -- drive 255

512 Megabytes Installed Memory
Slot 'BANK_0' has 256 MB
Slot 'BANK_1' has 256 MB

Local Drive Volumes 
c: (on drive 0) 16.29 GB 12.28 GB free 
d: (on drive 1) 8.41 GB 7.23 GB free
Comment 4 Mathias_Bauer 2003-01-14 15:56:24 UTC
Please first try to get a clean installation.

First backup everything you might still need from your user directory 
inside your home dir.

Deinstall OOo, make sure that the program directory and the user tree 
that was placed into your home dir have been removed. Also make sure 
that no .sversionrc file is left in your home dir. Then you have 
removed everything from OOo in your system.

Then reinstall OOo. If you install as root, make sure that you 
use "setup -net" for this installation and log in afterwards 
as "normal" user to do a "simple" setup.

If you do the setup as "normal" user, you can simply use "setup".

Does the problem still exist?
Comment 5 Unknown 2003-01-22 02:27:06 UTC
I uninstalled OO and deleted the other files you suggested. Then I 
downloaded OO 1.01, and installed it per instructions. I still 
get "operation started with an invalid parameter" when I try to save 
a file in the writer.
Mike
Comment 6 Unknown 2003-01-24 13:40:30 UTC
Originally, OO Writer would not save documents in any format. After 
the clean install, I found it will now save them in .doc or .rtf 
formats, but still won't save them in it's native format.
Mike
Comment 7 Mathias_Bauer 2003-01-24 16:38:07 UTC
Thank you for your support.

So let me summarize: you now can create or load documents of any type 
and save f.e. text documents to word and rtf format, but not into our 
own format (sxw)? Can you save in our binary format (sdw)?

And is it correct that you always get the error "operation started 
with an invalid parameter" when you try to save into our own format 
(sxw)? Or do you also get other errors?
Comment 8 Unknown 2003-01-24 22:05:37 UTC
Clarification
Open Office behaves as follows:
.rtf - can create/save and open (can then open in MS Word)
.doc - can create/save but not open (can then open in MS Word)
When saving .rtf or .doc I get:
Error saving the document untitled1
The document could not be saved
But I have given it a name, (not untitled1), and it does in fact 
create the document with the name I gave it.
I cannot create/save to formats .sxw or .sdw. I get:
Error saving the document untitled1
Wrong parameter
The operation was started under an invalid parameter
I then click the 'ok' button and get:
An unrecoverable error has occured
All modified files have been saved and can
probably be recovered at program restart
I click 'ok' again and OO closes. After this happens I find a zero 
byte .tmp file in my home directory.
Comment 9 Mathias_Bauer 2003-03-10 16:12:48 UTC
I really would like to fix that problem, but currently I cannot
reproduce it here. Given the time schedule for OOo1.1 Beta, I think
that OOo2.0 is the correct target for that, because without a
reproducable scenario this is not a showstopper. If we can reproduce
it here, I am willing to raise the target (time permitting).
Comment 10 Rainer Bielefeld 2003-06-07 15:40:44 UTC
The remaining problem might be a duplicate of issue 12090 ?

Rainer
Comment 11 dankegel 2003-06-07 16:53:22 UTC
Damyankee, can you reproduce this problem with OpenOffice1.1beta2?
If you can submit a symbolic stack traceback of the unrecoverable error 
happening with beta2, we might have time to fix it before 1.1final.
See http://www.kegel.com/openoffice/#dump for instructions
on how to capture a symbolic stack traceback.
Comment 12 prgmgr 2003-06-17 01:28:25 UTC
This really sounds like an install issue to me.  Liz on the QA team
seems quite adept at solving OOo on SuSE problems.  She tipped me off
about this link a long time ago.

In the SuSE database see:

http://sdb.suse.de/en/sdb/html/cihlarov_oo_install.html


You really have a few options.  Backup your data, completely remove
all OOo installations ( RPM or binaries ) and go from there.

Either do a RPM install and make sure the SuSE install instructions
are followed, or install from binary by first running install as root,
then going to the directory where OOo has been installed and running
setup.
Comment 13 Rainer Bielefeld 2003-09-04 17:53:41 UTC
No reporter-activity for 7 months
No votes
No other one who confirmed the problem

I think we should close that issue.
If someone still sees the problem, the issue can be reopened

If I will not see any further action as votes, attachments or
confirmations, I will have to close this issue 2003-09-30 as WFM.

Rainer
Comment 14 dankegel 2003-09-04 20:03:51 UTC
That Suse document,
http://sdb.suse.de/en/sdb/html/cihlarov_oo_install.html
really sounds like the cause.  I'd say the right fix
is to put some protection into the global executable
to notice this problem -- or to get rid of the need
for the local executable.

In fact, I'm pretty sure this is a duplicate
of issue 1940, although the user didn't know it.
I'm marking it as such.

*** This issue has been marked as a duplicate of 1940 ***
Comment 15 Mathias_Bauer 2003-09-10 11:52:31 UTC
So until it's not proven that this issue is different, it can be closed