Issue 102056 - lost of cell content after drag&drop; only cell with note
lost of cell content after drag&drop; only cell with note
Status: CLOSED FIXED
Product: Calc
Classification: Application
Component: editing
DEV300m48
PC Windows XP
: P3 trivial (vote)
: ---
Assigned To: oc
issues@sc
: oooqa
: 102454 102483 (view as issue list)
Depends on:
Blocks: 101565
  Show dependency treegraph
 
Reported: 2009-05-19 11:23 UTC by raal
Modified: 2013-08-07 15:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation on: ---
Developer Difficulty: ---


Attachments
screenshots (38.00 KB, application/vnd.oasis.opendocument.text)
2009-05-19 11:24 UTC, raal
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description raal 2009-05-19 11:23:52 UTC
1 - open calc
2 - write to cell some text, eg. A1 = "AA"
3 - Insert - note
4 - write text to note
5 - drag this one cell
6 - drop somewhere, eg. to cell C1

actual results:
dataloss. cell is empty, note remains
C1 = ""

expected results:
cell is moved completely; C1="AA"

When the cell is without note then drag&drop works.
Undo, Redo works - steps 1-6 + Undo + Redo => C1="AA"
Comment 1 raal 2009-05-19 11:24:51 UTC
Created attachment 62361 [details]
screenshots
Comment 2 oc 2009-05-19 11:56:35 UTC
Hi Daniel, please have a look
Comment 3 niklas.nebel 2009-05-19 16:54:58 UTC
reassigning to Daniel
Comment 4 daniel.rentz 2009-05-20 19:16:14 UTC
fixed in CWS OOO310/calc311fixes
Comment 5 niklas.nebel 2009-05-25 17:09:37 UTC
Also in CWS "calc50", for 3.2.
Comment 6 niklas.nebel 2009-05-26 18:55:48 UTC
reassigning to QA for verification
Comment 7 oc 2009-05-29 14:37:18 UTC
verified in internal build cws_calc311fixes (OOo311) and
verified in internal build cws_calc50 (OOo32)
Comment 8 niklas.nebel 2009-06-03 09:52:16 UTC
*** Issue 102454 has been marked as a duplicate of this issue. ***
Comment 9 niklas.nebel 2009-06-04 09:04:51 UTC
*** Issue 102483 has been marked as a duplicate of this issue. ***
Comment 10 niklas.nebel 2009-06-04 09:06:09 UTC
*** Issue 102483 has been marked as a duplicate of this issue. ***
Comment 11 thackert 2009-08-12 17:58:55 UTC
Hello raal, *,
I have tested it with OOO310m18 under Debian SID AMD64, where this issue works
for me now :) Would you be so kind to test it again with Win and with OOO310m18,
please?
TIA
Thomas.
Comment 12 raal 2009-08-13 07:38:02 UTC
WinXP, OOO310m18 . issue doesn't occurs.
Comment 13 raal 2009-08-13 08:29:25 UTC
Ubuntu 9.04, OOO310m18 . issue doesn't occurs.
Comment 14 thackert 2009-08-13 16:57:47 UTC
Hello raal, *,
do your comments mean, that this issue is fixed? Would it be possible, that you
close this issue then?
TIA
Thomas.
Comment 15 raal 2009-08-14 07:53:01 UTC
closing