Issue 9861

Summary: hangs loading html 65KB with linked images
Product: Writer Reporter: andremachado <andremachado>
Component: codeAssignee: thorsten.martens
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: issues
Version: OOo 1.0.1   
Target Milestone: ---   
Hardware: PC   
OS: Linux   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---
Attachments:
Description Flags
html that OO 1.0.1 BR can not edit none

Description andremachado 2002-12-05 13:06:37 UTC
Sir: 
I am trying to edit a html 65KB document previously created and edited many 
times with StarOffice 5.2. 
OpenOffice 1.0.1 simply hangs when opening this document. 
I "guess" that is because has many linked images (external sites) or uses many 
cookies. 
I can send a copy of the document for debugging
Comment 1 andremachado 2002-12-05 13:12:39 UTC
Created attachment 3921 [details]
html that OO 1.0.1 BR can not edit
Comment 2 h.ilter 2002-12-06 13:35:43 UTC
Reassigned to ES
Comment 3 eric.savary 2002-12-09 17:17:36 UTC
ES->FL: Keyword: "Multithreading"... Loading an HTML doc with 88 link
graphics *seems* to loop. In reality, the user has no access
(scrolling, editing...) to the document untill all graphics have been
loaded. And it lasts (here) 3min!!!
A document should be scrollabel, edi5table even if not all its
components are loaded. (see how browsers handle this file)
Comment 4 frank.loehmann 2002-12-12 11:35:22 UTC
FL->MBA: This is the one we have talked about today. I have also 
asked Oliver Duesterhoeft and Thorsten Behrens and it seems that 
this issue is no problem of loading graphics asynchronously. SO is 
waiting for a time-out when loading the bugdoc, but we do not know 
why.
I have also tried to load this one in SO 4.0 and 5.2 and they could 
not load any graphic linked to this file at all. SO 5.2 shows many 
messages boxes (i.e.): "www.clickcerto.com.br:80" could not be 
connected. Word, IE, Netscape could load the doc, only one graphic 
link seems to be broken. Could you please have a look at this one 
and point out were the real problem is? Thank you!
Comment 5 frank.loehmann 2002-12-12 11:35:57 UTC
FL->MBA: This is the one we have talked about today. I have also 
asked Oliver Duesterhoeft and Thorsten Behrens and it seems that 
this issue is no problem of loading graphics asynchronously. SO is 
waiting for a time-out when loading the bugdoc, but we do not know 
why.
I have also tried to load this one in SO 4.0 and 5.2 and they could 
not load any graphic linked to this file at all. SO 5.2 shows many 
messages boxes (i.e.): "www.clickcerto.com.br:80" could not be 
connected. Word, IE, Netscape could load the doc, only one graphic 
link seems to be broken. Could you please have a look at this one 
and point out were the real problem is? Thank you!
Comment 6 andremachado 2002-12-12 12:43:43 UTC
Hello,  
Comparing SO5.2 against Mozilla, or NS4.78, I realized that graphics  
do not load because of the size of cookie strings.  
Each banner sends a cookie to the server.  
This problem doc is a template for an e-zine. Most of times, at  
regular editions, the total number of graphics is less than 88. When  
it is around 40, SO5.2 can load the graphics.  
  
Well, it is not the main problem, as SO5.2 can edit the doc without  
the graphics.  
  
OpenOffice 1.0.1 simply can not edit this document, even without  
loading graphics...  
Nor one small edition, that SO5.2 can load graphics also.  
OO 1.0.1 can load and edit much longer html files WITHOUT or with 
very few graphics. 
 
Regarding multithreading, I saw that when SO5.2 edit the SOURCE of  
file in a slooow machine (like mine), it takes some time to  
"colorize" the source at the end of document. In some big html  
documents, It is possible to "run after" the processing by scrolling  
down. It is clear that at fast machines it can not be seen.  
  
I hope these can help.  
Best regards.  
Andre Felipe  
Comment 7 Mathias_Bauer 2002-12-12 17:07:13 UTC
OOo is very busy resolving the links to some graphics files.
The timeout seems to be caused by the name resolution.

Kai, can you add some information? Or is it necessary to accept that 
behaviour?
Comment 8 kai.sommerfeld 2002-12-13 09:19:31 UTC
Office does not loop or hang forever; it 'just' takes ages to load the
document. So if you are patient enough you will be able to edit your
document ;-) In the first try I gave up after 15 minutes... :-O

The problem is actually exactly one of the links contained in the
document:
http://www.clickcerto.com.br/veiculacao/busca_banner.asp?codigo=14690
If you remove that link from the document OOo 1.0.1 will 'only' need 2
minutes (on my machine) to load the document.

Background: Office's WebDAV client sends a PROPFIND to the URL above
and the server does not reply within 2 minutes, which is the internal
receive timeout of the WebDAV client. This is be done several times
... overall this takes a very long time.

The good news is that we improved the WebDAV client a lot during the
last months. One of the improvements is not to send PROPFIND requests
for resources that are not WebDAV enabled. Thus the problem that arose
with your document will not happen with OOo 1.1 Beta anymore. But even
loading your document using our most recent WebDAV client takes about
2 minutes, which is still not acceptable, IMHO. To improve this we
must change the way OOo loads graphics which leeds to bigger changes
in fundamental code peaces.

Since there is the workaround (to remove the bad link) for OOo 1.0.1
and since it already works much better for 1.1 Beta I will set the
target of this task to OOo 2.0 where we will try to improve loading
documents with linked graphics in general.
Comment 9 Mathias_Bauer 2002-12-16 11:44:39 UTC
We will address all performance related loading problems in a later 
version that supports real multhithreading - without that all fixes 
are just hacks.
Comment 10 andremachado 2002-12-17 17:18:41 UTC
Hello, 
Is it not possible to use the SO5.2 "engine"? 
Did not Sun allowed to use the source code for that? 
Best regards. 
Andre Felipe 
Comment 11 kai.sommerfeld 2002-12-18 08:57:05 UTC
*** Issue 4608 has been marked as a duplicate of this issue. ***
Comment 12 kai.sommerfeld 2002-12-18 11:00:35 UTC
*** Issue 4608 has been marked as a duplicate of this issue. ***
Comment 13 Mathias_Bauer 2004-01-07 14:55:30 UTC
Using the "SO5.2 engine" is not an option, it was neither good enough nor did it
fit to our API.

But we will fix that bug in the same way as it would be done in that old engine:
we load the graphic files in the background.
Comment 14 Mathias_Bauer 2004-04-30 13:42:05 UTC
This issue will be fixed by our new asynchronous loading procedure
Comment 15 niklas.nebel 2004-09-02 14:55:43 UTC
*** Issue 33510 has been marked as a duplicate of this issue. ***
Comment 16 andreas.bille 2004-10-29 16:27:40 UTC
started
Comment 17 andreas.bille 2005-01-18 11:54:45 UTC
Fixed
Comment 18 Mathias_Bauer 2005-01-30 15:41:43 UTC
*** Issue 41368 has been marked as a duplicate of this issue. ***
Comment 19 andreas.bille 2005-02-01 09:37:41 UTC
op
Comment 20 andreas.bille 2005-02-01 09:39:31 UTC
please verify.
Comment 21 andreas.bille 2005-02-01 09:39:57 UTC
fi
Comment 22 thorsten.martens 2005-02-03 10:45:29 UTC
Checked and verified in cws maybeb:
Windows OK !
Comment 23 thorsten.martens 2005-02-03 13:13:10 UTC
Linux OK
Comment 24 thorsten.martens 2005-04-12 15:17:42 UTC
Verified in 680m93 -> OK !