Issue 92908

Summary: PDF Import Beta 0.3.1 ignores transformation matrix on an image
Product: extensions Reporter: frank_markesteijn <frank.markesteijn>
Component: pdfimportAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: wolframgarten
Severity: trivial    
Priority: P3 CC: issues, norbert.notz, oo, rainerbielefeld_ooo_qa
Version: currentKeywords: oooqa
Target Milestone: milestone 1   
Hardware: Sun   
OS: All   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---
Attachments:
Description Flags
example pdf with upside down image none

Description frank_markesteijn 2008-08-19 12:48:31 UTC
The Sun PDF Import extension Beta 0.3.1 Solaris x86 on ooo3.0 Beta 2 Build
BEB300_m3 appears to ignore the transformation matrix, when encountering an
image in a pdf file, in the attached file Leers.text.pdf, which is in plain
ascii, the background image is flipped upside down In the pdf file, in object 2,
on line 20 you will find the transformation "842 0 0 -595 0 595 cm" the next
line "/X Do" calls object 3, the actual image, in the objects dictionary on line
16 "/Resources << /XObject << /X 3 0 R >> >>" you can see that "/X" actually
revers to object 3, thus it appears that the transformation on line 20 is being
ignored.
There are other things wrong when this file is imported
but those are different bugs.
The attached file Leers.txt.pdf is a plain ascii file, so you can open it in any
text editor.
Comment 1 frank_markesteijn 2008-08-19 12:49:32 UTC
Created attachment 55853 [details]
example pdf with upside down image
Comment 2 wolframgarten 2008-08-19 13:15:46 UTC
Reproducible. Reassigned.
Comment 3 Rainer Bielefeld 2008-08-20 06:03:06 UTC
You can find an import in  Issue 92919
Shouldn't Component be "extensions"?
Comment 4 Martin Hollmichel 2008-10-08 09:51:55 UTC
change component.
Comment 5 philipp.lohmann 2009-05-11 10:19:21 UTC
fixed in CWS pdfextfix02
Comment 6 philipp.lohmann 2009-05-11 10:29:15 UTC
please verify in CWS pdfextfix02
Comment 7 philipp.lohmann 2009-05-11 10:49:52 UTC
set milestone
Comment 8 michael.ruess 2009-05-11 15:08:57 UTC
Verified fix in CWS pdfextfix02.
Comment 9 michael.ruess 2009-08-03 16:13:08 UTC
Checked fix in DEV300m53 and OOO310m17.
Comment 10 norbert2 2009-08-04 13:41:30 UTC
Great to hera that the bug is fixed.

But I don't understand "Checked fix in DEV300m53 and OOO310m17.".

Were changes in the OOo code neccessary?

Do I have to update OOo AND the extension?

When will a new extension be released? What version number will it have?
Comment 11 michael.ruess 2009-08-05 11:25:37 UTC
The extension is built together with all milestones, has a similar cycle.
Can't tell you, when it will be released, but I think analog to OOo release.
I do no think that it is necessary to update OOo also.
Comment 12 norbert2 2009-09-07 08:12:48 UTC
@mru:

Since OOo 3.1.1 has recently been released can we expect an updated pdf import
extension soon?
Comment 13 michael.ruess 2009-09-08 16:29:00 UTC
mru->norbert2: I do not know, best would be to ask the person publishing the
extension.
Comment 14 norbert2 2009-09-08 19:03:09 UTC
Who is it?
Comment 15 michael.ruess 2009-09-08 20:38:07 UTC
I either did not know, because I tested this as vacation substitute. So I
searched for PDF Extension and this is what I got:
http://extensions.services.openoffice.org/search/node/pdf+import