Issue 90698

Summary: Automatic Update Installation Fails Due to Files Being Used by Explorer.exe
Product: Installation Reporter: lutz.hoeger
Component: codeAssignee: AOO issues mailing list <issues>
Status: ACCEPTED --- QA Contact:
Severity: trivial    
Priority: P2 CC: ingo.schmidt-rosbiegal, issues
Version: OOo 2.4.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows Vista   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---

Description lutz.hoeger 2008-06-13 15:08:50 UTC
- Running OOo 2.4 on Vista Ultimate; No Quickstarter. No ActiveX Control. No
Mozilla Plugin.
- Just opened one Writer window - didn't type anything. 
- Automatic update check found new version (2.4.1). 
- Followed instructions on screen to download and install the update. 
- Writer window was closed automatically. Installation started with correct
module pre-selection & install directory (same as in OOo 2.4). 
- On "Validating Install" progress is at about 75%, error message tells me I
need to close Windows Explorer to continue:

Files in Use;
Some files that need to be updated are currently in use.
The following applications are using files that need to be updated by this
setup. Close these applications and click Retry to continue.

Windows-Explorer (Process Id: 1172).

I cannot run the 2.4.1 installer successfully. That's why I set this to P2 -
though I understand P3 may be worth debating. I am available for debugging on my
system on Monday, June 16.
Comment 1 Olaf Felka 2008-06-17 08:59:11 UTC
OF: I've tried three times on Vista. OOo 2.4.1 installs like charm. No such
warning that the explorer needs to be closed. On XP the same: No warning. At
least the warning comes from the OS. I don't see a chance to suppress such
warnings and it's dangerous too.
Comment 2 lutz.hoeger 2008-06-17 10:09:23 UTC
Sorry, but the issue still is valid. I keep getting the error message, no matter
how often I reboot, etc. Of course I do know how to manually uninstall 2.4 and
install 2.4.1. But that's not what this issue is about. I still am available for
a debugging session on my laptop, where I can reproduce this issue with 100%
fidelity.
Comment 3 Olaf Felka 2008-06-17 10:14:39 UTC
No doubt that you know how to install an Office. I've never written that I've
installed plain OOo 2.4.1. I've always have made the update. I've never got such
a message.
@ is: Please take the chance to debug on the laptop.
Comment 4 ingo.schmidt-rosbiegal 2008-06-20 15:12:47 UTC
The tests showed, that the uwinapi.dll was used by the Windows Explorer. After
reboot and not starting the Explorer, the problem did not occur.
Further tests are needed: What happens if "Ignore" in the Windows Installer dialog?
Comment 5 ingo.schmidt-rosbiegal 2008-06-20 15:29:17 UTC
There is not much we can do, if Vista does not want to release uwinapi.dll.
So I set target 3.x. Perhaps we can find a solution in future, perhaps "Ignore"
is the simple solution.
Comment 6 Olaf Felka 2008-06-28 08:02:26 UTC
*** Issue 91161 has been marked as a duplicate of this issue. ***
Comment 7 Olaf Felka 2008-06-30 07:21:16 UTC
*** Issue 91185 has been marked as a duplicate of this issue. ***