Issue 82460

Summary: Implement thrilling 3D slide transitions using OpenGL
Product: Draw Reporter: thb
Component: codeAssignee: shane.m.mathews
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: ahz001, andre.schnabel, issues, norbert.notz, shane.m.mathews, theradio
Version: recent-trunk   
Target Milestone: OOo 2.4   
Hardware: All   
OS: Unix, all   
Issue Type: FEATURE Latest Confirmation on: ---
Developer Difficulty: ---

Description thb 2007-10-10 09:48:57 UTC
See $subject. Awesome contribution from smmathews from this year's GSoC event.
Comment 1 thb 2007-10-10 09:49:49 UTC
Stuff is in CWS transogl01.
Comment 2 thb 2007-10-22 12:16:49 UTC
Done. OGL transitions are disabled by default, but could be easily deployed as
an extension, once the surrounding CWS is in.
Comment 3 thb 2007-10-22 12:19:25 UTC
@smmathews: please verify in CWS transogl01
Comment 4 andreschnabel 2007-12-09 09:38:15 UTC
is it possible to get an extension for demonstration and testing purposes?

I'd really like to "Make The Redmond and Santa Clara based developers eat our
Dust" ;-)
Comment 5 thb 2007-12-10 09:03:46 UTC
@andre: with CWS configure22 (not yet in), and issue 83872, you get a configure
switch to enable this - though only if you build it yourself. Apart from that,
yes, extension is entirely possible, /me makes mental note to provide one for 2.4
Comment 6 aziem 2008-02-11 01:05:38 UTC
thb: Is the extension still possible for OOo 2.4 time frame?  Could a developer
snapshot be available sooner?  I built ooo-build for myself, but it's non-trivial.  

andreschnabel: If I can figure out a universal Linux build (not tied to Fedora),
then I may post a big torrent with this feature.
Comment 7 thb 2008-02-11 07:45:32 UTC
@aziehm: sure. everything is in place to have an extension for 2.4.
Comment 8 aziem 2008-02-12 15:52:50 UTC
*** Issue 71843 has been marked as a duplicate of this issue. ***
Comment 9 aziem 2008-03-02 00:09:00 UTC
andreschnabel: As you requested, I have a binary "for demonstration and testing
purposes."  I will host this experimental version until the final version comes.
 In this build, the feature is integrated (not an extension).

http://www.oooninja.com/2008/02/eye-candy-3d-opengl-transitions-impress.html
Comment 10 norbert2 2008-03-27 14:59:42 UTC
I cannot find this feature in OOo 2.4 Windows build.

I have read somewhere that this feature has only been implemented fpr Linux
builds. Is this right?

But the issue has set
Platform:	All
OS:	All

???


Nevertheless, if this feature is not available in the Windows build, an new
issue should be filed.
Comment 11 thb 2008-03-27 21:11:19 UTC
@norbert2: right, currently available only for unix platforms. please feel free
to file another issue.
Comment 12 norbert2 2008-03-27 22:33:32 UTC
I have filed Issue 87529.
Comment 13 andreschnabel 2009-04-04 19:45:40 UTC
closed (source has been integrate long ago)
Comment 14 Edwin Sharp 2014-04-21 16:08:45 UTC
*** Issue 99329 has been marked as a duplicate of this issue. ***