Issue 82234

Summary: Implement Insert-Movie and Sound using QTKit (QuickTime)
Product: porting Reporter: msicotte
Component: MacOSXAssignee: thorsten.martens
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: eric.bachard, issues, jogi, philipp.lohmann
Version: 680m230Keywords: aqua
Target Milestone: OOo 2.4   
Hardware: Mac   
OS: Mac OSX, all   
URL: http://specs.openoffice.org/Mac_Port/System_Integration/macosx_quicktime.odt
Issue Type: FEATURE Latest Confirmation on: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 77586    
Attachments:
Description Flags
Changes to earlier code to support QTKit
none
Spec for quicktime implementation
none
test cases for quicktime implementation none

Description msicotte 2007-10-04 01:59:03 UTC
Add Movie and Sound support to Mac OS X port using QTKit (QuickTime)
Comment 1 msicotte 2007-10-04 02:02:46 UTC
starting
Comment 2 msicotte 2007-10-04 02:04:34 UTC
Created attachment 48689 [details]
Changes to earlier code to support QTKit
Comment 3 msicotte 2007-10-04 02:11:15 UTC
When adding a movie (mov) the attached code crashes after stepping into line 244
of avmedia/source/viewer/mediawindow_impl.cxx (codebase m231 + aquavcl03 on Mac
OS X 10.4 Intel)

Backtrace:
Thread:      1 :avmediaquicktime: Manager::Manager
Thread:      1 :avmediaquicktime: Manager::createPlayer

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000004
0x01189da3 in JavaChildWindow::getParentWindowHandleForJava ()
(gdb) bt
#0  0x01189da3 in JavaChildWindow::getParentWindowHandleForJava ()
#1  0x1ffee729 in avmedia::priv::MediaWindowImpl::onURLChanged (this=0x3387e00)
at
/Users/MikeS/Documents/Projects/ooo/m231/avmedia/source/viewer/mediawindow_impl.cxx:244
#2  0x1ffebfc4 in avmedia::priv::MediaWindowBaseImpl::setURL (this=0x3387f10,
rURL=@0x1da5789c) at
/Users/MikeS/Documents/Projects/ooo/m231/avmedia/source/viewer/mediawindowbase_impl.cxx:131
#3  0x1ffec037 in avmedia::priv::MediaWindowBaseImpl::executeMediaItem
(this=0x3387f10, rItem=@0x1da57890) at
/Users/MikeS/Documents/Projects/ooo/m231/avmedia/source/viewer/mediawindowbase_impl.cxx:398
#4  0x1ffef53d in avmedia::MediaWindow::executeMediaItem (this=0x1d47dd30,
rItem=@0x1da57890) at
/Users/MikeS/Documents/Projects/ooo/m231/avmedia/source/viewer/mediawindow.cxx:336
#5  0x245e6587 in sdr::contact::ViewObjectContactOfSdrMediaObj::executeMediaItem ()
#6  0x245e664c in
sdr::contact::ViewObjectContactOfSdrMediaObj::ViewObjectContactOfSdrMediaObj ()
#7  0x245e632e in
sdr::contact::ViewContactOfSdrMediaObj::CreateObjectSpecificViewObjectContact ()
#8  0x245dbd3e in sdr::contact::ViewContact::GetViewObjectContact ()
#9  0x245e5eda in sdr::contact::ViewObjectContactList::BuildDrawHierarchy ()
#10 0x245e3981 in sdr::contact::ViewObjectContact::BuildDrawHierarchy ()
#11 0x245e3f24 in sdr::contact::ViewObjectContact::CheckDrawHierarchy ()
#12 0x245e364a in sdr::contact::ObjectContactOfPageView::EnsureValidDrawHierarchy ()
#13 0x245e3711 in sdr::contact::ObjectContactOfPageView::ProcessDisplay ()
#14 0x240f9879 in SdrPageWindow::RedrawAll ()
#15 0x24050f35 in SdrPageView::CompleteRedraw ()
#16 0x2405ee7e in SdrPaintView::CompleteRedraw ()
#17 0x1b6886ba in sd::View::CompleteRedraw ()
#18 0x1b6b2460 in sd::DrawViewShell::Paint ()
#19 0x1b6a319c in sd::Window::Paint ()
#20 0x011ad998 in Window::ImplCallPaint ()
#21 0x011ad693 in Window::ImplCallPaint ()
#22 0x011ad693 in Window::ImplCallPaint ()
#23 0x011ad693 in Window::ImplCallPaint ()
#24 0x011ad693 in Window::ImplCallPaint ()
#25 0x011ad693 in Window::ImplCallPaint ()
#26 0x011ad693 in Window::ImplCallPaint ()
#27 0x011ade49 in Window::Update ()
#28 0x01187888 in StatusBar::SetItemText ()
#29 0x015e7615 in svt::StatusbarController::statusChanged ()
#30 0x16173c7f in SfxDispatchController_Impl::StateChanged ()
#31 0x1616823f in SfxStateCache::SetState_Impl ()
#32 0x1614993a in SfxBindings::SetState ()
#33 0x1b6b1346 in sd::DrawViewShell::ShowMousePosInfo ()
#34 0x1b6b15a7 in sd::DrawViewShell::MouseMove ()
#35 0x1b6a3258 in sd::Window::MouseMove ()
#36 0x011c1cb6 in ImplHandleMouseEvent ()
#37 0x011c2c55 in ImplWindowFrameProc ()
#38 0x01232ca3 in -[SalFrameView sendMouseEventToFrame:button:eventtype:] ()
#39 0x0122d616 in -[SalFrameView mouseEntered:] ()
#40 0x93365be1 in -[NSWindow sendEvent:] ()
#41 0x93357350 in -[NSApplication sendEvent:] ()
#42 0x0124a765 in -[VCL_NSApplication sendEvent:] ()
#43 0x0124c98a in AquaSalInstance::Yield ()
#44 0x01013bd3 in Application::Yield ()
#45 0x01013c55 in Application::Execute ()
#46 0x000150b7 in desktop::Desktop::Main ()
#47 0x010193e5 in ImplSVMain ()
#48 0x0124a68c in AquaSalInstance::handleAppDefinedEvent ()
#49 0x0124a775 in -[VCL_NSApplication sendEvent:] ()
#50 0x93281dfe in -[NSApplication run] ()
#51 0x93275d2f in NSApplicationMain ()
#52 0x0124b75c in ImplSVMainHook ()
#53 0x01019471 in SVMain ()
#54 0x00002b57 in main ()
#55 0x0000241a in _start ()
#56 0x00002341 in start ()

 
Comment 4 eric.bachard 2007-10-04 09:53:29 UTC
@msicotte: I'lll test your code this week end, and I'll try to trace a bit, if ever I can help you. 
Comment 5 eric.bachard 2007-10-04 14:48:24 UTC
added me on CC
Comment 6 msicotte 2007-10-05 04:15:54 UTC
added keyword

cws macosxquicktime01 created and initial checkin done
Comment 7 msicotte 2007-11-03 20:09:30 UTC
Created attachment 49394 [details]
Spec for quicktime implementation
Comment 8 msicotte 2007-11-03 20:11:40 UTC
Created attachment 49395 [details]
test cases for quicktime implementation
Comment 9 msicotte 2007-11-03 20:13:41 UTC
Quicktime implementation done in cws macosxquicktime01
Draft spec and test cases attached to issue.
Comment 10 jogi 2007-11-05 08:41:32 UTC
Note: Specification has been checked in
http://specs.openoffice.org/Mac_Port/System_Integration/macosx_quicktime.odt or 
CVS specs.openoffice.org/Mac_Port/System_Integration/macosx_quicktime.odt
Comment 11 jogi 2007-11-05 08:42:41 UTC
Target milestone is AFAIK 2.4 so I changed the target. Writing feature
announcement, including test case into the TCS system.
Comment 12 jogi 2007-11-05 09:21:02 UTC
Test case specification has been imported in test case specification system in
qa.openoffice.org; link will be updated soon in software specification.
Comment 14 philipp.lohmann 2007-11-07 12:23:03 UTC
fixed
Comment 15 philipp.lohmann 2007-11-07 12:23:47 UTC
please verify in CWS macosxquicktime01
Comment 16 jogi 2007-11-09 12:41:42 UTC
-> tm, as discussed
Comment 17 jogi 2007-11-23 08:37:05 UTC
@msicotte: "A media item embedded in a Writer document cannot be played." do you
have an issue number for it? Or should I write one?
Comment 18 msicotte 2007-11-23 13:36:33 UTC
@jsi - This is handled in issue 83183
http://qa.openoffice.org/issues/show_bug.cgi?id=83183  

The fix is in aw054
Comment 19 philipp.lohmann 2007-11-28 17:30:10 UTC
*** Issue 81276 has been marked as a duplicate of this issue. ***
Comment 20 thorsten.martens 2007-12-03 08:31:36 UTC
Checked and verified in cws macosxquicktime01
Comment 21 thorsten.martens 2009-05-04 09:44:12 UTC
closed