Issue 82071

Summary: Flaws in print logic
Product: Calc Reporter: deaconctk <cnospam>
Component: printingAssignee: frank
Status: CLOSED DUPLICATE QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: andre.schnabel, caiot1, carsten.driesner, frank.loehmann, issues, kyoshida, niklas.nebel, ralph, rb.henschel, thomas.benisch
Version: OOo 2.3Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---
Attachments:
Description Flags
testcasespecification none

Description deaconctk 2007-09-28 18:02:35 UTC
From the 2.3.0 release notes:

The default values for the following print options in Calc have been changed: -
Print only selected sheets (property AllSheets) - Suppress output of empty pages
(property EmptyPages) By default those options are now enabled. In addition, if
the 'Print only selected sheets' option is enabled, the Calc page preview prints
only the displayed sheet. Furthermore a warning box with the message 'There is
nothing to print. The selected print range or sheet is empty.' is shown, if
nothing is printed, e.g. if the document, selected sheet or print range is empty.

This is not entirely accurate:

1) Page preview always shows all sheets regardless of whether "Print only
selected sheets" is checked or not.

2) When printing, if you have a simple two sheet / one page per sheet document,
the pages field of the Print dialog will be pre-filled with "1-2" regardless of
whether "Print only selected sheets" is checked.

3) In the above case, if "Print only selected sheets" is checked (which is the
new default) and you choose to print only page 2, nothing will be sent to the
printer and no warning is displayed.

I am seeing the same symptoms with OOo 2.3.0 under both Windows and Linux.
Comment 1 Regina Henschel 2007-09-28 19:20:10 UTC
I can confirm all three points, WinXP Home.
Whether (1) is an error, I don't know, because it is a page view not a print
preview. (2) and (3) I consider a defect.
Comment 2 ralphie 2007-09-29 16:54:48 UTC
I can confirm this on Linux Gnome too. With 3) I get "Error while Printing"

http://www.pangea.at/%7eralph/oo23-error-while-printing.png

which is not very helpful at all.

Also the shape of the print options dialog has a very strange layout
with its wide shape and all the empty space in the lower half. Probably
will file a low priority bug about that.
Comment 3 ralphie 2007-09-29 17:24:24 UTC
This is a duplicate of <a
href=http://www.openoffice.org/issues/show_bug.cgi?id=69576>#69576</a>,
the strange shape of the options dialog is <a
href=http://www.openoffice.org/issues/show_bug.cgi?id=80588>#80588</a>.
Comment 4 deaconctk 2007-09-29 19:59:34 UTC
It does look like issue 69576 is related to point (3), however, that issue does
not address the concerns raised in points (1) and (2).
Comment 5 frank 2007-10-15 14:13:29 UTC
Hi,

I think most if not all points are covered now by Issue 69576.

Frank do you agree ?

If so please close as double otherwise proceed as needed.

Frank
Comment 6 frank.loehmann 2007-10-15 14:42:54 UTC
I think yes, but I also read an issue that printing "fails" in 2.3 but worked in
2.2.1 with activated option "Selected Tables only". (see i82016)

I have started some investigation today, if we can change the Print dialog to
cover range and selection directly in the print dialog. Will give an update
about that later this week. Hope that we can set target to 2.4.
Comment 7 frank.loehmann 2007-10-16 16:38:24 UTC
Spec (currently an early draft) can be found here:
http://specs.openoffice.org/appwide/printing/Print_Dialog.odt

Feedback welcome.
Comment 8 frank.loehmann 2007-11-01 09:49:42 UTC
FL->PB: Spec has been finalized. This issue is important for Calc so please
check if this can be integrated for OOo 2.4. Thank you!
Comment 9 frank.loehmann 2007-11-01 09:59:07 UTC
Add cc.
Comment 10 pb 2007-11-01 16:47:11 UTC
pb: we give it a try for 2.4.
Comment 11 pb 2007-11-12 08:17:13 UTC
pb: started.
Comment 12 thomas.benisch 2007-11-12 09:08:40 UTC
All calc specific code changes done.
Comment 13 pb 2007-11-12 10:06:43 UTC
pb: Fixed in cws calcprintdlg.
Files changed:
/svtools/inc/svtools/printdlg.hxx 1.2.194.3
/svtools/source/dialogs/printdlg.cxx 1.28.44.3
/svtools/source/dialogs/printdlg.hrc 1.6.118.1
/svtools/source/dialogs/printdlg.src 1.46.180.2
/svtools/workben/svdem.cxx 1.11.118.1
/sfx2/source/view/viewprn.cxx 1.30.52.4
/sd/source/ui/view/PrintManager.cxx 1.18.46.1
/sc/source/core/data/documen8.cxx 1.49.92.2
/sc/source/ui/docshell/docsh4.cxx 1.56.110.2
/sc/source/ui/view/prevwsh.cxx 1.38.48.3
/sc/source/ui/view/tabvwsh4.cxx 1.68.108.3
/sc/source/ui/optdlg/tpprint.cxx 1.7.174.2
/sc/source/ui/unoobj/confuno.cxx 1.27.110.1
/sw/source/ui/uiview/viewprt.cxx 1.36.72.1
Comment 14 pb 2007-11-13 11:38:17 UTC
pb -> fst: please verify, thx.
Comment 15 pb 2007-11-13 11:40:05 UTC
.
Comment 16 frank 2007-11-21 09:29:03 UTC
found fixed according to the Spec on cws calcprintdlg.
Comment 17 frank 2007-11-21 10:56:52 UTC
Created attachment 49787 [details]
testcasespecification
Comment 18 frank 2007-12-05 16:32:19 UTC
*** Issue 84273 has been marked as a duplicate of this issue. ***
Comment 19 frank 2007-12-14 13:10:23 UTC
found integrated on master m239 using Linux, Solaris and Windows build
Comment 20 andreschnabel 2008-06-07 18:00:35 UTC
reopened

it is correct, that the Print-Dialog Spec has been implemented. Unforunatly this
does not change the behaviour that has been reported with this issue. Torepeat
the claims:

1) Page preview always shows all sheets regardless of whether "Print only
selected sheets" is checked or not.

2) When printing, if you have a simple two sheet / one page per sheet document,
the pages field of the Print dialog will be pre-filled with "1-2" regardless of
whether "Print only selected sheets" is checked.

3) In the above case, if "Print only selected sheets" is checked (which is the
new default) and you choose to print only page 2, nothing will be sent to the
printer and no warning is displayed.
Comment 21 frank 2008-06-09 08:42:13 UTC
Hi Frank,

please have a look at this one.

Frank
Comment 22 frank.loehmann 2008-06-10 14:12:40 UTC
The current page preview should become a real print preview in the future. This
print preview should show exactly what will be printed when the user will hit
the print button.

Furthermore the print scaling feature, only available in the Page dialog today,
is being implemented as a slider (88521) on a toolbar of the page preview mode.
Therefore we need to show more than one page at a time in future versions, to
get a better impression how the sheets will be printed.

I guess that we already have an issue regarding the missing (real) print preview
in Calc. So maybe it is abetter idea to use that issue instead of this reopened one.
FL->FST: Do we have an appropriate issue regarding the missing print preview or
do we have to use this one?
Comment 23 frank 2008-06-10 15:18:32 UTC
double to Issue 22762 even if the title of this Issue named it preview for
selection. It's the same root cause and the same fix.

Frank

*** This issue has been marked as a duplicate of 22762 ***
Comment 24 frank 2008-06-10 15:18:57 UTC
closed double