Issue 75519

Summary: 'private:stream' & 'URL seems to be an unsupported one' exception
Product: General Reporter: mvance <vance>
Component: codeAssignee: andreas.schluens
Status: CLOSED DUPLICATE QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: issues, Mathias_Bauer, mirko
Version: OOo 2.2 RC3Keywords: needmoreinfo
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---
Attachments:
Description Flags
Java code that connects to OOo and loads a document
none
Sample .odt file
none
Sample .doc file none

Description mvance 2007-03-19 12:30:20 UTC
The issue happens while delivering Open Office 2.2 0. a stream of document 
from java program using UNO. Software works ok with previous stable versions of 
Open Office. 
Iterface function 

   XComponent xComp = xcomponentloader.loadComponentFromURL(
     PRIVATE_STREAM, "_blank", 0, props);

where PRIVATE_STREAM is

    private static final String PRIVATE_STREAM = "private:stream";

raises exception 

     com.sun.star.lang.IllegalArgumentException: URL seems to be an unsupported 
one.

seems like it doesn't accept "private:stream" parameter.
Comment 1 Mathias_Bauer 2007-03-22 10:48:13 UTC
Did you provide an XInputStream in the properties with the name "InputStream"?
And is this stream seekable (means: does it support XSeekable)?
Does it work if you use "private:stream/"?
Comment 2 thorsten.martens 2007-04-17 15:07:47 UTC
TM->mvance: please provide requested additional further information. Thanks !
Comment 3 yezhi 2007-04-26 15:58:51 UTC
I've provided an XInputStream and XSeekable in the properties with the name
"InputStream".
Also i tried "private:stream/". Result the same.

wuindows XP with Service Pack 2. OOo 2.2.0.

stack trace:

com.sun.star.lang.IllegalArgumentException: URL seems to be an unsupported one.
	at
com.sun.star.lib.uno.environments.remote.Job.remoteUnoRequestRaisedException(Job.java:187)
	at com.sun.star.lib.uno.environments.remote.Job.execute(Job.java:153)
	at com.sun.star.lib.uno.environments.remote.JobQueue.enter(JobQueue.java:349)
	at com.sun.star.lib.uno.environments.remote.JobQueue.enter(JobQueue.java:318)
	at
com.sun.star.lib.uno.environments.remote.JavaThreadPool.enter(JavaThreadPool.java:106)
	at
com.sun.star.lib.uno.bridges.java_remote.java_remote_bridge.sendRequest(java_remote_bridge.java:657)
	at
com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.request(ProxyFactory.java:159)
	at
com.sun.star.lib.uno.bridges.java_remote.ProxyFactory$Handler.invoke(ProxyFactory.java:141)
	at $Proxy4.loadComponentFromURL(Unknown Source)
Comment 4 mnasato 2007-04-27 17:46:40 UTC
Users of JODConverter have also reported the same problem with OOo 2.2.

It seems to happen only with a few document types: .doc, .rtf, .xls.  All the
others (including all the OpenDocument types and oddly .ppt) still work fine as
with previous OOo version.

I'll provide you with some Java code to reproduce the problem as soon as I have
the time.
Comment 5 mnasato 2007-04-29 13:53:00 UTC
Created attachment 44761 [details]
Java code that connects to OOo and loads a document
Comment 6 mnasato 2007-04-29 14:05:40 UTC
The attached DocumentLoader.java requires juh.jar jurt.jar ridl.jar and
unoil.jar from OOo, plus commons-io 1.3.1
(http://jakarta.apache.org/commons/io/) in the CLASSPATH.

Once compiled, it can be used to programmatically load a document in OOo with
the special "private:stream" URL as follows

 1. start OOo in listening mode with
   soffice -accept="socket,port=8100;urp;"
 2. load a document with e.g.
   java issue75519.DocumentLoader test.doc

With OOo 2.2 downloaded from OpenOffice.org on Linux (Ubuntu 7.04) and the
attached documents I get:
 * the .odt file can be loaded successfully
 * the .doc file results in the mentioned IllegalArgumentException

However - this is getting interesting - the problem only seem to affect the OOo
build downloaded from OpenOffice.org. The packages provided by Ubuntu work fine
- as did older OOo versions.
Comment 7 mnasato 2007-04-29 14:07:06 UTC
Created attachment 44762 [details]
Sample .odt file
Comment 8 mnasato 2007-04-29 14:07:43 UTC
Created attachment 44763 [details]
Sample .doc file
Comment 9 thorsten.martens 2007-06-12 13:35:39 UTC
TM->MBA: please have a look again. Thanks in advance !
Comment 10 Mathias_Bauer 2007-06-21 14:42:58 UTC
Andreas, please take over
Comment 11 mnasato 2007-06-21 15:05:49 UTC
Same behaviour with OOo 2.2.1.
Comment 12 andreas.schluens 2007-06-26 10:39:06 UTC
*** Issue 77454 has been marked as a duplicate of this issue. ***
Comment 13 andreas.schluens 2007-06-26 10:41:04 UTC
duplicate to issue #i75191#

*** This issue has been marked as a duplicate of 75191 ***
Comment 14 andreas.schluens 2007-06-26 10:41:29 UTC
.