Issue 64752

Summary: filled net chart (filled radar)
Product: General Reporter: harobed <stephane>
Component: chartAssignee: kla <thomas.klarhoefer>
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: IngridvdM, issues, lars_o_hansen, weizhao
Version: OOo 3.3 or olderKeywords: ms_interoperability, rfe_eval_ok
Target Milestone: ---   
Hardware: All   
OS: All   
URL: http://specs.openoffice.org/chart/wizards/ChartWizard.odt
Issue Type: FEATURE Latest Confirmation on: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 72764    
Attachments:
Description Flags
Radar chart example
none
example for a filled net chart
none
patch_20090520
none
Testcasespec for Filled Net Chart none

Description harobed 2006-04-25 15:46:26 UTC
I would like set background color to each fields in radar chart.
Comment 1 lars 2006-04-25 18:12:34 UTC
if you mean a pie chart this is possible: simply double click the pie, select 
Area from the tabs at the top and choose your background color (Fill->Color).
Comment 2 harobed 2006-04-25 21:26:40 UTC
Created attachment 36036 [details]
Radar chart example
Comment 3 harobed 2006-04-25 21:27:56 UTC
I mean radar chart like this :
http://www.openoffice.org/nonav/issues/showattachment.cgi/36036/radar_chart.png

In this example, I can't set fields backgrounds.
Comment 4 lars 2006-04-25 21:38:18 UTC
you cannot set the background color for each field (=quarter?) as far as I can 
see, true, only for the whole background this is possible. I confirm the issue.
Comment 5 kla 2006-04-26 09:40:15 UTC
@Iha: maybe a good idea. 
Comment 6 IngridvdM 2006-04-26 11:59:52 UTC
I assume that you mean a filled net chart, similar to the area chart type. Yes
that is a missing charttype.
Comment 7 IngridvdM 2006-04-26 12:03:10 UTC
Created attachment 36046 [details]
example for a filled net chart
Comment 8 IngridvdM 2007-01-02 13:08:07 UTC
*** Issue 72665 has been marked as a duplicate of this issue. ***
Comment 9 IngridvdM 2008-07-22 14:20:55 UTC
reset to new
Comment 10 IngridvdM 2009-04-21 10:12:55 UTC
@weiz, please implement the additional chart type 'filled net chart'.
Comment 11 IngridvdM 2009-04-21 11:57:04 UTC
@weiz, the ODF file format specifies that the string 'filled-radar' needs to be
used to classify this chart type. Search in module xmloff for 'radar' to find
the relevant places where this is implemented for the not filled net chart already.
Comment 12 IngridvdM 2009-05-18 10:26:39 UTC
For this chart type it will be necessary to change the z-oder of axis lines and
series - the axis line should be displayed above the series. The z-order of the
shapes is influenced by their creation order - new shapes are created on top. It
is also possible to change the order later but that is not the principle used
during chart view creation.
Look at the method VCoordinateSystem::initPlottingTargets. Here are two group
shapes created m_xLogicTargetForGrids and m_xLogicTargetForAxes. The group shape
for the grids is created first. This ensures that all the grid lines are behind
the axis lines. What we need now is a third group xLogicTargetForSeries that is
created between the grid and axis group shape. This new group then could be
returned by method initPlottingTargets and then be used instead of
xCoordinateRegionTarget as input for pSeriesPlotter->initPlotter( xSeriesTarget,
...) within ChartView.cxx.
Comment 13 weiz 2009-05-20 07:26:40 UTC
Created attachment 62389 [details]
patch_20090520
Comment 14 weiz 2009-05-20 07:28:35 UTC
@iha, the patch is submitted, please let me know your suggestions. :-)
Thank you!
Comment 15 IngridvdM 2009-05-22 13:59:01 UTC
@weiz, thanks a lot for the patch! :-)
I will look at it next week. Have a nice weekend!
Comment 16 IngridvdM 2009-05-29 17:55:22 UTC
@weiz, the patch looks good already! :-) Only in xmloff the token string must be
'filled-radar' and not 'filled_radar'. This is important as it is specified
within the ODF fileformat. At other places I will rename 'radar' to 'net', as we
use 'net' in the user interface and within the UNO API already for the other
net-sub-types. For further details see my mail.
I will ask Stella for new icons. I take over to make the necessary changes
within the specifications and coordinate with QA in which CWS to fix this best.
Thanks a lot again!
Comment 17 IngridvdM 2009-06-03 19:12:32 UTC
I added the new type to the wizard specification:
http://specs.openoffice.org/chart/wizards/ChartWizard.odt

Furthermore the data label positions needed a change. They should be placed 'outer'.
Specification is also updated:
http://specs.openoffice.org/chart/ChartDataLabels.odt
Comment 18 IngridvdM 2009-06-08 09:36:03 UTC
I found that while saving to ODF the chart:class attribute is
'chart:filled-radar' only at the element <chart:chart> but still is
'chart:radar' at the <chart:series>. This is wrong. To fix that I created a new
chart type service '"com.sun.star.chart2.FilledNetChartType" separated from
service "com.sun.star.chart2.NetChartType".
Comment 19 IngridvdM 2009-06-12 12:02:36 UTC
Fixed in CWS fillednetchart.
Filter will be implemented with issue 102677.
Comment 20 IngridvdM 2009-07-22 17:08:16 UTC
@Thomas, please verify in CWS fillednetchart.
Comment 21 kla 2009-08-17 09:41:23 UTC
Created attachment 64204 [details]
Testcasespec for Filled Net Chart
Comment 22 kla 2009-08-17 09:42:47 UTC
verified
Comment 23 kla 2009-09-30 11:03:23 UTC
Seen ok  in current master -> closed