Issue 42737

Summary: PPT Import: old presentation api should not be used when importing presentation effects
Product: Impress Reporter: sven.jacobi
Component: codeAssignee: christian.guenther
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: issues
Version: 680m78   
Target Milestone: OOo 2.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---

Description sven.jacobi 2005-02-14 13:31:26 UTC
PPT Import: it is not possible to fully benefit from new presentation core
features when using the old presentation api, so we should switch to the new one
if importing.

The old presentation api is used if importing ppt 97 documents only, ppt 2000
and newer documents are smil based and can be loaded properly.

Due to the fact that the old presentation api does not comply to the quality we
had before providing the new presentation core, this issue will be received by
the user as defect instead of an enhancement.

- each old ppt effect should be represented as new smil effect 
- we should benefit from the new presentation core and try to support at least
the "after effect"
Comment 1 IngridvdM 2005-02-14 15:46:31 UTC
I will have a look.
Comment 2 sven.jacobi 2005-02-14 18:16:14 UTC
*** Issue 39242 has been marked as a duplicate of this issue. ***
Comment 3 IngridvdM 2005-03-11 20:24:18 UTC
Fixed in CWS effectmigration01.
Comment 4 IngridvdM 2005-03-21 17:37:50 UTC
reopen for reassign
Comment 5 IngridvdM 2005-03-21 17:38:17 UTC
reopen for reassign
Comment 6 IngridvdM 2005-03-21 18:00:45 UTC
->CGU: You can verify this in CWS efffectmigration01.
The import of PP97 animations was completly rewritten, so please test all PP97
animations with different parameters also. Test docs are on tausch.
We are now in addition able to import the following effects:
'spirale', 'zoom in from center', 'zoom out from screen border', 'slightly zoom
in' and 'slightly zoom out'.
The 'blink'-effect is corrected also.
The text effects are now able to do 'paragraph grouping', 'word by word' and
'letter by letter'.
Known issues:
Issue 45098: The after effects has a timing problem with changing color.
Issue 44509:  Text effects + 'all at once' + 'animate without form'  does not
work correctly. The form is always animated.
Issue 44515:  The last word is missing if text is animated 'word by word'.

Please make sure that the import of interactions from PP97 is not broken by this
fix.
Please do write separat issues if single problems occur. Thanks.
Comment 7 IngridvdM 2005-03-21 18:01:12 UTC
fixed
Comment 8 christian.guenther 2005-03-24 17:34:23 UTC
Verified in cws effectmigration01
Comment 9 christian.guenther 2005-04-19 17:29:09 UTC
Verified in src680m93