Issue 40372

Summary: Send Document as E-Mail tries to save the document again and therefore would detach all signatures
Product: General Reporter: frank
Component: uiAssignee: frank
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: issues, jogi
Version: 680m71   
Target Milestone: OOo 2.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---

Description frank 2005-01-11 13:27:12 UTC
Open a signed document and choose Send - Document as E-Mail from the File menu.
You get a warning about saving would remove all signatures. 
This isn't intuitive behaviour and makes this feature useless for Signed Documents.
Comment 1 malte_timmermann 2005-01-19 10:46:36 UTC
MAV?
Comment 2 mikhail.voytenko 2005-01-19 13:15:42 UTC
Any document storing removes signatures. Thus sending of a document as E-Mail
without loss of signature is possible only in case the document is not modified.

MAV->CD: If I am not wrong you have implemented the "Send Document As E-Mail"
feature. The dialog regarding storing of the document ( and the storing itself )
should take place only in case the document is modified. In case the document is
not changed the temporary representation should be created by copying of the
document stream.
Comment 3 carsten.driesner 2005-01-20 12:24:48 UTC
.
Comment 4 frank 2005-01-21 09:38:55 UTC
*** Issue 41064 has been marked as a duplicate of this issue. ***
Comment 5 carsten.driesner 2005-01-28 14:35:15 UTC
CD: Now we make a copy of the storage to preserve the digital signature.
Comment 6 carsten.driesner 2005-02-21 09:37:25 UTC
cd->fst: Please verify.

re-open issue and try to reassign to fst@openoffice.org
Comment 7 carsten.driesner 2005-02-21 09:37:40 UTC
try to reassign to fst@openoffice.org
Comment 8 carsten.driesner 2005-02-21 09:37:45 UTC
try to reset resolution to FIXED
Comment 9 frank 2005-03-14 14:09:13 UTC
found fixed on cws fwkpostbeta1
Comment 10 frank 2005-04-01 13:28:14 UTC
found integrated on master src680m90 using Solaris, Linux and Windows build