Issue 36335

Summary: Add Java Xalan 2.6 to the Office for XSL transformation
Product: xml Reporter: svante.schubert
Component: codeAssignee: oc
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: issues, rene
Version: OOo 1.0.0   
Target Milestone: OOo 2.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---
Issue Depends on: 36351    
Issue Blocks: 34703    

Description svante.schubert 2004-10-29 11:26:57 UTC
Adding three JARs (xalan.jar, xercesImpl.jar, xml-apis.jar) of the Xalan
distribution and adding Java calling parameter '-Xbootclasspath/p:', to assure
that they will be used even a JRE/JDK 1.4 with older Xalan is install.
Comment 1 svante.schubert 2004-10-29 14:54:21 UTC
Added the dependency to a release engineer task.

Further deliberations:
Xalan is not only needed to be integrated to the Office, but for potential
regression testing during build time as well.
The Java startup parameter '-Xbootclasspath/p:' will not be used, as it can not
be evaluated how exisiting and future Java implementations will react, as it is
not even specified to be keept for SUN's Java.

Comment 2 svante.schubert 2004-11-05 20:55:07 UTC
What has been done:
New modul Xalan has been added to build environment, and hosted by Collab.
The task for module alias, necessary before the CWS will be integrated has been
fixed (the cmp. 36351). 
A build dependency to the filter project has been added (via build.lst).
The module contains three JARs (xalan.jar, xercesImpl.jar, xml-apis.jar), which
will be copied during delivery to solver and integrated in program/classes.
As javarc/ini is removed, the using component XSLTFilter.jar has a changed
manifest entry, which loads the three jars on demand of the component 
(i.e. 'Class-Path: xalan.jar xercesImp.jar xml-apis.jar').
Comment 3 svante.schubert 2004-11-05 20:55:39 UTC
fixed
Comment 4 svante.schubert 2004-11-05 21:09:13 UTC
Although it is flagged as 'DEFECT' a feature mail will follow and a discussion
about removing the old JAVA XSLT parser / processor will be started before
integration.
Comment 5 svante.schubert 2004-11-09 13:36:30 UTC
reopen to exchange owner
Comment 6 svante.schubert 2004-11-09 13:37:45 UTC
SUS->OC: 
Reassign to you as JSI may not test in time.
Comment 7 svante.schubert 2004-11-09 13:38:29 UTC
reset to fixed
Comment 8 oc 2004-11-16 09:57:56 UTC
verified in internal build cws_xsltfilter04
Comment 9 oc 2004-11-29 15:37:00 UTC
closed because fix available in OOo1.9m63