Issue 36092

Summary: mozilla addressbook doesn't work on linux with libstdc++-3.4.xxx
Product: Base Reporter: marc.neumann
Component: codeAssignee: wind.li
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P2 CC: frank.schoenheit, issues, nesshof, openoffice, pavel
Version: 680m57   
Target Milestone: OOo 2.0   
Hardware: All   
OS: Linux   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---
Issue Depends on: 11424    
Issue Blocks:    

Description marc.neumann 2004-10-25 13:57:49 UTC
the library libmozabdrv2.so is linked against libstdc++.so.5 , but this library
isn't availabel on a linux system with installed libstdc++-3.4.xxx. So the
addressbook doesn't work.
Comment 1 Frank Schönheit 2004-10-25 14:36:44 UTC
FS->MH: According to SB, we're planning to ship a libstdc++.so.5 for
compatibility reasons, anyway - which is your task, AFAIK. After our
installation contains this version, this bug here should be pointless, shouldn't it?
Comment 2 Martin Hollmichel 2004-11-05 18:52:29 UTC
there are no plans for OOo to deliver older libstdc++ for compatibity reasons.
Comment 3 Frank Schönheit 2004-11-08 09:46:32 UTC
fs->windly: This means we would need to build the mozilla libs with gcc 3.4.
Which does make sense, since, as long as issue 11424 is not checked in, the rule
is that the moz libs and our OOo build are built with the same compiler.
Currently, OOo is with gcc 3.4 (unxlngi6), while the moz libs seem to be with
gcc 3.3.

Could you please re-compile the Linux moz libs gcc 3.4, and check in the new
tarballs in a CWS of your choice? Thanks :)
Comment 4 wind.li 2004-11-08 09:54:43 UTC
What is the time deadline? Now? Or later?
Comment 5 Frank Schönheit 2004-11-08 09:58:07 UTC
Man, you're fast :)
Well, 2.0. We're close to Beta, so the earlier, the better, but whatever it
takes ... How long to you think would you need?
Comment 6 wind.li 2004-11-08 10:10:32 UTC
1 day or more. Since we have not build any thing in Beijing using gcc3.4. I need
setup up a env. And after build I need build an installset to test it. So if we
are lucky I can finished it in one day or less. But I don't know.
Comment 7 wind.li 2004-11-09 09:57:02 UTC
will be fixed in CWS dba19
Comment 8 wind.li 2004-11-09 09:58:02 UTC
reopen to reasign
Comment 9 wind.li 2004-11-09 10:04:08 UTC
reasign to QA
Comment 10 marc.neumann 2004-11-12 10:23:37 UTC
fixed in cws dba19. now libmozabdrv2.so is linked against libstdc++.so.6
Comment 11 marc.neumann 2004-11-12 10:23:58 UTC
verified in cws dba19
Comment 12 hjs 2004-11-23 12:31:00 UTC
.
Comment 13 Martin Hollmichel 2004-11-23 20:30:04 UTC
this issue should be fixed by mozooo cws, commiting binaries to cvs will break
the build since this don't takes care of the used libstdc++ for the build. We
need to be consistent here.
Comment 14 Martin Hollmichel 2004-11-23 20:34:01 UTC
reassign
Comment 15 wind.li 2004-11-24 02:46:14 UTC
Wind->mh
I don't we need do some thing in mozooo cws. If you build mozooo with gcc3.3
then it is linked with libstdc++.so.5, if you build it with gcc3.4 then it will
be linked against libstdc++.so.6. This is depends on your build env. There are
not any hard code in mozooo cws to link with libstdc++.so.5.
Comment 16 Martin Hollmichel 2004-11-24 09:04:28 UTC
mh->windly: yes, exactly, you got it, using the libstdc++ which come with the
used compiler, will fix the issue for all cases. Don't do anyhardcoding here.
Comment 17 wind.li 2004-11-24 09:12:38 UTC
Wind->mh
Can I close this issue now?
Comment 18 Martin Hollmichel 2004-11-24 10:09:25 UTC
mh->windly: no, the build is broken for OOo builds using gcc 3.2 and 3.3 now, I
consider to raise Prio to 1. from my point of view fixing 11424 is the
resolution we agreed on.
Comment 19 Frank Schönheit 2004-11-25 10:09:59 UTC
I strongly disagree. If OOo is built with an older gcc, then this build needs to
disable building the Mozilla AB (there's a configure switch for this). While
this is certainly not really desirable (though in fact already done by a lot of
OOo distributions, it seems), it's an implication of the current architecture of
the AB integration. Yes, this architecture is terrible (and to be solved with
issue 11424), but the fact that not respecting it breaks the build can't be a
P1, IMO.

What I really think is that this issue here is FIXED, any issue that OOo cannot
completely be compiled with an older gcc is either INVALID, or a duplicate of 11424.

In any case, this issue here is only lingering around without *any* concrete
action to take on it, right? But, if nobody needs to take any action on an
issue, then this issue is obsolete.

So, if we want to enforce 11424 to be in the master (and we/me really should),
then let's raise the prio of 11424, but not using placeholder issues like this one.

So, sorry, I'm going to close this issue. It's subjected "mozilla addressbook
doesn't work on linux with libstdc++-3.4.xxx", and that what it is about, and
that what is fixed.
Comment 20 marc.neumann 2005-04-06 14:45:17 UTC
so I really close this issue, as FS explain.