Issue 33027

Summary: Regression: spellchecker always US
Product: General Reporter: zali <mrzali>
Component: wwwAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: issues, lohmaier
Version: 680m49Keywords: oooqa
Target Milestone: OOo 2.0   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation on: ---
Developer Difficulty: ---

Description zali 2004-08-16 10:43:50 UTC
Spellchecker can't be set default into another language. Set the spellchecker
into     your own language, and closed the OpenOffice. Open OpenOffice once
again, the spellchecker will default to US language.
Comment 1 zali 2004-09-29 02:27:28 UTC
Have been fixed on OpenOffice.org 1.1.3rc. Issue closed.
Comment 2 ingenstans 2004-10-14 11:53:22 UTC
Hang on. This is a regression. It works in 1.1.3, but is broken in m_49 

It is still broken in m_56

I'm changing the component to Framework, since that's where the spellchecker 
changes seem to come from.

Comment 3 lohmaier 2004-10-16 12:53:05 UTC
reassigning to default owner.
Comment 4 Mathias_Bauer 2004-10-18 17:40:20 UTC
No, it's not a framework issue, the spellchecker is an own component. Thomas can
you help us?
Comment 5 Mathias_Bauer 2004-10-18 17:43:44 UTC
.
Comment 6 thomas.lange 2004-11-15 10:33:35 UTC
TL->PB: Please have a look thanks.
Comment 7 pb 2004-11-15 10:40:09 UTC
pb: accepted.
Comment 8 pb 2004-11-17 07:39:01 UTC
pb -> lo: the problem: Tools - Options - Language Settings - Languages: if you
change the value of the western default language of documents, the new value
will be saved in linguistic.xcu. But the next office start overwrites this new
setting back to "en-US". It is the method "UserInstall::configureLanguage()"
which sets the value (DefaultLocale). Why?
Comment 9 thomas.lange 2004-11-18 10:27:59 UTC
TL: I discussed with AMA: Since we like this one to be fixed for the Beta an LO
is currently nt available I'll take this one.
Comment 10 thomas.lange 2004-11-18 10:28:18 UTC
.
Comment 11 thomas.lange 2004-11-18 10:46:58 UTC
Fixed in CWS os43.
Files changed:

officecfg:
- registry/schema/org/openoffice/Office/Linguistic.xcs  new revision: 1.18.12.2

svtools:
- source/misc/lingucfg.cxx  new revision: 1.15.104.1

desktop:
- source/app/userinstall.cxx  new revision: 1.13.60.1
Comment 12 thomas.lange 2004-11-18 10:47:55 UTC
.
Comment 13 thomas.lange 2004-11-18 13:20:27 UTC
TL->QA: In asian installation sets the western default language was always set
to en-US and in all other installation sets to the UI language.

Since this bug was introduced in Dec 2003 maybe it should also be fixed in new
product updates for meanwhile released versions.
Comment 14 thomas.lange 2004-11-22 14:23:39 UTC
Waiting for LO to review the fix.
Comment 15 thomas.lange 2004-11-22 14:38:13 UTC
.
Comment 16 thomas.lange 2004-11-22 14:38:41 UTC
.
Comment 17 thomas.lange 2004-11-22 14:38:58 UTC
.
Comment 18 michael.ruess 2004-11-23 11:13:53 UTC
Verified fix in os43.
Comment 19 michael.ruess 2004-12-03 14:16:11 UTC
Checked integration in 680m64.