Issue 27725

Summary: leave edit mode upon protecting sheet
Product: Calc Reporter: e.matthis
Component: uiAssignee: frank
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: issues
Version: 680   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation on: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 72764    
Attachments:
Description Flags
27725.patch
none
27725.patch
none
patch using InputEnterHandler none

Description e.matthis 2004-04-13 11:09:16 UTC
Liz->NN: please add this to the list of such cases in Calc code: Leave edit mode
upon protecting sheet. Thank you!

present scenario: I edit a cell and then protect the sheet before clicking
somewhere else, then I try to save my document. I get an error message saying I
cannot edit a protected cell. I click OK, since there is no other option, and as
a result the document is saved but my data in that cell is lost.
The situation is comparable to saving a document when still in the edit cell
mode, in which case Calc leaves the edit mode before saving.
Comment 1 niklas.nebel 2004-04-13 17:19:49 UTC
accepting.
Comment 2 frank 2004-05-05 10:23:25 UTC
Due to time problems this is re-targeted to OOo2.0
Comment 3 yun_jt 2007-09-10 02:41:40 UTC
Created attachment 48093 [details]
27725.patch
Comment 4 niklas.nebel 2007-09-10 17:59:37 UTC
Please make patches for normal OOo source, without other local changes.

If called while not editing a cell, your change would set the cursor to the cell
that was last edited.
Comment 5 yun_jt 2007-09-12 08:43:08 UTC
Created attachment 48189 [details]
27725.patch
Comment 6 yun_jt 2007-09-13 04:45:19 UTC
Created attachment 48205 [details]
patch using InputEnterHandler
Comment 7 niklas.nebel 2007-09-13 13:57:00 UTC
The patch still doesn't apply to the file's version that's in CVS (what did you
diff against?), but the change itself looks good. I added it to CWS "calc44",
for OOo 2.4.
Comment 8 niklas.nebel 2007-09-18 13:52:04 UTC
Reassigning to QA for verification.
Comment 9 frank 2007-09-26 12:04:06 UTC
found fixed on cws calc44 using Linux, Solaris and Windows build
Comment 10 frank 2007-12-11 15:02:52 UTC
*** Issue 84452 has been marked as a duplicate of this issue. ***
Comment 11 frank 2007-12-11 15:05:20 UTC
found integrated on master m239 using Solaris, Windows and Linux build